Cannot open nvidia-settings on pc with a hybrid device (or use prime-select), missing python

Bug #1721394 reported by Doug McMahon on 2017-10-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nvidia-prime (Ubuntu)
High
Alberto Milone

Bug Description

You would see -
$ nvidia-settings
** Message: PRIME: Requires offloading
** Message: PRIME: is it supported? yes

** (nvidia-settings:1848): ERROR **: PRIME error: Failed to execute child process “/usr/bin/prime-select” (No such file or directory)
Trace/breakpoint trap

Additionally if trying to run prime-select you'd see -
sudo: unable to execute /usr/bin/prime-select: No such file or directory

One would need to go
 python3 /usr/bin/prime-select intel

This is because the python package has been removed from image & isn't installed by either nvidia-settings or nvidia-prime.

Please adjust this packages to either use python3 or dep to python

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: nvidia-settings 367.35-0ubuntu1
ProcVersionSignature: Ubuntu 4.13.0-12.13-generic 4.13.3
Uname: Linux 4.13.0-12-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.7-0ubuntu2
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Wed Oct 4 17:16:44 2017
InstallationDate: Installed on 2017-10-04 (0 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Beta amd64 (20170929)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: nvidia-settings
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
description: updated
summary: - Cannot open nvidia-settings on pc with a hybrid device
+ Cannot open nvidia-settings on pc with a hybrid device (or use prime-
+ select
description: updated
Doug McMahon (mc3man) on 2017-10-04
summary: Cannot open nvidia-settings on pc with a hybrid device (or use prime-
- select
+ select), missing python
Doug McMahon (mc3man) wrote :

going to mark invalid, how this install, (Beta amd64 (20170929) ended up without python-minimal is unknown.
Could have been from bad behavior from unattended-upgrades.
For historical info it had been removed as seen here when I installed python
Commit Log for Wed Oct 4 17:19:48 2017

Installed the following packages:
libpython-stdlib (2.7.14-2ubuntu1)
python (2.7.14-2ubuntu1)
python-minimal (2.7.14-2ubuntu1)
python2.7 (2.7.14-2ubuntu2)
python2.7-minimal (2.7.14-2ubuntu2)

Changed in nvidia-prime (Ubuntu):
status: New → Invalid
Changed in nvidia-settings (Ubuntu):
status: New → Invalid
Jeremy Bicha (jbicha) wrote :

Doug, if the package needs python, then it should be marked as a dependency.

Changed in nvidia-prime (Ubuntu):
status: Invalid → New
Changed in nvidia-settings (Ubuntu):
status: Invalid → New
tags: added: rls-aa-incoming

I wasn't really sure that it really needed the python package, it seems
toneed /usr/bin/python which should have been installed as it's provided by
the python-minimal package.
When nvidia-settings wouldn't start I just installed the python package
which brought in python-minimal, ect.

When I check the manifest for the current image python-minimal is listed.
Maybe I'll try a new install to make sure it is there after installing

On Oct 5, 2017 10:01 PM, "Jeremy Bicha" <email address hidden> wrote:

> Doug, if the package needs python, then it should be marked as a
> dependency.
>
> ** Changed in: nvidia-prime (Ubuntu)
> Status: Invalid => New
>
> ** Changed in: nvidia-settings (Ubuntu)
> Status: Invalid => New
>
> ** Tags added: rls-aa-incoming
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1721394
>
> Title:
> Cannot open nvidia-settings on pc with a hybrid device (or use prime-
> select), missing python
>
> Status in nvidia-prime package in Ubuntu:
> New
> Status in nvidia-settings package in Ubuntu:
> New
>
> Bug description:
> You would see -
> $ nvidia-settings
> ** Message: PRIME: Requires offloading
> ** Message: PRIME: is it supported? yes
>
> ** (nvidia-settings:1848): ERROR **: PRIME error: Failed to execute
> child process “/usr/bin/prime-select” (No such file or directory)
> Trace/breakpoint trap
>
> Additionally if trying to run prime-select you'd see -
> sudo: unable to execute /usr/bin/prime-select: No such file or directory
>
> One would need to go
> python3 /usr/bin/prime-select intel
>
> This is because the python package has been removed from image & isn't
> installed by either nvidia-settings or nvidia-prime.
>
> Please adjust this packages to either use python3 or dep to python
>
> ProblemType: Bug
> DistroRelease: Ubuntu 17.10
> Package: nvidia-settings 367.35-0ubuntu1
> ProcVersionSignature: Ubuntu 4.13.0-12.13-generic 4.13.3
> Uname: Linux 4.13.0-12-generic x86_64
> NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
> ApportVersion: 2.20.7-0ubuntu2
> Architecture: amd64
> CurrentDesktop: ubuntu:GNOME
> Date: Wed Oct 4 17:16:44 2017
> InstallationDate: Installed on 2017-10-04 (0 days ago)
> InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Beta amd64 (20170929)
> ProcEnviron:
> TERM=xterm-256color
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: nvidia-settings
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/nvidia-prime/+
> bug/1721394/+subscriptions
>

Doug McMahon (mc3man) wrote :

Ok, fresh install today's image
1. The manifest say python-minimal is included but it's not installed,
$ apt-cache policy python-minimal
python-minimal:
  Installed: (none)
  Candidate: 2.7.14-2ubuntu1
  Version table:
     2.7.14-2ubuntu1 500
        500 http://us.archive.ubuntu.com/ubuntu artful/main amd64 Packages

2. Also on the manifest but not installed are python2.7 python2.7-minimal

3. Installing nvidia-384 goes fine. If opening nvidia-settings after install but *before* rebooting it actually opens.

4. After rebooting it fails to open as noted in the bug report description.
5. Installing python-minimal or python fixes this or maybe they just need to use python3

Changed in nvidia-prime (Ubuntu):
status: New → Triaged
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-settings (Ubuntu):
status: New → Confirmed
Yuriy Padlyak (gneeot) wrote :

After python-minimal installation and switching to intel the suggested relogin doesn't work. I've tried reboot, but now the setting doesn't start again. This time with a different error:
ERROR: The control display is undefined; please run `nvidia-settings --help`
       for usage information.

Doug McMahon (mc3man) wrote :

On 10/08/2017 05:11 AM, Yuriy Padlyak wrote:
> After python-minimal installation and switching to intel the suggested relogin doesn't work. I've tried reboot, but now the setting doesn't start again. This time with a different error:
> ERROR: The control display is undefined; please run `nvidia-settings --help`
> for usage information.
>
Not sure that has anything to do with  this bug. When switching prime
profiles a restart is required (gdm3 only), that's a separate
longstanding unattended to bug.
https://bugs.launchpad.net/ubuntu/+source/nvidia-prime/+bug/1704781
Maybe something went south for you when trying to do the switch via a
log out?

no longer affects: nvidia-settings (Ubuntu)
Changed in nvidia-prime (Ubuntu):
status: Triaged → In Progress
Changed in nvidia-prime (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-prime - 0.8.5

---------------
nvidia-prime (0.8.5) artful; urgency=medium

  * debian/control, debian/rules, prime-select:
    - Add support for and depend on python 3 (LP: #1721394).

 -- Alberto Milone <email address hidden> Mon, 10 Oct 2017 11:40:53 +0200

Changed in nvidia-prime (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers