nvidia-prime depends upon gdm instead of gdm3

Bug #1582439 reported by Gabriel Devenyi on 2016-05-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
High
Unassigned
nvidia-prime (Ubuntu)
Medium
Alberto Milone
Xenial
Medium
Alberto Milone

Bug Description

https://github.com/tseliot/nvidia-prime/pull/4

[Impact]
- Triaged as High for its impact on Ubuntu GNOME.
- Users who install nvidia-prime currently will get lightdm installed, which triggers a nasty debconf prompt asking them to choose whether to use lightdm or gdm3.
- However, there is no explanation given about what are the advantages or disadvantages of each choice. (For instance, GNOME Shell does not integrate as well with lightdm; I'm guessing Unity has a similar issue with gdm3). Users may easily not know which one is installed by default on their system or which is recommended in their situation.

[Test Case]
1. From Ubuntu GNOME 16.04 LTS, install nividia-prime
2. Is lightdm installed? Are you asked to choose which display manager to use?

[Regression Potential]
None, this simply adds gdm3 as a supported alternative dependency.

[Original Report]
Trying to install nvidia-prime on an ubuntu-gnome system tries to pull in a bunch of unity stuff, because it lists as dependencies:

Depends: lightdm (>= 1.9.1) | gdm | kdm | sddm, bbswitch-dkms, pciutils, lsb-release, lsb-base (>= 4.1+Debian11ubuntu7)

It should depend on gdm3 in addition, since gdm is a transitional package.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: nvidia-prime (not installed)
Uname: Linux 4.5.4-040504-lowlatency x86_64
NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: GNOME
Date: Mon May 16 19:17:25 2016
InstallationDate: Installed on 2016-05-15 (1 days ago)
InstallationMedia: Ubuntu-GNOME 16.04 LTS "Xenial Xerus" - Release amd64 (20160421)
SourcePackage: nvidia-prime
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-prime (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2016-06-28
Changed in nvidia-prime (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in nvidia-prime (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: High → Medium
Jeremy Bicha (jbicha) on 2016-06-28
description: updated
Changed in ubuntu-gnome:
importance: Undecided → High
status: New → Triaged
description: updated
Jeremy Bicha (jbicha) on 2016-06-28
description: updated
Changed in nvidia-prime (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Alberto Milone (albertomilone)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-prime - 0.8.3

---------------
nvidia-prime (0.8.3) yakkety; urgency=medium

  * debian/control:
    - Use gdm3 instead of gdm (LP: #1582439).
      Thanks to Jeremy Bicha for the patch.

 -- Alberto Milone <email address hidden> Thu, 30 Jun 2016 18:16:15 +0200

Changed in nvidia-prime (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers