[systemd] Installing systemd-sysv removes nvidia-prime

Bug #1428849 reported by Bryan Quigley on 2015-03-05
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
nvidia-prime (Ubuntu)
High
Martin Pitt

Bug Description

$ sudo apt-get install systemd-sysv
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  nvidia-prime upstart
The following NEW packages will be installed:
  systemd-sysv
0 upgraded, 1 newly installed, 2 to remove and 0 not upgraded.
Need to get 8,512 B of archives.
After this operation, 463 kB disk space will be freed.
Do you want to continue? [Y/n] n

Docs says if it removes anything else.. yell! (https://wiki.ubuntu.com/SystemdForUpstartUsers#Permanent_switch)

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: nvidia-prime 0.7
ProcVersionSignature: Ubuntu 3.19.0-7.7-generic 3.19.0
Uname: Linux 3.19.0-7-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia
ApportVersion: 2.16.2-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Mar 5 16:01:14 2015
InstallationDate: Installed on 2015-01-08 (55 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20150108)
SourcePackage: nvidia-prime
UpgradeStatus: No upgrade log present (probably fresh install)

Bryan Quigley (bryanquigley) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-prime (Ubuntu):
status: New → Confirmed

Will this prevent the system from working?

When answered, please set this bug status back to "confirmed". Thank you.

Changed in nvidia-prime (Ubuntu):
status: Confirmed → Incomplete
Bryan Quigley (bryanquigley) wrote :

I don't have an nvidia-prime setup, just reporting that it get's removed.

Marcin Sągol (soee) wrote :

If we try to install nvidia-prime when using systemd already we will end up with:

sudo apt-get install nvidia-prime
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-prime : Depends: upstart
E: Unable to correct problems, you have held broken packages.

Changed in nvidia-prime (Ubuntu):
status: Incomplete → Confirmed
Martin Pitt (pitti) on 2015-03-09
Changed in nvidia-prime (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
assignee: nobody → Martin Pitt (pitti)
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-prime - 0.8

---------------
nvidia-prime (0.8) vivid; urgency=medium

  * Drop upstart dependency, previous version added systemd support.
    (LP: #1428849)
 -- Martin Pitt <email address hidden> Mon, 09 Mar 2015 08:43:49 +0100

Changed in nvidia-prime (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers