xorg.conf with manual config is moved away at upgrade

Bug #1345585 reported by Martin Stjernholm on 2014-07-20
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
nvidia-prime (Ubuntu)
Medium
Alberto Milone

Bug Description

I need to configure a couple of options for the nvidia driver, e.g. Coolbits. For this I have /etc/X11/xorg.conf which contains purely my manual configuration. I have found that this file is being renamed xorg.conf.<MMDDYYYY> at irregular intervals, thereby disabling these manual settings.

/var/lib/dpkg/info/nvidia-prime.postrm is very likely what's causing this:

case "$1" in
    purge|remove|upgrade|failed-upgrade|abort-install|abort-upgrade|disappear)
        # Remove the xorg.conf
        if [ -f $xorg_conf ]; then
            mv $xorg_conf $xorg_conf.$now
        fi

Iiuc this is run on every upgrade of the nvidia-prime package. I don't know the reasons for doing this, but given that /etc/X11/xorg.conf is still intended (only) for manual configuration, it should not summarily be moved away. If there's a risk for conflicting old configs then they should be detected more accurately and handled through the normal tools that updates/replaces /etc files containing local changes.

Alex Roman (alex-roman) wrote :

This is happening to me on a regular basis as well, and is annoying. The nvidia driver doesn't recognize the DPI properly and so I am left with VERY LARGE TEXT, so it's easy to recognize when this happens. Every time I have to rename the file back to xorg.conf. I don't understand why packages are touching this file at all. It should be left to the user to configure their X. Especially since Ubuntu doesn't create this file by default, if the user put it there, leave it there.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-prime (Ubuntu):
status: New → Confirmed
Changed in nvidia-prime (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → Medium
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-prime - 0.8.4

---------------
nvidia-prime (0.8.4) yakkety; urgency=medium

  * debian/postrm.in:
    - Do not try to remove the old xorg.conf (LP: #1345585).

 -- Alberto Milone <email address hidden> Mon, 25 Jul 2016 17:54:00 +0200

Changed in nvidia-prime (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers