Optimus: Nvidia Settings asks sudo password to change between Nvidia and Intel card

Bug #1292730 reported by Sergio Benjamim on 2014-03-14
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
nvidia-prime (Ubuntu)
Undecided
Unassigned

Bug Description

Nvidia Settings asks sudo password to change between Nvidia and Intel card.

It should be something trivial, no need to password here... (hey, bumblebee does this without password, and by the way, without something like a button "Performance x Power Saving")

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: nvidia-prime 0.6.1
ProcVersionSignature: Ubuntu 3.13.0-17.37-generic 3.13.6
Uname: Linux 3.13.0-17-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
Date: Fri Mar 14 23:30:02 2014
InstallationDate: Installed on 2014-03-14 (0 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140314)
SourcePackage: nvidia-prime
UpgradeStatus: No upgrade log present (probably fresh install)

Sergio Benjamim (sergio-br2) wrote :
description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1292730

tags: added: package-qa-testing
tags: added: precise
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-prime (Ubuntu):
status: New → Confirmed
Alberto Milone (albertomilone) wrote :

Bumblebee doesn't require a password because it doesn't switch between GPUs. Bbswitch does, and doing so requires root privileges.

Changed in nvidia-prime (Ubuntu):
status: Confirmed → Invalid
Sergio Benjamim (sergio-br2) wrote :

Ok, bbswitch does, but it is unseen by end user (at least, when you use bumblebee, for example).

Is this behavior not unfriendly for user perspective? (and I'm not talking about logout and login after the change...)

Alberto Milone (albertomilone) wrote :

Apparently Bumblebee now uses a daemon which I assume runs with root privileges, hence it doesn't need to request the password. We can probably work around that with policykit.

Sergio Benjamim (sergio-br2) wrote :

Why is it marked as invalid? I'm having problem with this right now...

I can use bumblebee, but i can't anymore switch to nvidia card with this "button solution". And no errors messages...

Changed in nvidia-prime (Ubuntu):
status: Invalid → Confirmed
Aaahh Ahh (woohoomoo2u) wrote :

@Sergio Benjamim
Anyways, that is a diffrenet bug

Changed in nvidia-prime (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers