nvidia-prime multiple monitors not showing up with 0.6

Bug #1290711 reported by Logan Browne on 2014-03-11
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
nvidia-prime (Ubuntu)
High
Alberto Milone

Bug Description

With the conversion to use ubuntu-drivers-common, there is no longer a way to specify a custom xorg configuration with specific options for a hybrid intel/nvidia card setup.

I had multiple monitor support working very well with 0.5 and a custom xorg.template which had the Option "UseDisplayDevice" "none" commented out because my HP Zbook 15 has it's external ports connected to the nvidia card.

The options in the xorg.conf file are now hardcoded into the ubuntu-drivers-common/share/hybrid/gpu-manager.c

It also does appear from the nvidia docs for 331.38 that Option "UseDisplayDevice" "none" is no longer preferred - http://us.download.nvidia.com/XFree86/Linux-x86/331.38/README/randr14.html

Logan Browne (y-logan) wrote :

$ lsb_release -a; uname -a; apt-cache policy nvidia-prime
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu Trusty Tahr (development branch)
Release: 14.04
Codename: trusty
Linux lcb-zbook-15 3.13.0-16-generic #36-Ubuntu SMP Tue Mar 4 23:02:40 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
nvidia-prime:
  Installed: 0.6
  Candidate: 0.6
  Version table:
 *** 0.6 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

tkurmann (tkurmann) wrote :

I have the same issues on my ZBook 15 with nvidia-prime 0.6.
After modifying ubuntu-drivers-common/share/hybrid/gpu-manager.c on line 1225 to
               // " Option \"UseDisplayDevice\" \"none\"\n"
I was able to get an output on DVI, VGA and the internal display, but the system was very unstable (crashing after 1-2 minutes).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-prime (Ubuntu):
status: New → Confirmed
solazs (solazs) wrote :

To summarize it, the problem: the xorg.conf file is now hardcoded in the gpu_manager.c file, thus removing the ability to edit the xorg.conf that gets written to /etc/X11/ when swicthing to nvidia, so people who have an output wired to the nvidia chip can not comment out the line mentioned in comment #2

Alberto Milone (albertomilone) wrote :

I'm going to replace Option "UseDisplayDevice" "none" with Option "AllowEmptyInitialConfiguration" "on".

The gpu-manager will only require that Option "ConstrainCursor" "off" and Option "AllowEmptyInitialConfiguration" "on" are in your xorg.conf.

This will give you access to all the outputs connected to the discrete card.

Changed in nvidia-prime (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High
status: Confirmed → In Progress
Alberto Milone (albertomilone) wrote :

as for the rest, you can add any other option or section to your xorg.conf

Logan Browne (y-logan) wrote :

This is fully fixed in 0.6.1. Thanks so much for the quick work on the change.
---
$ lsb_release -a; uname -a; apt-cache policy nvidia-prime
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu Trusty Tahr (development branch)
Release: 14.04
Codename: trusty
Linux lcb-zbook-15 3.13.0-17-generic #37-Ubuntu SMP Mon Mar 10 21:44:01 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
nvidia-prime:
  Installed: 0.6.1
  Candidate: 0.6.1
  Version table:
 *** 0.6.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

Changed in nvidia-prime (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions