Removing nvidia-prime & nvidia driver packages creates an unusable install

Bug #1257434 reported by Doug McMahon on 2013-12-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-331 (Ubuntu)
High
Alberto Milone
nvidia-graphics-drivers-331-updates (Ubuntu)
High
Alberto Milone
nvidia-prime (Ubuntu)
High
Alberto Milone

Bug Description

Test case:
on a 14.04 install on an optimus laptop
install nvidia driver (331) & nvidia-prime, restart

After restart remove the nvidia driver & nvidia-prime (whether the other packages installed when nvidia driver was installed are also removed doesn't seem matter one way or the other
Restart

What happens here:
Logs into a blank 'Desktop', background + ubuntu 13.10 logo
compiz is running but no OpenGl so no unity, deco, ect. ect.
Enabling OpenGl in ccsm proves futile as it is not loaded & will be again be disabled upon log out/in or restart

Have yet to find any means to recover the install

Alt what happens here: (above is more likely
sometimes never get to the greeter, get the low graphic pop up which is a complete dead end

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: nvidia-prime (not installed)
ProcVersionSignature: Ubuntu 3.12.0-4.12-generic 3.12.1
Uname: Linux 3.12.0-4-generic x86_64
ApportVersion: 2.12.7-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Dec 3 13:51:50 2013
InstallationDate: Installed on 2013-12-01 (2 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20131129)
SourcePackage: nvidia-prime
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
Alberto Milone (albertomilone) wrote :

I would at least need to see the content of your /var/log/lightdm directory and your /var/log/Xorg.0.log to see what's going on.

I'm waiting for LP: #1255583 to be approved before I can upload a new release of nvidia-prime which should be more robust. In the meantime, if you can attach the files that I've requested, maybe I can help and investigate the issue.

Doug McMahon (mc3man) wrote :

here you go, noting this is a new install as I couldn't recover old & needed to test a proposed gtk fix (shouldn't affect this
Same behavior on new install on removing nvidia drivers & nvidia-prime

Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) wrote :
Alberto Milone (albertomilone) wrote :

I don't see anything wrong in the attached logs. Please also attach /var/log/Xorg.0.log and ~/.xsession-errors

If I understand correctly you did reproduce the problem on this new installation, didn't you?

Doug McMahon (mc3man) wrote :

Correct, same problem
i cleared the .cache/upstart/ logs and tried twice to restart, login (exited twice with sudo reboot
The gnome-session log is quite sparse, attached
(looking for an .so that I don't believe is still installed??

Doug McMahon (mc3man) wrote :

same seen here

Doug McMahon (mc3man) wrote :

the Xorg.0 log was attached above, here again

Alberto Milone (albertomilone) wrote :

This line doesn't look good (no wonder Unity doesn't start): /usr/lib/nux/unity_support_test: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

Please attach the output of the following commands:
1) update-alternatives --display x86_64-linux-gnu_gl_conf
2) update-alternatives --display i386-linux-gnu_gl_conf

Doug McMahon (mc3man) wrote :

I got the result of one, was trying to do when logged in so I could C&P but a real hassle as windows open on top of each other, ect.

update-alternatives --display x86_64-linux-gnu_gl_conf
update-alternatives: warning: alternative /usr/lib/nvidia-331-prime/ld.so.conf (part of link group x86_64-linux-gnu_gl_conf) doesn't exist; removing from list of alternatives
x86_64-linux-gnu_gl_conf - auto mode
  link currently points to /usr/lib/nvidia-331-prime/ld.so.conf
/usr/lib/x86_64-linux-gnu/mesa/ld.so.conf - priority 500
  slave x86_64-linux-gnu_xorg_extra_modules: /usr/lib/x86_64-linux-gnu/xorg/x11-extra-modules
Current 'best' version is '/usr/lib/x86_64-linux-gnu/mesa/ld.so.conf'.

Alberto Milone (albertomilone) wrote :

I need to investigate this further but it looks like a bug in the driver package (the nvidia-331-prime alternative was not removed).

If you want to go back to a fully working system, you should do the following:

1) sudo update-alternatives --config x86_64-linux-gnu_gl_conf
2) Select the alternative that contains the word "mesa".
3) type:
sudo ldconfig
sudo update-initramfs -u

You might want to repeat the steps to fix the alternative for i386:
1) sudo update-alternatives --config i386-linux-gnu_gl_conf
Steps 2 and 3 are the same.

Changed in nvidia-prime (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
status: New → Triaged
importance: Undecided → High

On 12/04/2013 01:04 PM, Alberto Milone wrote:
> I need to investigate this further but it looks like a bug in the driver
> package (the nvidia-331-prime alternative was not removed).
>
> If you want to go back to a fully working system, you should do the
> following:
>
> 1) sudo update-alternatives --config x86_64-linux-gnu_gl_conf
> 2) Select the alternative that contains the word "mesa".
> 3) type:
> sudo ldconfig
> sudo update-initramfs -u
>
> You might want to repeat the steps to fix the alternative for i386:
> 1) sudo update-alternatives --config i386-linux-gnu_gl_conf
> Steps 2 and 3 are the same.
>
> ** Changed in: nvidia-prime (Ubuntu)
> Assignee: (unassigned) => Alberto Milone (albertomilone)
>
> ** Changed in: nvidia-prime (Ubuntu)
> Status: New => Triaged
>
> ** Changed in: nvidia-prime (Ubuntu)
> Importance: Undecided => High
>
I believe I checked alternatives the 1st. time this happened & nothing
to do.
See the same with command -

sudo update-alternatives --config x86_64-linux-gnu_gl_conf
[sudo] password for doug:
update-alternatives: warning: /etc/alternatives/x86_64-linux-gnu_gl_conf
is dangling; it will be updated with best choice
There is only one alternative in link group x86_64-linux-gnu_gl_conf
(providing /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf):
/usr/lib/nvidia-331-prime/ld.so.conf
Nothing to configure.

No big deal as I can do a new install in a few minutes time..

Doug McMahon (mc3man) wrote :

(- was able to manually link & fix so all is well, really besides the point, only relaying as I didn't want you to waste any time on 'saving' my install

Changed in nvidia-graphics-drivers-331 (Ubuntu):
status: New → In Progress
Changed in nvidia-graphics-drivers-331-updates (Ubuntu):
status: New → In Progress
Changed in nvidia-graphics-drivers-331 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-331-updates (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-331 (Ubuntu):
importance: Undecided → High
Changed in nvidia-graphics-drivers-331-updates (Ubuntu):
importance: Undecided → High
Changed in nvidia-prime (Ubuntu):
status: Triaged → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-331-updates - 331.20-0ubuntu6

---------------
nvidia-graphics-drivers-331-updates (331.20-0ubuntu6) trusty; urgency=low

  * debian/templates/nvidia-graphics-drivers.prerm.in:
    - Make sure to remove the alternatives for PRIME
      (LP: #1257434).
 -- Alberto Milone <email address hidden> Thu, 05 Dec 2013 08:27:05 +0100

Changed in nvidia-graphics-drivers-331-updates (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-331 - 331.20-0ubuntu6

---------------
nvidia-graphics-drivers-331 (331.20-0ubuntu6) trusty; urgency=low

  * debian/templates/nvidia-graphics-drivers.prerm.in:
    - Make sure to remove the alternatives for PRIME
      (LP: #1257434).
 -- Alberto Milone <email address hidden> Thu, 05 Dec 2013 08:24:34 +0100

Changed in nvidia-graphics-drivers-331 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers