package nvidia-prime 0.4.2~ubuntu13.10.1 failed to install/upgrade: le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1

Bug #1252667 reported by lecole on 2013-11-19
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
nvidia-prime (Ubuntu)
High
Alberto Milone
Precise
High
Alberto Milone

Bug Description

internet

ProblemType: Package
DistroRelease: Ubuntu 13.10
Package: nvidia-prime 0.4.2~ubuntu13.10.1
ProcVersionSignature: Ubuntu 3.11.0-14.21-generic 3.11.7
Uname: Linux 3.11.0-14-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
Date: Tue Nov 19 10:15:42 2013
DuplicateSignature: package:nvidia-prime:0.4.2~ubuntu13.10.1:le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
ErrorMessage: le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
InstallationDate: Installed on 2013-08-17 (93 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: nvidia-prime
Title: package nvidia-prime 0.4.2~ubuntu13.10.1 failed to install/upgrade: le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
UpgradeStatus: Upgraded to saucy on 2013-09-26 (54 days ago)

lecole (chrislecole-u) wrote :
tags: removed: need-duplicate-check
Alberto Milone (albertomilone) wrote :

This should be fixed as per LP: #1219650.

Can you attach the output of the following command, please?
lspci -n

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-prime (Ubuntu):
status: New → Confirmed
Changed in nvidia-prime (Ubuntu):
status: Confirmed → Incomplete
Alberto Milone (albertomilone) wrote :

It looks like bug #1219650, that I fixed.

Please download the attached file and then run it with:

sh test_prime_2014.sh &> prime_output

and then attach the prime_output file.

Alberto Milone (albertomilone) wrote :

the fix wasn't correct. I'll upload a fix soon.

Changed in nvidia-prime (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High
status: Incomplete → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-prime - 0.5.3

---------------
nvidia-prime (0.5.3) trusty; urgency=low

  * debian/postrm.in, debian/rules:
    - Avoid calling dpkg-architecture (LP: #1264611).
  * prime-xconfig:
    - Properly format hexadecimal parameters (LP: #1252667).
 -- Alberto Milone <email address hidden> Fri, 10 Jan 2014 14:41:22 +0100

Changed in nvidia-prime (Ubuntu):
status: In Progress → Fix Released
Changed in nvidia-prime (Ubuntu Precise):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High
status: New → In Progress

Hi
I keep getting error messages about nvidia. And I keep getting your
updates.
Maybe I missed something, but I don't see what I do to fix the problem.
Can you point me in the right direction?
Thanks
Rabin

On 14-01-13 05:32 PM, Alberto Milone wrote:
> ** Also affects: nvidia-prime (Ubuntu Precise)
> Importance: Undecided
> Status: New
>
> ** Changed in: nvidia-prime (Ubuntu Precise)
> Importance: Undecided => High
>
> ** Changed in: nvidia-prime (Ubuntu Precise)
> Status: New => In Progress
>
> ** Changed in: nvidia-prime (Ubuntu Precise)
> Assignee: (unassigned) => Alberto Milone (albertomilone)
>

Hello lecole, or anyone else affected,

Accepted nvidia-prime into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nvidia-prime/0.5~hybrid0.0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nvidia-prime (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Alberto Milone (albertomilone) wrote :

The new nvidia-prime works fine here. The pci address is treated as hexadecimal as expected.

:~$ apt-cache policy nvidia-prime
nvidia-prime:
  Installed: 0.5~hybrid0.0.2
  Candidate: 0.5~hybrid0.0.2
  Version table:
 *** 0.5~hybrid0.0.2 0
        400 http://archive.ubuntu.com/ubuntu/ precise-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     0.4.2~hybrid0.0.1 0
        500 http://it.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages

tags: added: verification-done
removed: verification-needed

I really appreciate the work you've done on this bug.
However, I'm still new to Ubuntu and I don't know how to install this
working update.
Thanks

On 14-01-30 10:45 AM, Alberto Milone wrote:
> The new nvidia-prime works fine here. The pci address is treated as
> hexadecimal as expected.
>
> :~$ apt-cache policy nvidia-prime
> nvidia-prime:
> Installed: 0.5~hybrid0.0.2
> Candidate: 0.5~hybrid0.0.2
> Version table:
> *** 0.5~hybrid0.0.2 0
> 400 http://archive.ubuntu.com/ubuntu/ precise-proposed/main amd64 Packages
> 100 /var/lib/dpkg/status
> 0.4.2~hybrid0.0.1 0
> 500 http://it.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
>
> ** Tags removed: verification-needed
> ** Tags added: verification-done
>

Alberto Milone (albertomilone) wrote :

@Rabin: you might want to follow the instructions:
https://wiki.ubuntu.com/Testing/EnableProposed

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-prime - 0.5~hybrid0.0.2

---------------
nvidia-prime (0.5~hybrid0.0.2) precise-proposed; urgency=low

  * debian/control:
    - Add alternative dependency on gdm and kdm.
  * debian/preinst.in:
    - Set the lightdm configuration bits only if lightdm is the
      default display manager (LP: #1262068).
  * debian/postrm.in, debian/rules:
    - Avoid calling dpkg-architecture (LP: #1264611).
  * prime-xconfig:
    - Format hexadecimal parameters properly (LP: #1252667).

nvidia-prime (0.5~hybrid0.0.1) precise-proposed; urgency=low

  * New upstream release:
    - Add support for power management (LP: #1259237).
  * debian/control:
    - Depend on upstart, bbswitch, lsb-release, lightdm >= 1.2.3-0ubuntu2.4,
      screen-resolution-extra (>= 0.14ubuntu2.1).
    - Build only for i386 and amd64.
 -- Alberto Milone <email address hidden> Mon, 13 Jan 2014 16:32:47 +0100

Changed in nvidia-prime (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for nvidia-prime has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Your instructions were faulty. I'm using 13.10 and had to find it on my
own. We'll see if it works now.

On 14-02-02 03:14 AM, Alberto Milone wrote:
> @Rabin: you might want to follow the instructions:
> https://wiki.ubuntu.com/Testing/EnableProposed
>

I have found the problem.
Now is instaling fine. The problem is in post install configurations that are using decimal values in printf that came from hexadecimal.
My patch is in attachment.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers