nvidia prime causes freeze at start up

Bug #1249067 reported by Matt Joiner
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
nvidia-prime (Ubuntu)
High
Alberto Milone

Bug Description

I believe nvidia-prime modified my xorg.conf to use intel during boot. I had to remove xorg.conf to enable my system to boot to unity again. I've attached the file that caused the problem.

My system has onboard intel graphics on the motherboard, and a beefcake nvidia card to which my monitors are connected.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: nvidia-prime 0.4.2~hybrid0.0.1
ProcVersionSignature: Ubuntu 3.8.0-33.48~precise1-generic 3.8.13.11
Uname: Linux 3.8.0-33-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu17.6
Architecture: amd64
Date: Fri Nov 8 06:07:51 2013
InstallationMedia: Ubuntu 12.04.3 LTS "Precise Pangolin" - Release amd64 (20130820.1)
MarkForUpload: True
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, no user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: nvidia-prime
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Matt Joiner (anacrolix) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-prime (Ubuntu):
status: New → Confirmed
Revision history for this message
Alberto Milone (albertomilone) wrote :

Thank you for reporting the problem and sorry for the inconvenience.

nvidia-prime 0.5 will solve this problem thanks to improved hardware detection, so that we enable hybrid graphics only on the systems that we actually support (i.e. laptops). The update will land soon in 12.04 and 14.04.

Changed in nvidia-prime (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High
status: Confirmed → In Progress
Revision history for this message
Matt Joiner (anacrolix) wrote :

Keep up the good work.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-prime - 0.5

---------------
nvidia-prime (0.5) trusty; urgency=low

  * debian/control:
    - Depend on bbswitch-dkms and upstart.
    - Depend on lightdm (>= 1.9.1).
    - Build only for i386 and amd64.
  * debian/install.in:
    - Install the new components.
  * debian/nvidia-prime.upstart:
    - Make sure that NVIDIA is always enabled on shutdown.
      This will avoid issues with the BIOS.
    - Make sure that bbswitch does not disable nvidia when
      loading.
    - Set up xorg.conf on boot.
  * debian/preinst.in:
    - Create a display-stopped-script entry in lightdm.conf.
    - Create /etc/lightdm/hybrid_default.
  * debian/postinst.in:
    - Remove it.
  * debian/postrm.in:
    - Remove /etc/lightdm/hybrid_default on package removal.
    - Remove the display-stopped-script entry from
      lightdm.conf.
    - Restore the non-prime related alternative on removal.
  * New upstream release:
    - Improved hardware detection. The package won't change
      anything if the hardware configuration is not
      supported. We only support laptops with NVIDIA
      optimus hardware and nvidia driver >= 319
      (LP: #1249067).
    - More robust system to deal with xorg.conf. Broken
      xorg.conf files will be automatically restored to
      a configuration that works with hybrid graphics.
      Whether on boot or on log out, we always try to make
      sure that the system is configured correctly.
    - Added prime-select switcher to switch between the
      integrated and the discrete GPU. This allows users
      to disable the discrete GPU to save power. Users'
      settings are now saved and applied on log out and
      on boot.
    - Added a quirk system to pass custom options to the
      bbswitch module (see /etc/prime-quirks).
 -- Alberto Milone <email address hidden> Wed, 04 Dec 2013 16:23:32 +0100

Changed in nvidia-prime (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Anthony Kamau (ak-launchpad) wrote :

This morning (20140205 @ ~8am AEDST) accepted an update on my system (nvidia-prime amongst others). However, I was unable to login afterwards. After prowling my /var/log folder, I came across /var/log/nvidia-prime-upstart.log (attached) which suggested that nvidia-prime was the issue. I was then able to login to my desktop (degraded graphics mode - max res 1024x768) and do a Google search which brougt me here.

Having never manually submitted (I believe my laptop automatically collects info about my laptop before it submits a bug when something crashes) a bug report on Launchpad, please bear with me:

Laptop details:
Manufacturer: Dell Precision M6700
CPU: Intel(R) Core(TM) i7-3840QM CPU @ 2.80GHz
Onboard Video: 00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
Discrete Video: 01:00.0 VGA compatible controller: NVIDIA Corporation GK104GLM [Quadro K3000M] (rev ff)
OS: Ubuntu 12.04.3 LTS
Kernel: 3.9.0-030900-generic (from Saucy Salamanda to fix issues with slow Wifi performance on Ultimate-N 6300 built-in card)

Work-around:
I had to modify /etc/init/nvidia-prime.conf (add 'exit' statement near the top) and cat /dev/null to /etc/X11/xorg.conf in order to get back to full desktop mode.

Please see attachment from out put of apport-cli -f -p nvidia-prime --save bug.apport

Cheers,
ak.

Revision history for this message
Anthony Kamau (ak-launchpad) wrote :

Attaching /var/log/nvidia-prime-upstart.log

Revision history for this message
Alberto Milone (albertomilone) wrote :

it looks like a configuration problem:

"Error: alternatives are not set up properly"

what's the output of the following commands?

1) update-alternatives --display x86_64-linux-gnu_gl_conf
2) update-alternatives --display i386-linux-gnu_gl_conf

Revision history for this message
Anthony Kamau (ak-launchpad) wrote :
Revision history for this message
Anthony Kamau (ak-launchpad) wrote :
Revision history for this message
Anthony Kamau (ak-launchpad) wrote :

According to my apt history log:

Start-Date: 2014-02-05 08:00:40
Commandline: aptdaemon role='role-commit-packages' sender=':1.80'
Upgrade: nvidia-prime:amd64 (0.4.2~hybrid0.0.1, 0.5~hybrid0.0.2), lightdm:amd64 (1.2.3-0ubuntu2.3, 1.2.3-0ubuntu2.4), python-apt:amd64 (0.8.3ubuntu7.1, 0.8.3ubuntu7.2), python-apt-common:amd64 (0.8.3ubuntu7.1, 0.8.3ubuntu7.2), libyaml-0-2:amd64 (0.1.4-2, 0.1.4-2ubuntu0.12.04.1), libcurl3:amd64 (7.22.0-3ubuntu4.6, 7.22.0-3ubuntu4.7), libcurl3:i386 (7.22.0-3ubuntu4.6, 7.22.0-3ubuntu4.7), dkms:amd64 (2.2.0.3-1ubuntu3.1, 2.2.0.3-1ubuntu3.2), libcurl3-nss:amd64 (7.22.0-3ubuntu4.6, 7.22.0-3ubuntu4.7), curl:amd64 (7.22.0-3ubuntu4.6, 7.22.0-3ubuntu4.7), jockey-common:amd64 (0.9.7-0ubuntu7.11, 0.9.7-0ubuntu7.13), jockey-gtk:amd64 (0.9.7-0ubuntu7.11, 0.9.7-0ubuntu7.13), liblightdm-gobject-1-0:amd64 (1.2.3-0ubuntu2.3, 1.2.3-0ubuntu2.4), libcurl3-gnutls:amd64 (7.22.0-3ubuntu4.6, 7.22.0-3ubuntu4.7)
End-Date: 2014-02-05 08:00:52

I did not have any problems when running the nvidia-prime v0.4.2! When I remove the quiet and splash entries from my kernel line in grub.cfg, I hear a beep before the laptop freezes. REISUB doesn't even bring it back to life; only power button for ~5 seconds gets it to shutdown then I can restart!

Cheers,
ak.

Revision history for this message
Alberto Milone (albertomilone) wrote :

ok, please try the following steps:

sudo apt-get --purge remove nvidia-331-updates nvidia-331

sudo apt-get install nvidia-331 nvidia-prime

sudo prime-select nvidia

Then reboot and you should be all set.

Revision history for this message
Alberto Milone (albertomilone) wrote :

you have too many drivers installed.

sudo apt-get --purge remove nvidia-304 nvidia-current

Revision history for this message
Alberto Milone (albertomilone) wrote :

also, please make sure to remove bumblebee

Revision history for this message
Anthony Kamau (ak-launchpad) wrote :

I'm using bumblebee to enable optimus. Is this functionality now built into the Nvidia driver?

Cheers,
ak.

Revision history for this message
Anthony Kamau (ak-launchpad) wrote :

I've just noticed that when I attempt to purge nvidia-331*, systems insists on installing nvidia-304. Why?

# apt-get --purge remove nvidia-331
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  nvidia-304 nvidia-current
The following packages will be REMOVED:
  nvidia-331*
The following NEW packages will be installed:
  nvidia-304 nvidia-current
0 to upgrade, 2 to newly install, 1 to remove and 3 not to upgrade.
Need to get 0 B/68.3 MB of archives.
After this operation, 27.4 MB disk space will be freed.
Do you want to continue [Y/n]?

In any case, I'll rerun the previous commands in addition to also purging bumblebee and if anything fails, maybe it's time to move onto the Salamanda!

Cheers,
ak.

Revision history for this message
Alberto Milone (albertomilone) wrote :

The bumblebee-nvidia package depends on the nvidia-packages.

sudo apt-get --purge remove bumblebee*

sudo apt-get install nvidia-331 nvidia-prime

sudo prime-select nvidia

The nvidia-prime package enables Optimus. There's no need to use bumblebee, unless you prefer to use it (in which case you should remove nvidia-prime)

Revision history for this message
Anthony Kamau (ak-launchpad) wrote :

In the end, I just gave up on nvidia-prime and went back to bumblebee:
https://wiki.ubuntu.com/Bumblebee

Hopefully by the time I'm migrating to the next LTS version, nvidia-prime will be ready for prime time - ;)!

Cheers,
ak.

Revision history for this message
Anthony Kamau (ak-launchpad) wrote :

Let me add that although nvidia-prime maybe working for some, the above statement should really have quantified it more to be specific to my use case:

Dell Precision M6700 w/ Optimus Tech
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GK104GLM [Quadro K3000M] (rev ff)

This combination does not work with nvidia-prime.

Cheers,
ak.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers