xserver wont start after nvidia-prime installation

Bug #1224098 reported by Christian Röser on 2013-09-11
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
nvidia-prime (Ubuntu)
High
Alberto Milone
Precise
High
Alberto Milone
Saucy
High
Alberto Milone

Bug Description

SRU request:

[Impact]

 * As a result of this bug, the lightdm configuration file will always been overwritten. This is not desirabled or expected and causes serious problems on any *buntu system other than Ubuntu.

[Test Case]

 * Enable the precise-proposed or the saucy-proposed repository and install nvidia-prime (0.4.2~hybrid0.0.1 in precise or 0.4.2~hybrid0.1 in saucy).

 * If the package doesn't overwrite the lightdm greeter in the lightdm.conf file, then the fix is correct.

[Regression Potential]

 * The regression potential here should be zero, as we only replace two conditions ( "test -f" and "test ! -s") that can never be true at the same time, with the "test -s" condition which does exactly what we need - it checks that the file exists and has a size greater than zero - and reuse the existing file if this condition is satisfied.

----

I have done a fresh install of saucy, before the installation of nvidia-prime lightdm-gtk-greeter was set in lightdm.conf. During the installation of nvidia-prime the greeter ist changed to unity-greeter which causes a crash and no display after a reboot. When changing the greeter back to lightdm-gtk-greeter everything works fine.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: nvidia-prime 0.4
ProcVersionSignature: Ubuntu 3.11.0-7.13-generic 3.11.0
Uname: Linux 3.11.0-7-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.12.1-0ubuntu3
Architecture: amd64
Date: Wed Sep 11 22:11:06 2013
InstallationDate: Installed on 2013-09-11 (0 days ago)
InstallationMedia: Xubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130902.1)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: nvidia-prime
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-prime (Ubuntu):
status: New → Confirmed
Darius Tumas (tokeiito-m) wrote :

I had same problem in Kubuntu. nvidia-prime chages /etc/lightdm/lightdm.conf greeter parameter to unity-greeter. This change prevents lightdm starting. To fix it i had to change greeter back to lightdm-kde-greeter.

Changed in nvidia-prime (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-prime (Ubuntu Precise):
status: New → Triaged
Changed in nvidia-prime (Ubuntu Saucy):
status: New → Triaged
Changed in nvidia-prime (Ubuntu Precise):
importance: Undecided → High
Changed in nvidia-prime (Ubuntu Saucy):
importance: Undecided → High
Changed in nvidia-prime (Ubuntu Precise):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-prime (Ubuntu Saucy):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-prime (Ubuntu):
status: Triaged → In Progress
Changed in nvidia-prime (Ubuntu Precise):
status: Triaged → In Progress
Changed in nvidia-prime (Ubuntu Saucy):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-prime - 0.4.1

---------------
nvidia-prime (0.4.1) trusty; urgency=low

  * debian/preinst.in:
    - Remove leftover in the test condition. This was
      causing the lightdm.conf file to be rewritten
      every time. This is a serious problem on the
      different Ubuntu flavours (LP: #1224098).
 -- Alberto Milone <email address hidden> Wed, 23 Oct 2013 13:03:55 +0200

Changed in nvidia-prime (Ubuntu):
status: In Progress → Fix Released
Alberto Milone (albertomilone) wrote :

SRU request:

[Impact]

 * As a result of this bug, the lightdm configuration file will always been overwritten. This is not desirabled or expected and causes serious problems on any *buntu system other than Ubuntu.

[Test Case]

 * Enable the precise-proposed or the saucy-proposed repository and install nvidia-prime (0.4.2~hybrid0.0.1 in precise or 0.4.2~hybrid0.1 in saucy).

 * If the package doesn't overwrite the lightdm greeter in the lightdm.conf file, then the fix is correct.

[Regression Potential]

 * The regression potential here should be zero, as we only replace two conditions ( "test -f" and "test ! -s") that can never be true at the same time, with the "test -s" condition which does exactly what we need - it checks that the file exists and has a size greater than zero - and reuse the existing file if this condition is satisfied.

Hi
Thanks for your reply. I'm a complete amateur, I did get my screen working,
I forget exactly how (I'm at work and not near my system) I think I had to
purge the nvidia 319 and go to additional drivers and use Nvidia 3:04.
I still have bugs, but my graphics seem OK.
Rabin
On Oct 23, 2013 11:01 AM, "Alberto Milone" <email address hidden>
wrote:

> SRU request:
>
> [Impact]
>
> * As a result of this bug, the lightdm configuration file will always
> been overwritten. This is not desirabled or expected and causes serious
> problems on any *buntu system other than Ubuntu.
>
> [Test Case]
>
> * Enable the precise-proposed or the saucy-proposed repository and
> install nvidia-prime (0.4.2~hybrid0.0.1 in precise or 0.4.2~hybrid0.1 in
> saucy).
>
> * If the package doesn't overwrite the lightdm greeter in the
> lightdm.conf file, then the fix is correct.
>
>
> [Regression Potential]
>
> * The regression potential here should be zero, as we only replace two
> conditions ( "test -f" and "test ! -s") that can never be true at the
> same time, with the "test -s" condition which does exactly what we need
> - it checks that the file exists and has a size greater than zero - and
> reuse the existing file if this condition is satisfied.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1243460).
> https://bugs.launchpad.net/bugs/1224098
>
> Title:
> xserver wont start after nvidia-prime installation
>
> Status in “nvidia-prime” package in Ubuntu:
> Fix Released
> Status in “nvidia-prime” source package in Precise:
> In Progress
> Status in “nvidia-prime” source package in Saucy:
> In Progress
>
> Bug description:
> I have done a fresh install of saucy, before the installation of
> nvidia-prime lightdm-gtk-greeter was set in lightdm.conf. During the
> installation of nvidia-prime the greeter ist changed to unity-greeter
> which causes a crash and no display after a reboot. When changing the
> greeter back to lightdm-gtk-greeter everything works fine.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.10
> Package: nvidia-prime 0.4
> ProcVersionSignature: Ubuntu 3.11.0-7.13-generic 3.11.0
> Uname: Linux 3.11.0-7-generic x86_64
> NonfreeKernelModules: nvidia
> ApportVersion: 2.12.1-0ubuntu3
> Architecture: amd64
> Date: Wed Sep 11 22:11:06 2013
> InstallationDate: Installed on 2013-09-11 (0 days ago)
> InstallationMedia: Xubuntu 13.10 "Saucy Salamander" - Alpha amd64
> (20130902.1)
> MarkForUpload: True
> PackageArchitecture: all
> SourcePackage: nvidia-prime
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/nvidia-prime/+bug/1224098/+subscriptions
>

Hello Christian, or anyone else affected,

Accepted nvidia-prime into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nvidia-prime/0.4.2~hybrid0.0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nvidia-prime (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
description: updated
Stéphane Graber (stgraber) wrote :

Hello Christian, or anyone else affected,

Accepted nvidia-prime into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nvidia-prime/0.4.2~ubuntu13.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nvidia-prime (Ubuntu Saucy):
status: In Progress → Fix Committed
Dave Morley (davmor2) wrote :

Confirmed the proposed version is working nicely on Saucy on an Ideapad y580 hybrid.

Confirming the fix is working for me as well on Lubuntu 13.10 with Asus UX51VZ (with nvidia GT650M).
Thanks a lot!

Miklos Juhasz (mjuhasz) on 2013-10-31
tags: added: verification-done
removed: verification-needed

Doesn't work for me on Lenovo G580 (nVidia 610m)

Alberto Milone (albertomilone) wrote :

@Michał: what happens exactly and what Ubuntu flavour are you using?

Remten (cascasca) wrote :

Not sure whether this is the correct place to post the following -

I have been running lubuntu 13.10.1 with XFCE4.

I wanted to install nvidia-prime, so I decided to try the fix reported here to minimize any problems with nvidia prime. However, after installing the nvidia-prime_0.4.2~ubuntu13.10.1_all.deb, I am no longer able to log into xfce sessions and I can now only use lubuntu sessions.

laptop ASUS N550JV (Intel gpu & GT750M gpu)
Lubuntu 13.10.1 amd64 alternate install
                                        (dual boot encrypted Win 7 & encrypted LVM lubuntu)
Linux version 3.11.0-12-generic
                    (buildd@allspice) (gcc version 4.8.1 (Ubuntu/Linaro 4.8.1-10ubuntu7) )
Architecture: amd64
InstallationDate: Lubuntu Installed on 2013-10-28

Nvidia-319.32 x86_64 installed 2013-11-03

xfce4 4.10.1 metapackage
xfce4-goodies 4.10 metapackage
xbindkeys & xbindkeys-config packages
policykit-1-gnome

How I installed the drivers:
installed nvidia-319 using Synaptic
installed nvidia-settings using Synaptic
downloaded nvidia-prime_0.4.2~ubuntu13.10.1_all.deb
  from ux51vz.blogspot.com/2013/10/install-lubuntu1310-saucy-salamander.html which cited this launchpad bug entry (I think that is a blog post by Sebastien Coquelin, who posted at #10 here)
rebooted

Normal grub2 screen. Normal unlocking of encryption for the LVM.
But when attempt to login to xfce session, screen turns dark black for a couple of sessions, then slightly grey, then dark black again. Have to reboot and choose lubuntu session.

Initially in lubuntu session, multiple error message windows appeared:

The [xfce] panel has closed unexpectedly.
The application desktop [xfce] has closed unexpectedly.
Sorry, the application xbindkeys-config has stopped unexpectedly.
Sorry, Lubuntu 13.10 has experienced an internal error.
Invalid problem report (This problem report is damaged and cannot be processed. Permission error (1,'Operation not permitted')
Permission denied

I removed xbindkeys. On reboot, still couldn't log into xfce sessions.
I removed xfce4 and xfce4-goodies metapackages via Synaptic (marked for complete removal). Then reinstalled.

Still can't log into xfce sessions. Black screen. Have to reboot.
I can log into lubuntu sessions still (and now no longer see the multiple error messages when logging into lubuntu sessions).

nvidia-prime does seem to be working though (or maybe video limits have been removed?) because
- before installed nvidia-319 driver and nvidia-prime, glxspheres gave 60 fps, 67 Mpixels/sec
- after installed nvidia-319 and nvidia-prime, glxspheres gives 1300+ fps, 1500 Mpixels/sec

Alberto Milone (albertomilone) wrote :

@Remten: unfortunately, we only modify the main lightdm configuration file. If you install other Ubuntu flavours after installing nvidia-prime, it might not work.

You can try the following steps:

1) Remove the xubuntu settings package (also pay attention to the other packages that this removes):

sudo apt-get --purge remove xubuntu-default-settings

2) Reinstall xubuntu-default-settings:

sudo apt-get install xubuntu-default-settings

3) Reinstall any packages that were removed when you uninstalled xubuntu-default-settings

4) Make sure that the alternative is set to Xubuntu:

sudo update-alternatives --config lightdm-gtk-greeter-config-derivative

(and select the alternative for Xubuntu)

5) Finally reinstall nvidia-prime:

sudo apt-get install --reinstall nvidia-prime

Remten (cascasca) wrote :

@Alberto: I did not understand your last suggestion. I had not installed the xubuntu-default-settings, so when I tried to remove that, I got an error message.
I had previously tried removing the XFCE4 and XFCE4-goodies metapackages, then reinstalling them, but that didn't help.

I ended up reloading my original Lubuntu-13.10 Saucy installation from backup, then installed, in this order
nvidia-319
nvidia-settings-319
rebooted
nvidia-prime from the Saucy proposed repository via Synaptic
(updated grub)
rebooted
xfce4
xfce4-goodies*
rebooted

logged into xfce session
chose Use default configuration

It worked.
No error messages loading the xfce desktop. Now I can use either lubuntu sessions or xfce4 sessions, and nvidia-prime seems to be working (at least going by glxspheres64).

I'm not sure why it worked this time - I was 100% sure it would fail. But it worked.

(*I had tried the sudo update-alternatives --config lightdm-gtk-greeter-config-derivatives, but I didn't understand what you meant by that command exactly. I got an error message saying no alternatives available.)

Remten (cascasca) wrote :

addendum:

several differences though this time
- did not have xbindkeys installed
- had changed software updater to include proposed versions of software and then ran updater before doing anything else
- downloaded the nvidia-prime from proposed repository instead of from the blog post I previously mentioned

Anyway, thanks for the help. I am very happy.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-prime - 0.4.2~ubuntu13.10.1

---------------
nvidia-prime (0.4.2~ubuntu13.10.1) saucy-proposed; urgency=low

  * debian/preinst.in:
    - Remove leftover in the test condition. This was
      causing the lightdm.conf file to be rewritten
      every time. This is a serious problem on the
      different Ubuntu flavours (LP: #1224098).
  * debian/postinst.in:
    - Apparently the printf command treats string values
      with leading zeros as octal. Work around this by
      removing any leading zeros (LP: #1219650).
 -- Alberto Milone <email address hidden> Mon, 28 Oct 2013 17:25:42 +0100

Changed in nvidia-prime (Ubuntu Saucy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-prime - 0.4.2~hybrid0.0.1

---------------
nvidia-prime (0.4.2~hybrid0.0.1) precise-proposed; urgency=low

  * debian/preinst.in:
    - Remove leftover in the test condition. This was
      causing the lightdm.conf file to be rewritten
      every time. This is a serious problem on the
      different Ubuntu flavours (LP: #1224098).
  * debian/postinst.in:
    - Apparently the printf command treats string values
      with leading zeros as octal. Work around this by
      removing any leading zeros (LP: #1219650).
 -- Alberto Milone <email address hidden> Wed, 23 Oct 2013 16:10:07 +0200

Changed in nvidia-prime (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers