Hybrid graphics doesn't work with pci classes other than 300

Bug #1207626 reported by Yung Shen on 2013-08-02
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
fglrx-pxpress (Ubuntu)
Undecided
Alberto Milone
nvidia-prime (Ubuntu)
Undecided
Alberto Milone

Bug Description

Unable to log into unity corretly, where intel graphic chipset can work correctly when removing nvidia driver.

Affected graphic card:
01:00.0 3D controller [0302]: NVIDIA Corporation GF117M [GeForce 610M/710M / GT 620M/625M/630M/720M] [10de:1140] (rev a1)

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: nvidia-319 319.32-0ubuntu5
ProcVersionSignature: Ubuntu 3.10.0-6.17-generic 3.10.3
Uname: Linux 3.10.0-6-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.11-0ubuntu1
Architecture: amd64
Date: Fri Aug 2 01:38:26 2013
InstallationDate: Installed on 2013-08-01 (0 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130731)
MarkForUpload: True
SourcePackage: nvidia-graphics-drivers-319
UpgradeStatus: No upgrade log present (probably fresh install)

Yung Shen (kaxing) wrote :
Yung Shen (kaxing) wrote :

This is not a bug, so I'm converting it to a question.

Changed in nvidia-graphics-drivers-319 (Ubuntu):
status: New → Invalid
Yung Shen (kaxing) wrote :

Attached logs for references:

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK107GLM [Quadro K1000M] [10de:0ffc] (rev a1)

Xorg.0.log:
[ 22.862] (EE) Failed to load /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so: libnvidia-tls.so.319.32: cannot open shared object file: No such file or directory
[ 22.862] (EE) Failed to load module "glx" (loader failed, 7)
[ 23.185] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[ 23.185] (EE) NVIDIA(0): log file that the GLX module has been loaded in your X
[ 23.185] (EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
[ 23.185] (EE) NVIDIA(0): you continue to encounter problems, Please try
[ 23.185] (EE) NVIDIA(0): reinstalling the NVIDIA driver.

Yung Shen (kaxing) wrote :

Attached logs for references:

02:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK107M [GeForce GT 640M] [10de:0fd2] (rev ff)

Xorg.0.log:
[ 24.440] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:2:0:0. Please
[ 24.440] (EE) NVIDIA(0): check your system's kernel log for additional error
[ 24.440] (EE) NVIDIA(0): messages and refer to Chapter 8: Common Problems in the
[ 24.440] (EE) NVIDIA(0): README for additional information.
[ 24.440] (EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
[ 24.440] (EE) NVIDIA(0): Failing initialization of X screen 0
[ 24.445] (EE) Screen(s) found, but none have a usable configuration.
[ 24.445] (EE)
[ 24.445] (EE) no screens found(EE)
[ 24.445] (EE)
[ 24.445] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 24.445] (EE)
[ 24.447] (EE) Server terminated with error (1). Closing log file.

Alberto Milone (albertomilone) wrote :

Did you also install the nvidia-prime package?

The following line suggests that either you didn't or that something went wrong with its installation:

/etc/X11/xorg.conf does not exist

Yung Shen (kaxing) wrote :

I did install nvidia-prime alongside with nvidia-319.

ubuntu@201209-11715:~$ dpkg -l |grep nvidia
ii nvidia-319 319.32-0ubuntu5 amd64 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-common 1:0.2.83 amd64 transitional package for ubuntu-drivers-common
ii nvidia-prime 0.3 all Tools to enable NVIDIA's Prime
ii nvidia-settings-319 319.32-0ubuntu2 amd64 Tool for configuring the NVIDIA graphics driver

Alberto Milone (albertomilone) wrote :

something must have gone wrong during the installation of nvidia-prime then, as you have no xorg.conf.

Please type the following commands and reboot:

sudo apt-get --purge remove nvidia-prime
sudo apt-get install nvidia-prime

Yung Shen (kaxing) wrote :

following previous comment,
still getting same low-graphics mode warning window,
and fallback to console if tried to log into failsafe mode.

Yung Shen (kaxing) wrote :
Yung Shen (kaxing) on 2013-08-06
Changed in nvidia-graphics-drivers-319 (Ubuntu):
status: Invalid → New
Alberto Milone (albertomilone) wrote :

No wonder it doesn't work, your xorg.conf has the wrong bus id:

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "0:0:0"
EndSection

1) Is "lspci" installed on your system?
2) Can you please attach the output of "lspci -n | grep 300"?

Yung Shen (kaxing) wrote :

systems are install from lateast saucy daily build:
http://cdimage.ubuntu.com/daily-live/current/saucy-desktop-amd64.iso

this is the result of lspci on system with GF117M graphic card:
$lspci -n|grep 300
00:02.0 0300: 8086:0166 (rev 09)

Alberto Milone (albertomilone) wrote :

ok, so it's not a bug on my side since there is no nvidia card in the output (only the intel card). Is optimus mode enabled?

Yung Shen (kaxing) wrote :

double check with BIOS options, there is no option for turn on/off optimus mode on this system(GF117M).

fyr, according to nvidia offical webpage, it does support optimus:
http://www.geforce.com/hardware/notebook-gpus/geforce-610m
http://www.geforce.com/hardware/notebook-gpus/geforce-710m

Alberto Milone (albertomilone) wrote :

right but if its pci-id doesn't show up in "lspci -n | grep 300" then I'm afraid it won't work

Alberto Milone (albertomilone) wrote :

we can solve this on all the other systems you wrote about, such as the one with GeForce GT 640M (10de:0fd2) or the one with Quadro K1000M (10de:0ffc)

Yung Shen (kaxing) wrote :

GF117M pci-id shows under device class id 0302:

$lspci -nn|grep 302
01:00.0 3D controller [0302]: NVIDIA Corporation GF117M [GeForce 610M/710M / GT 620M/625M/630M/720M] [10de:1140] (rev a1)

I've tried to change to busID to "PCI:01:0:0" , and reboot.
Now I can hear lightdm startup sound but the screen still black, and low-graphics warning did not show up.
please check attached log for more details.

Alberto Milone (albertomilone) wrote :

I think I know what's going on. Please purge nvidia-prime and install the following package:
http://people.canonical.com/~amilone/nvidia-prime_0.4_all.deb

then restart your computer.

Please let me know how it goes.

Yung Shen (kaxing) wrote :

Thanks for your fix,

By installing nvidia-prime_0.4_all.deb and reboot the system,
system with GF117M now able to load into unity/compiz correctly,
also verified system with GF108M, works smoothly.

Alberto Milone (albertomilone) wrote :

excellent, thanks for testing

Changed in nvidia-graphics-drivers-319 (Ubuntu):
status: New → In Progress
assignee: nobody → Alberto Milone (albertomilone)
summary: - Failed to initialize GLX extension (Compatible NVIDIA X driver not
- found)
+ Hybrid graphics doesn't work with pci classes other than 300
affects: nvidia-graphics-drivers-319 (Ubuntu) → nvidia-prime (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-prime - 0.4

---------------
nvidia-prime (0.4) saucy; urgency=low

  * debian/postinst.in, hybrid-power:
    - Make sure to support more pci device classes as per
      the pci.ids file (LP: #1207626).
 -- Alberto Milone <email address hidden> Thu, 08 Aug 2013 11:27:27 +0200

Changed in nvidia-prime (Ubuntu):
status: In Progress → Fix Released
Changed in fglrx-pxpress (Ubuntu):
status: New → Fix Released
assignee: nobody → Alberto Milone (albertomilone)
zubozrout (zubozrout) wrote :

Well, it probably appeared again in Trusty Tahr ... at least I can't get my Nvidia GPU working.

[ 6.395] (II) Module glx: vendor="NVIDIA Corporation"
[ 6.395] (II) NVIDIA GLX Module 331.20 Wed Oct 30 17:36:48 PDT 2013
[ 6.396] (==) Matched nvidia as autoconfigured driver 1
[ 6.402] (II) LoadModule: "nvidia"
[ 6.402] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so
[ 6.426] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 6.442] (II) NVIDIA dlloader X Driver 331.20 Wed Oct 30 17:16:53 PDT 2013
[ 6.442] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 6.443] (II) NOUVEAU driver for NVIDIA chipset families :
[ 6.455] (II) UnloadModule: "nvidia"
[ 6.455] (II) Unloading nvidia
[ 6.479] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

Alberto Milone (albertomilone) wrote :

not really. It's just that prime doesn't work with Linux 3.13.

Aaahh Ahh (woohoomoo2u) wrote :

No I'm using the 12 and 14.04 and the same things have been happening to me! However my lspci is
00:02.0 0300: 8086:0166 (rev 09)
01:00.0 0300: 10de:0fd1 (rev a1)

Alberto Milone (albertomilone) wrote :

This is not the same bug then, as your card clearly belongs to the 0300 pci class.

Feel free to file a separate bug report for 12.04

Hi
I tried everything above with no success on an Acer E1-570G.

lspci -n | grep 300
00:02.0 0300: 8086:0166 (rev 09)

lspci -nn|grep 302
01:00.0 3D controller [0302]: NVIDIA Corporation GF117M [GeForce 610M/710M / GT 620M/625M/630M/720M] [10de:1140] (rev ff)

The hardware boosts both a I-915 and a GE-force 720M.
Original nvidia NVIDIA-Linux-x86_64-331.49.run says that no supported card exists in my system.

no glx is available with nvidia when it boots in graphics mode

purged everything and came back to intel

saucy 64-bit

uname -a
Linux ajoliveira 3.11.0-18-generic #32-Ubuntu SMP Tue Feb 18 21:11:14 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

the bug is there

Cheers

purged everything, am now giving it a try with:

sudo aptitude install nvidia-319 nvidia-prime nvidia-common nvidia-settings-319

xorg.conf now reads:

# Warning: This file is autogenerated by nvidia-prime. All changes to this file will be lost.

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "1:0:0"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    # Uncomment this line if your computer has no display devices connected to
    # the NVIDIA GPU. Leave it commented if you have display devices
    # connected to the NVIDIA GPU that you would like to use.
    Option "UseDisplayDevice" "none"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Unfortunately, terminal screen, even if commenting

Option "UseDisplayDevice" "none"

Cheers

Alberto Milone (albertomilone) wrote :

@Antonio: what Ubuntu release are you using?

Also, please attach the output of the following command:

lspci -Dn

Greetings Alberto & thanks for your answer.

Xubuntu

uname -a

3.11.0-18-generic #32-Ubuntu SMP Tue Feb 18 21:11:14 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 13.10
Release: 13.10
Codename: saucy

lspci -Dn

0000:00:00.0 0600: 8086:0154 (rev 09)
0000:00:01.0 0604: 8086:0151 (rev 09)
0000:00:02.0 0300: 8086:0166 (rev 09)
0000:00:14.0 0c03: 8086:1e31 (rev 04)
0000:00:16.0 0780: 8086:1e3a (rev 04)
0000:00:1a.0 0c03: 8086:1e2d (rev 04)
0000:00:1b.0 0403: 8086:1e20 (rev 04)
0000:00:1c.0 0604: 8086:1e10 (rev c4)
0000:00:1c.1 0604: 8086:1e12 (rev c4)
0000:00:1d.0 0c03: 8086:1e26 (rev 04)
0000:00:1f.0 0601: 8086:1e57 (rev 04)
0000:00:1f.2 0106: 8086:1e03 (rev 04)
0000:00:1f.3 0c05: 8086:1e22 (rev 04)
0000:01:00.0 0302: 10de:1140 (rev ff)
0000:02:00.0 0200: 14e4:16b3 (rev 01)
0000:02:00.1 0805: 14e4:16bc (rev 01)
0000:03:00.0 0280: 168c:0036 (rev 01)

corrected in trusty beta2.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers