No edid sysfs file with -nvidia

Bug #992350 reported by Bryce Harrington on 2012-05-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Wishlist
Unassigned

Bug Description

With Intel (and I think -ati), there is an edid node created in sysfs with the queried edid data. This is important for writable-edid.

On -nvidia there is no such file:

bryce@porlock:/sys/module/nvidia/drivers/pci:nvidia/0000:05:00.0$ ls
boot_vga device i2c-1 modalias reset resource3 subsystem_vendor
broken_parity_status dma_mask_bits i2c-2 msi_bus resource resource5 uevent
class driver irq power resource0 rom vendor
config enable local_cpulist remove resource1 subsystem
consistent_dma_mask_bits i2c-0 local_cpus rescan resource1_wc subsystem_device
bryce@porlock:/sys/module/nvidia/drivers/pci:nvidia/0000:05:00.0$ find /sys/module/nvidia/ -name "*edid*"
bryce@porlock:/sys/module/nvidia/drivers/pci:nvidia/0000:05:00.0$

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xorg 1:7.6+12ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic-pae 3.2.13
Uname: Linux 3.2.0-21-generic-pae i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.gpus.1: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/1'
.proc.driver.nvidia.registry: Binary: ""
ApportVersion: 2.0-0ubuntu4
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Mon Apr 30 19:06:16 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120301)
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm-256color
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-21-generic-pae root=UUID=29eb1f85-e785-4e42-b5d5-cb5927118ed7 ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 05/07/2008
dmi.bios.vendor: Intel Corp.
dmi.bios.version: SOX5810J.86A.0604.2008.0507.1808
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: DX58SO
dmi.board.vendor: Intel Corporation
dmi.board.version: AAE29331-202
dmi.chassis.type: 2
dmi.modalias: dmi:bvnIntelCorp.:bvrSOX5810J.86A.0604.2008.0507.1808:bd05/07/2008:svn:pn:pvr:rvnIntelCorporation:rnDX58SO:rvrAAE29331-202:cvn:ct2:cvr:
version.compiz: compiz 1:0.9.7.4-0ubuntu1
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu11~jupiter1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Bryce Harrington (bryce) wrote :
Timo Aaltonen (tjaalton) wrote :

guess it's related to nvidia not supporting kms?

affects: xorg (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Bryce Harrington (bryce) on 2012-08-17
Changed in nvidia-graphics-drivers (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers