Unity is working incorrectly after returning from standby mode

Bug #987496 reported by atte on 2012-04-23
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
NVIDIA Drivers Ubuntu
Undecided
Unassigned
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu desktop is working incorrectly after returning from standby mode or editing Nvidia X server settings. Unity is slow, unresponsive and is working incorrectly. The launcher is not working and top bar is invisible and mirroring one row of background.
I have attached some screenshots of the problem. While I took the screenshot sound of screenshot was played immediately but the screen flashed few seconds later very slowly. By logging out and logging in again the problem disappears. Byt if I change account and log again in to my account the problem appears again. Changing display drivers will affect to this problem.This problem was in earlier ubuntu versions but it is worse on 12.04. In earlier versions of ubuntu the display was normalized after changing desktop. I had this problem on ubuntu 11.10 in gnome-shell 3.2 but it disappeared after changing display drivers. Ubuntu is 12.04 LTS Beta 2 Precise Pangolin. Display driver is NVidia 295.40.

To reproduce: Use a NVidia Graphics card (if possible Nvidia GF7600GS) Install the latest Nvidia driver from Ubuntu with the Additional drivers tool. Set the launcher to hide itself automatically. Put the computer to standby mode and wake it. Try also to edit the Display settings with NVidia X server settings. Apply the settings after editing for exapmle the display refresh rate. After waking the computer or applying the settings try to reveal launcher or do anything else with ubuntu.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.10.0-0ubuntu6
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] On hakemisto: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 295.40 Thu Apr 5 21:28:09 PDT 2012
 GCC version: gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu4)
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu5
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,imgpng,vpswitch,compiztoolbox,unitymtgrabhandles,mousepoll,move,snap,regex,animation,resize,gnomecompat,grid,expo,place,workarounds,wall,ezoom,fade,session,scale,unityshell,dbus]
CompositorRunning: compiz
CurrentDmesg:
 [ 34.664683] r8169 0000:02:05.0: eth0: link up
 [ 34.664859] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
 [ 36.383391] usblp0: removed
 [ 36.395703] usblp0: USB Bidirectional printer dev 5 if 1 alt 0 proto 2 vid 0x04A9 pid 0x173B
 [ 44.752017] eth0: no IPv6 routers present
Date: Mon Apr 23 22:16:41 2012
DistUpgraded: 2012-04-06 00:03:16,252 DEBUG enabling apt cron job
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus: nvidia-current-updates, 295.40, 3.2.0-23-generic, i686: installed
GraphicsCard:
 NVIDIA Corporation G73 [GeForce 7600 GS] [10de:0392] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:822a]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
JockeyStatus:
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Enabled, In use)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=fi_FI.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=8a90cb11-34e9-41e6-a6ec-a2a4fff82941 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-04-05 (17 days ago)
dmi.bios.date: 10/27/2006
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 080012
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: IL9 Pro
dmi.board.vendor: www.abit.com.tw
dmi.board.version: 1.X
dmi.chassis.asset.tag: 0123ABC
dmi.chassis.type: 3
dmi.chassis.version: 1.X
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr080012:bd10/27/2006:svn:pnIL9Pro:pvr1.X:rvnwww.abit.com.tw:rnIL9Pro:rvr1.X:cvn:ct3:cvr1.X:
dmi.product.name: IL9 Pro
dmi.product.version: 1.X
version.compiz: compiz 1:0.9.7.6-0ubuntu1
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

description: updated
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, from the description it seems like a driver issue and not an unity one indeed

Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Invalid
no longer affects: unity (Ubuntu)
description: updated
description: updated
no longer affects: compiz (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
tags: added: resume running-unity suspend
removed: desktop display launcher nvidia settings sleep standby ubuntu unity x.org xserver
To post a comment you must log in.