Ubuntu

nvidia-common 295.40 makes my Xorg to crash sometimes

Reported by Andrea Grandi on 2012-04-21
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

Often, when I'm using the PC (in particular when I watch videos on Youtube) the whole Xorg crashes and I suppose it's related to the Nvidia driver. I wasn't getting any similar error with Ubuntu 11.10.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: nvidia-current 295.40-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
Uname: Linux 3.2.0-23-generic-pae i686
ApportVersion: 2.0.1-0ubuntu5
Architecture: i386
CheckboxSubmission: 8abda9869c585c6b87b27b20a9d8a71a
CheckboxSystem: edda5d4f616ca792bf437989cb597002
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,move,zoom,resize,imgpng,vpswitch,regex,commands,mousepoll,grid,snap,unitymtgrabhandles,gnomecompat,animation,place,session,wall,expo,ezoom,fade,scale,workarounds,unityshell]
CompositorRunning: None
Date: Sat Apr 21 03:11:29 2012
DistUpgraded: 2012-04-20 17:17:08,975 DEBUG enabling apt cron job
DistroCodename: precise
DistroVariant: ubuntu
GraphicsCard:
 NVIDIA Corporation G92 [GeForce 8800 GS] [10de:0606] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:8271]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111011)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 003: ID 059b:0475 Iomega Corp.
 Bus 002 Device 002: ID 055f:021f Mustek Systems, Inc. SNAPSCAN e22
 Bus 002 Device 003: ID 046d:c31c Logitech, Inc. Keyboard K120 for Business
MachineType: System manufacturer System Product Name
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic-pae root=UUID=4d1c2001-5c5d-4bd4-84bd-d33124051ece ro quiet splash
SourcePackage: nvidia-graphics-drivers
UnitySupportTest:
 Error: command ['/usr/lib/nux/unity_support_test', '-p', '-f'] failed with exit code 5: Xlib: extension "GLX" missing on display ":0".
 Error: GLX is not available on the system
UpgradeStatus: Upgraded to precise on 2012-04-20 (0 days ago)
dmi.bios.date: 06/11/2008
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: ASUS P5N-E SLI ACPI BIOS Revision 1101
dmi.board.name: P5N-E SLI
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: 1.XX
dmi.chassis.asset.tag: 123456789000
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSP5N-ESLIACPIBIOSRevision1101:bd06/11/2008:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5N-ESLI:rvr1.XX:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.7.6-0ubuntu1
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Andrea Grandi (andreagrandi) wrote :
Andrea Grandi (andreagrandi) wrote :

It looks like the problem with 295.40 version of Nvidia driver is confirmed even by Nvidia: http://www.phoronix.com/scan.php?page=news_item&px=MTA4ODc
I've switched back to 295.33 version, using this PPA: https://launchpad.net/~ubuntu-x-swat/+archive/x-updates
and it looks stable right now. I know that I'm now vulnerable to a security problem, but since it's not a remote security problem and I'm the only user of this PC it's pretty fine for me.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
summary: - nvidia-common makes my Xorg to crash sometimes
+ nvidia-common 295.40 makes my Xorg to crash sometimes
Andrea Grandi (andreagrandi) wrote :

I'm experimenting instability issues even with 295.33 driver version.
Please tell me how I can give you more informations to help you fixing the bug.

Axel H. (staff-pro-unreal) wrote :

I can confirm the 295.33 driver resolves instability issues with unity for GeForce 8800 GTX.

Andrea Grandi (andreagrandi) wrote :

Lucky you Axel. I had to installa the Nouveau driver instead. Not a single crash in one week of use. It's rock stable. It's a pity I cannot use the binary one :(

Andrea Grandi (andreagrandi) wrote :

@madbiologist: is it already available in repositories?

madbiologist (me-again) wrote :
Andrea Grandi (andreagrandi) wrote :

@madbiologist: it's only available for Quantal Quetzal, not for Precise. I hope in a backport.

madbiologist (me-again) wrote :

295.49 is now available in precise-proposed. If you would like to try it before it is made available via Update Manager, see https://wiki.ubuntu.com/Testing/EnableProposed for instructions on how to enable -proposed.

Otherwise just monitor https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-updates

Nils Bühler (nils-b-z) wrote :

I installed 195.49 but the bug still exists. System is up to date.

madbiologist (me-again) wrote :

NVIDIA Driver 295.49-0ubuntu0.1 is now available in -updates for Precise.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Fix Released
Andrea Grandi (andreagrandi) wrote :

I'm sorry, but I won't be able to test this fix until September :(
I've moved to Finland for 3 months and I could not bring my desktop PC with me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers