nouveau remains blacklisted after uninstall of nvidia drivers

Bug #958848 reported by Philipp Gassmann on 2012-03-18
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
NVIDIA Drivers Ubuntu
Undecided
Unassigned
nvidia-graphics-drivers (Ubuntu)
High
Alberto Milone

Bug Description

After apt-get remove nvidia-* the file /etc/modprobe.d/nvidia-current_hybrid.conf remains and blocks the loading of the nouveau-driver.

So, Ubuntu works great, with 3D Unity and nouveau. Then I installed the nvidia-driver but didn't like all the consequences of that proprietary driver that doesn't integrate.
 - No proper Monitor detection (separate tool, forwarded to system as single monitor)
 - No color profiles
 - Ugly boot screen
 - etc.

But after uninstall of nvidia. It got me back to unity-2d, no 2nd Monitor (mission hdmi support)

I tried to reinstall nouveau, but driver still doesn't load.
Then I found out that the nouveau driver is still blacklisted. Manually removed that file, rebooted, it worked again.

There's a second file that blacklists nouveau, but gets removed after uninstall of nvidia-current. /etc/modprobe.d/nvidia-graphics-drivers.conf

content of /etc/modprobe.d/nvidia-current_hybrid.conf:

# This file was installed by nvidia-current
# Do not edit this file manually

blacklist nouveau
blacklist lbm-nouveau
alias nouveau off
alias lbm-nouveau off

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: nvidia-current (not installed)
ProcVersionSignature: Ubuntu 3.2.0-19.30-generic 3.2.11
Uname: Linux 3.2.0-19-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,place,regex,mousepoll,resize,wall,animation,session,snap,compiztoolbox,workarounds,grid,move,vpswitch,imgpng,gnomecompat,expo,ezoom,staticswitcher,fade,scale,unityshell]
CompositorRunning: compiz
Date: Sun Mar 18 22:48:16 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.1.8, 3.2.0-17-generic, x86_64: installed
 virtualbox, 4.1.8, 3.2.0-18-generic, x86_64: installed
 virtualbox, 4.1.8, 3.2.0-19-generic, x86_64: installed
GraphicsCard:
 NVIDIA Corporation GT216 [GeForce GT 230M] [10de:0a28] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:7001]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111223)
MachineType: Hewlett-Packard HP Pavilion dv8 Notebook PC
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.2.0-19-generic root=UUID=715dd5a1-9f86-4040-9e07-d1766d26a7db ro quiet splash vt.handoff=7
SourcePackage: nvidia-graphics-drivers
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/27/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.24
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 7001
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 35.35
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.24:bd04/27/2010:svnHewlett-Packard:pnHPPaviliondv8NotebookPC:pvr049B210000241220001020000:rvnHewlett-Packard:rn7001:rvr35.35:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv8 Notebook PC
dmi.product.version: 049B210000241220001020000
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.7.0+bzr3035-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.1-0ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.1-0ubuntu5
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Philipp Gassmann (phiphi.g) wrote :
tags: added: packaging
Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers - 295.33-0ubuntu1

---------------
nvidia-graphics-drivers (295.33-0ubuntu1) precise; urgency=low

  * New upstream release:
    - Added support for the following GPUs:
      o GeForce GTX 680
      o GeForce GT 630M
      o GeForce GT 620
    - Fixed a VDPAU bug where decoding some H.264 streams
      would cause hardware errors on lower-end products,
      resulting in corruption and poor performance.
    - Fixed a bug that caused DisplayPort audio to stop
      working after monitors are hotplugged on GeForce GT
      520.
    - Improved compatibility with recent Linux kernels.
    - Fixed a behavior change that prevented
      ConnectedMonitor from being usable with DisplayPort
      connectors.
    - Marked the GVO Clone mode NV-CONTROL attributes:
      NV_CTRL_GVO_DISPLAY_X_SCREEN
      NV_CTRL_GVO_X_SCREEN_PAN_X
      NV_CTRL_GVO_X_SCREEN_PAN_Y
      as deprecated. They will be removed in a future
      release. To display an X screen over GVO, it is
      recommended to use GVO with MetaModes, instead.
    - Fixed a bug that caused DisplayPort devices to not
      be listed in Xorg.*.log.
    - Added support for 3D Vision ready displays that
      have a NVIDIA 3D Vision infrared emitter built
      inside the panel itself.
    - Fixed a bug that caused OpenGL applications to
      crash with some libc versions, such as eglibc 2.15
      (LP: #929384).
    - Fixed a bug that caused HDMI audio to stop working
      on AppleTV devices when an X server was started.
  * debian/nvidia-$flavour.postrm{.in}:
    - Make sure to remove the blacklist for hybrid
      graphics and to rebuild the initramfs (LP: #958848).
 -- Alberto Milone <email address hidden> Tue, 27 Mar 2012 10:06:36 +0200

Changed in nvidia-graphics-drivers (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers