Ubuntu

some packages fail to build because of missing libcuda1

Reported by IRIE Shinsuke on 2012-03-09
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
nvidia-cuda-toolkit (Ubuntu)
High
Alberto Milone
Precise
Undecided
Graham Inggs
nvidia-graphics-drivers (Ubuntu)
High
Alberto Milone
Precise
Undecided
Graham Inggs
starpu-contrib (Ubuntu)
High
Alberto Milone
Precise
Undecided
Graham Inggs
viennacl (Ubuntu)
High
Unassigned
Precise
Undecided
Graham Inggs

Bug Description

[SRU] Debdiffs attached for fixing the FTBFS in Precise for the following packages:
nvidia-cuda-toolkit (patch in comment #17)
starpu-contrib (patch in comment #18)
viennacl (patch in comment #19)

[IMPACT]
Packages fail to build from source on Precise because of missing libcuda1 or missing libopencl1. In Ubuntu, nvidia-current satisfies these dependencies, although not explicitly.

[Test Cases]
Verify that nvidia-cuda-toolkit, starpu-contrib and viennacl are able to build.

[Regression Potential]
None: packages currently do not build from source.

The following SRU has been completed, thank you.
nvidia-graphics-drivers (patch in comment #13):
[SRU] The attached debdiff backports a single change from nvidia-graphics-drivers 304.51.really.304.43-0ubuntu1 in Quantal to Precise so that packages that Build-Depend on nvidia-current can be built. Currently, nvidia-current fails to install without its recommended dependency nvidia-settings.

[IMPACT]
When attempting to build packages that Build-Depends on nvidia-current for Precise, the build servers are unable to install nvidia-current and the build fails.

[Test Cases]
Upload any source package that Build-Depends on nvidia-current; e.g. nvidia-cuda-toolkit, starpu-contrib or viennacl, to the PPA builders targeted for Precise.

[Regression Potential]
Minimal: the change only affects the installation of the nvidia-current and none of the packages that Build-Depend on it can currently build.

Original bug description:
Ubuntu 12.04
nvidia-graphics-drivers 295.20-0ubuntu1

In Ubuntu, nvidia-graphics-drivers package provides only nvidia-current and nvidia-current-dev, while the Debian's package provides many separated deb packages as follows:

libcuda1
libcuda1-dev
libcuda1-ia32
libgl1-nvidia-alternatives
libgl1-nvidia-alternatives-ia32
libgl1-nvidia-glx
libgl1-nvidia-glx-ia32
libglx-nvidia-alternatives
libnvidia-compiler
libnvidia-compiler-ia32
libnvidia-compiler1
libnvidia-compiler1-ia32
nvidia-glx
nvidia-glx-dev
nvidia-glx-ia32
nvidia-kernel-dkms
nvidia-kernel-source
nvidia-libopencl1
nvidia-libopencl1-dev
nvidia-libopencl1-ia32
nvidia-libvdpau-dev
nvidia-libvdpau1
nvidia-libvdpau1-ia32
nvidia-opencl-common
nvidia-opencl-icd
nvidia-opencl-icd-ia32
nvidia-smi
nvidia-vdpau-driver
nvidia-vdpau-driver-ia32

So, some packages imported from Debian cannot be built or not installable unless their dependencies are modified. For example, nvidia-cuda-toolkit is failed to build because of missing libcuda1. See https://launchpad.net/ubuntu/+source/nvidia-cuda-toolkit/4.0.17-3/+build/3079987 .

I think the separate packages should be provided as in Debian and nvidia-current and nvidia-current-dev should be changed to meta packages which depend on those separate packages.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-cuda-toolkit (Ubuntu):
status: New → Confirmed
Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
Changed in nvidia-cuda-toolkit (Ubuntu):
importance: Undecided → High
Changed in starpu-contrib (Ubuntu):
importance: Undecided → High
Changed in viennacl (Ubuntu):
importance: Undecided → High
tags: added: ftbfs
Changed in starpu-contrib (Ubuntu):
status: New → Confirmed
Changed in viennacl (Ubuntu):
status: New → Confirmed
Mystic-Mirage (mystic-mirage) wrote :

This bug affects me. GPU emulation on android emulator can't work on AMD64 without libgl1-nvidia-glx-ia32 and libgl1-nvidia-alternatives-ia32 installed.

Bryce Harrington (bryce) on 2012-09-20
Changed in nvidia-graphics-drivers (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Bryce Harrington (bryce) wrote :

This issue is the origin of these build failures in Quantal:
  pycuda - https://launchpad.net/ubuntu/+source/pycuda/2012.1-1/+build/3603969 (needs nvidia-cuda-toolkit)
  nvidia-cuda-toolkit - https://launchpad.net/ubuntu/+source/nvidia-cuda-toolkit/4.2.9-1/+build/3510919 (needs libcua1)

Alberto Milone (albertomilone) wrote :

Splitting the Nvidia driver into so many packages would require a major rework of the packaging. I fixed the dependencies and build dependencies of nvidia-cuda-toolkit instead.

Changed in nvidia-cuda-toolkit (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers (Ubuntu):
status: Triaged → Won't Fix
Changed in nvidia-cuda-toolkit (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-cuda-toolkit - 4.2.9-1ubuntu1

---------------
nvidia-cuda-toolkit (4.2.9-1ubuntu1) quantal; urgency=low

  * debian/control:
    - Build depend and depend on nvidia to fix FTBFS (LP: #950963).
 -- Alberto Milone <email address hidden> Thu, 04 Oct 2012 13:21:47 +0200

Changed in nvidia-cuda-toolkit (Ubuntu):
status: In Progress → Fix Released
Changed in starpu-contrib (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package starpu-contrib - 1.0.1-3ubuntu1

---------------
starpu-contrib (1.0.1-3ubuntu1) quantal; urgency=low

  * debian/control: fix FTBFS (LP: #950963).
 -- Alberto Milone <email address hidden> Thu, 04 Oct 2012 15:40:21 +0200

Changed in starpu-contrib (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers - 304.51.really.304.43-0ubuntu1

---------------
nvidia-graphics-drivers (304.51.really.304.43-0ubuntu1) quantal; urgency=low

  * Revert to 304.43 (LP: #1057000).
  * debian/nvidia-current.dirs.in:
    - Add /usr/share/applications. This should fix
      nvidia-cuda-toolkit FTBFS (LP: #950963).
  * debian/nvidia-current.{postinst|prerm}.in,
    debian/rules:
    - Make sure that the packaging knows how to deal with
      reverted versions such as this one.
 -- Alberto Milone <email address hidden> Fri, 05 Oct 2012 18:52:59 +0200

Changed in nvidia-graphics-drivers (Ubuntu):
status: Won't Fix → Fix Released
Micah Gersten (micahg) wrote :

This bug was fixed in the package viennacl - 1.2.0-2

---------------
viennacl (1.2.0-2) unstable; urgency=low

  * [432b5df] Change debian branch to debian/1.2.0
  * [815d6d8] Fix declaration order of prod_impl() and trans_prod_impl()
    - Added d/p/0004-Fix-declaration-order-of-prod_impl-trans_prod_impl.patch
    (Closes: 682410)

 -- Michael Wild <email address hidden> Fri, 27 Jul 2012 22:24:56 +0200

Changed in viennacl (Ubuntu):
status: Confirmed → Fix Released
Graham Inggs (ginggs) on 2013-02-19
summary: - nvidia-graphics-drivers needs to provide separate packages such as
- libcuda1
+ some packages fail to build because of missing libcuda1
Graham Inggs (ginggs) wrote :

[SRU] The attached debdiff backports a single change from nvidia-graphics-drivers 304.51.really.304.43-0ubuntu1 in Quantal to Precise so that packages that Build-Depend on nvidia-current can be built.

[IMPACT]
When attempting to build packages that Build-Depends on nvidia-current for Precise, the build servers are unable to install nvidia-current and the build fails.

[Test Cases]
Upload any source package that Build-Depends on nvidia-current; e.g. nvidia-cuda-toolkit, starpu-contrib or viennacl, to the PPA builders targeted for Precise.

[Regression Potential]
Minimal: the change only affects the installation of the nvidia-current and none of the packages that Build-Depend on it can currently build.

description: updated
Martin Pitt (pitti) wrote :

Sponsored the n-g-d precise patch into the SRU review queue. But please update the SRU description how adding a desktop file in /usr/share/applications is related to a missing libcuda1 and fixes build failures. Thanks!

Unsubscribing sponsors.

Changed in nvidia-graphics-drivers (Ubuntu Precise):
status: New → In Progress
Graham Inggs (ginggs) on 2013-02-21
description: updated
Changed in nvidia-cuda-toolkit (Ubuntu Precise):
assignee: nobody → Graham Inggs (ginggs)
Changed in nvidia-graphics-drivers (Ubuntu Precise):
assignee: nobody → Graham Inggs (ginggs)
Changed in starpu-contrib (Ubuntu Precise):
assignee: nobody → Graham Inggs (ginggs)
Changed in viennacl (Ubuntu Precise):
assignee: nobody → Graham Inggs (ginggs)
Graham Inggs (ginggs) on 2013-02-21
description: updated

Hello IRIE, or anyone else affected,

Accepted nvidia-graphics-drivers into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nvidia-graphics-drivers/295.40-0ubuntu1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nvidia-graphics-drivers (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Graham Inggs (ginggs) wrote :

I was able to build nvidia-cuda-toolkit successfully on a PPA builder with Proposed dependencies enabled.

Previously, the build would fail while installing nvidia-current:

Setting up nvidia-current (295.40-0ubuntu1.2) ...
update-alternatives: using /usr/lib/nvidia-current/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in auto mode.
update-alternatives: error: error creating symbolic link `/usr/share/applications/ubuntu-nvidia-settings.desktop.dpkg-tmp': No such file or directory
dpkg: error processing nvidia-current (--configure):
 subprocess installed post-installation script returned error exit status 2

Now, nvidia-current is installed successfully and the build goes on to completion:

Setting up nvidia-current (295.40-0ubuntu1.3) ...
update-alternatives: using /usr/lib/nvidia-current/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in auto mode.
update-alternatives: using /usr/lib/nvidia-current/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in auto mode.

tags: added: verification-done
removed: verification-needed
Changed in nvidia-graphics-drivers (Ubuntu Precise):
status: Fix Committed → In Progress
status: In Progress → Fix Committed
Graham Inggs (ginggs) wrote :
Graham Inggs (ginggs) on 2013-03-02
description: updated
Stefano Rivera (stefanor) wrote :

Uploaded all of those (including starpu-contrib which won't build until nvidia-cuda-toolkit has)

Changed in nvidia-graphics-drivers (Ubuntu Precise):
status: Fix Committed → In Progress
status: In Progress → Fix Committed
Changed in nvidia-cuda-toolkit (Ubuntu Precise):
status: New → In Progress
Changed in viennacl (Ubuntu Precise):
status: New → In Progress
Changed in starpu-contrib (Ubuntu Precise):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers - 295.40-0ubuntu1.3

---------------
nvidia-graphics-drivers (295.40-0ubuntu1.3) precise-proposed; urgency=low

  * Backport the following change from 304.51.really.304.43-0ubuntu1
    so that packages that Build-Depend on nvidia-current can be built
    (LP: #950963).
    - debian/nvidia-current.dirs.in:
      - Add /usr/share/applications.
 -- Graham Inggs <email address hidden> Wed, 20 Feb 2013 21:52:18 +0200

Changed in nvidia-graphics-drivers (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Hello IRIE, or anyone else affected,

Accepted nvidia-cuda-toolkit into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nvidia-cuda-toolkit/4.0.17-3ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nvidia-cuda-toolkit (Ubuntu Precise):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Changed in viennacl (Ubuntu Precise):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Hello IRIE, or anyone else affected,

Accepted viennacl into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/viennacl/1.1.2-6ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in starpu-contrib (Ubuntu Precise):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Hello IRIE, or anyone else affected,

Accepted starpu-contrib into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/starpu-contrib/0.9.1-3ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Graham Inggs (ginggs) wrote :

The starpu-contrib packages still haven't appeared in precise-proposed.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-cuda-toolkit - 4.0.17-3ubuntu0.1

---------------
nvidia-cuda-toolkit (4.0.17-3ubuntu0.1) precise-proposed; urgency=low

  * Backport the following changes from 5.0.35-4 in Raring so that
    nvidia-cuda-toolkit can also be built and installed on systems with
    nvidia-experimental installed and without depending on and recommending
    nvidia-current.
    - debian/{control,rules}: Use substvars for the names of the libcuda1 and
      nvidia-libopencl1 packages.
    - Build-Depend/Depend on nvidia-current | nvidia-current-updates |
      nvidia-experimental-*. instead of libcuda1 and nvidia-libopencl1.
      (LP: #950963)
    - Override libcuda.so.1 dependencies via shlibs.local to support
      installing with nvidia-experimental-* while building against
      nvidia-current. (LP: #1092259)
 -- Graham Inggs <email address hidden> Wed, 20 Feb 2013 13:23:19 +0200

Changed in nvidia-cuda-toolkit (Ubuntu Precise):
status: Fix Committed → Fix Released
Graham Inggs (ginggs) wrote :

The following packages all install cleanly from precise-proposed:

nvidia-cuda-toolkit
libviennacl-dev
libviennacl-doc
libstarpu-contrib0
libstarpu-contrib-dev
libstarpu-contribfft0
libstarpu-contribmpi0
starpu-contrib-examples
starpu-contrib-tools

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package viennacl - 1.1.2-6ubuntu0.1

---------------
viennacl (1.1.2-6ubuntu0.1) precise-proposed; urgency=low

  * debian/control: build-depends on nvidia-current or libopencl1.
    (LP: #950963)
 -- Graham Inggs <email address hidden> Thu, 21 Feb 2013 01:58:51 +0200

Changed in viennacl (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package starpu-contrib - 0.9.1-3ubuntu0.1

---------------
starpu-contrib (0.9.1-3ubuntu0.1) precise-proposed; urgency=low

  * debian/control: build-depends on nvidia-current, nvidia-current-updates,
    nvidia-experimental-* instead of libcuda1. (LP: #950963)
 -- Graham Inggs <email address hidden> Thu, 21 Feb 2013 01:50:54 +0200

Changed in starpu-contrib (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers