[9800GT] Problem after the installation Nvidia driver

Bug #943643 reported by fmo on 2012-02-29
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
NVIDIA Drivers Ubuntu
Undecided
Unassigned
nvidia-graphics-drivers (Ubuntu)
High
Unassigned

Bug Description

I installed Ubuntu 12.04 from daily image (29/02/2012), everything worked fine then I received the pop-up to install Restricted drivers which I did and after rebooting I noticed that all the fonts were blured like if the resolution was set incorrectly.

I ran nvidia-settings to check that the definition was definitely my LCD default 1680x1050 and everything appears to be fine.

I also tried the driver nvidia-current-updates and it does absolutely the same.

My card is a Nvidia 9800GT and it has always worked fine with the Nvidia driver.

My xorg.conf contains the following:
Section "Device"
        Identifier "Default Device"
        Option "NoLogo" "True"
EndSection

I have attached my xorg log file.

Please let me know if you need anything else, I can only test during UK evening times.

I also want to mention that this is a re-install, I had a Precise install before that had the same problem and I wanted to make sure that re-installing it wouldn't fix the bug (it didn't, at least while the nvidia driver is installed, it seems to work fine with Nouveau).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xorg 1:7.6+10ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 295.20 Mon Feb 6 21:07:30 PST 2012
 GCC version: gcc version 4.6.2 (Ubuntu/Linaro 4.6.2-16ubuntu1)
.tmp.unity.support.test.0:

ApportVersion: 1.93-0ubuntu2
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Wed Feb 29 22:20:51 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 295.20, 3.2.0-17-generic, x86_64: installed
 vboxhost, 4.1.8, 3.2.0-17-generic, x86_64: installed
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard: NVIDIA Corporation G92 [GeForce 9800 GT] [10de:0614] (rev a2) (prog-if 00 [VGA controller])
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120228.1)
JockeyStatus:
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
MachineType: Gigabyte Technology Co., Ltd. GA-MA785GMT-UD2H
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-17-generic root=UUID=fa2f94f8-a617-4d5a-8f6f-6674f2131318 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 05/25/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F9
dmi.board.name: GA-MA785GMT-UD2H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF9:bd05/25/2010:svnGigabyteTechnologyCo.,Ltd.:pnGA-MA785GMT-UD2H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-MA785GMT-UD2H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-MA785GMT-UD2H
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu5
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.1-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.1-0ubuntu2
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

fmo (fmo) wrote :
fmo (fmo) wrote :

I have fixed the problem, for some reason when I installed the drivers it created a graphical mode for my monitor in 1680x1050 at 60Hz that did not work.

Using nvidia-settings as root I switched the mode frequency to Auto and applied and it fixed the problem straight away. I saved the setting in /etc/X11/xorg.conf and now everything is clear again.

The question now is what did it do that on a fresh install....

fmo (fmo) wrote :

It looks like the settings don't stick, I have to go to the nvidia-settings everytime I login, change the frequency from Auto to 60hz and then Apply. Even if I run the tool as root and save the settings after I reboot I have the same issue.

Bryce Harrington (bryce) wrote :

Sounds roughly similar to bug #940742.

I'm a bit confused by your last two comments. In #2 you said you changed the mode frequency to Auto in xorg.conf, then in #3 you have to change it from Auto to 60Hz. Couldn't you just set it to 60Hz in your xorg.conf directly?

Your xorg.conf is not attached to this bug btw, can you attach it?

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Incomplete
fmo (fmo) wrote :

Hi Bryce,

I changed the setting from Auto to 60Hz in Nvidia-settings but even if I save the config to xorg.conf when I restart the fonts become blurry again.

I have also tried to remove my xorg.conf completely and regenerate one from Nvidia-settings but it doesn't help.

I ran Nvidia-settings as root.

I have attached my xorg.conf. not sure if it is very relevant as I deleted it to try again from scratch several time.

Many thanks,
Fernando

Tarrade (matxieu) wrote :

I do have the same problem, tried to write directly the xconf but no luck

fmo (fmo) on 2012-03-26
Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → Confirmed
fmo (fmo) wrote :

Hi,

I did a full re-install today as soon as I installed the nvidia drivers through Jockey the fonts became blurry again at next reboot

Bryce Harrington (bryce) on 2012-04-02
summary: - Fonts are blurry after the installation of Nvidia driver using jockey
+ [9800GT] Fonts are blurry after the installation of Nvidia driver using
+ jockey

Are you able to set the preferred rate via xrandr? I.e.

  xrandr -r 60.0 -s 1680x1050

If so, you could stick that in your .xsessionrc file.

Alternatively, try this in your xorg.conf:

Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TwinView" "0"
    Option "TwinViewXineramaInfoOrder" "CRT-0"
    Option "metamodes" "1680x1050_60 +0+0; nvidia-auto-select +0+0"
    SubSection "Display"
        Depth 24
        Modes "1680x1050_60"
    EndSubSection
EndSection

Further, make sure you do not have a ~/.config/monitors.xml file (it won't work with nvidia).

fmo (fmo) wrote :

When I run "xrandr -r 60.0 -s 1680x1050" I get "Rate 60.0 Hz not available for this size"

I tried the settings in the xorg.conf and it doesn't work either.

I don't have a ~/.config/monitors.xml file

Something worth mentioning is that I am using the VGA Out of the card, not the digital output.

I run xrandr on its own I get the following:
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 240, current 1680 x 1050, maximum 1680 x 1050
default connected 1680x1050+0+0 0mm x 0mm
   1680x1050 50.0 51.0 52.0*
   1440x900 53.0
   1400x1050 54.0 55.0 56.0 57.0
   1360x768 58.0 59.0
   1280x1024 60.0 61.0
   1280x960 62.0
   1152x864 63.0 64.0 65.0 66.0
   1024x768 67.0 68.0 69.0
   960x600 70.0
   960x540 71.0
   840x525 72.0 73.0 74.0 75.0
   832x624 76.0
   800x600 77.0 78.0 79.0 80.0
   720x450 81.0
   700x525 82.0 83.0
   680x384 84.0 85.0
   640x480 86.0 87.0 88.0 89.0 90.0
   512x384 91.0 92.0
   400x300 93.0
   320x240 94.0 95.0

Bryce Harrington (bryce) wrote :

I notice several bugs reporting similar problems with older nvidia cards: 877438 (8xxx cards), 940742 (6xxx cards), 943643 (9800), 958251 (8600), 962191 (7100). The problems include generally degraded performance, fuzzy fonts, and/or lagging in games, which did not exist in earlier versions of the nvidia driver.

We've recently added a new 295-33 version of -nvidia to Ubuntu. The changelog doesn't specifically list a fix for this type of problem, but it does list a few performance fixes, and would be worth re-testing. Update to nvidia 295.33 and report back here whether or not it improved the performance.

Note, you might be seeing crashes, corruption, or other assorted problems, but these may be separate bugs, let's just focus on the performance regression on this bug report.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Incomplete
fmo (fmo) wrote :

Hi Bryce,

Thanks a lot for looking into this bug, I also believe this comes from the nvidia driver itself.

I am already running the new 295.33, I received the update form 295.20 sometime last week I believe

ii nvidia-common 1:0.2.42 Find obsolete NVIDIA drivers
ii nvidia-current 295.33-0ubuntu1 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-settings 295.33-0ubuntu1 Tool of configuring the NVIDIA graphics driver

Bryce Harrington (bryce) wrote :

Thanks fmo

Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → High
FR. Loïc (hackurx) wrote :

Xorg does not work with nvidia-current on my 9800GT.
My graphics card only works with the nouveau driver:

LSHW:
                description: VGA compatible controller
                produit: G92 [GeForce 9800 GT]
                fabriquant: NVIDIA Corporation
                identifiant matériel: 0
                information bus: pci@0000:01:00.0
                version: a2
                bits: 64 bits
                horloge: 33MHz
                fonctionnalités: pm msi pciexpress vga_controller bus_master cap_list rom
                configuration: driver=nouveau latency=0
                ressources: irq:18 mémoire:fa000000-faffffff mémoire:d0000000-dfffffff mémoire:f8000000-f9ffffff portE/S:bf00(taille=128) mémoire:fb000000-fb01ffff

LSPCI:
01:00.0 VGA compatible controller: NVIDIA Corporation G92 [GeForce 9800 GT] (rev a2) (prog-if 00 [VGA controller])
 Subsystem: Device 1acc:902b
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 18
 Region 0: Memory at fa000000 (32-bit, non-prefetchable) [size=16M]
 Region 1: Memory at d0000000 (64-bit, prefetchable) [size=256M]
 Region 3: Memory at f8000000 (64-bit, non-prefetchable) [size=32M]
 Region 5: I/O ports at bf00 [size=128]
 [virtual] Expansion ROM at fb000000 [disabled] [size=128K]
 Capabilities: [60] Power Management version 3
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
  Address: 0000000000000000 Data: 0000
 Capabilities: [78] Express (v1) Endpoint, MSI 00
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <4us
   ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
  DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
   RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
   MaxPayload 128 bytes, MaxReadReq 512 bytes
  DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
  LnkCap: Port #0, Speed 2.5GT/s, Width x16, ASPM L0s L1, Latency L0 <512ns, L1 <1us
   ClockPM- Surprise- LLActRep- BwNot-
  LnkCtl: ASPM Disabled; RCB 128 bytes Disabled- Retrain- CommClk+
   ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed 2.5GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
 Capabilities: [100 v1] Virtual Channel
  Caps: LPEVC=0 RefClk=100ns PATEntryBits=1
  Arb: Fixed- WRR32- WRR64- WRR128-
  Ctrl: ArbSelect=Fixed
  Status: InProgress-
  VC0: Caps: PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
   Arb: Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
   Ctrl: Enable+ ID=0 ArbSelect=Fixed TC/VC=ff
   Status: NegoPending- InProgress-
 Capabilities: [128 v1] Power Budgeting <?>
 Capabilities: [600 v1] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
 Kernel driver in use: nouveau
 Kernel modules: nouveau, nvidiafb

FR. Loïc (hackurx) on 2012-05-08
summary: - [9800GT] Fonts are blurry after the installation of Nvidia driver using
- jockey
+ [9800GT] Problem after the installation Nvidia driver

I had the same issue ( 12.04 ) . It was solved when i switched to new monitor D-SUB -> DVI . Fonts were blurry with binary blob but not with nuoveau .

FR. Loïc (hackurx) wrote :
FR. Loïc (hackurx) wrote :
fmo (fmo) wrote :

This bug has finally been fixed in latest beta 304.22!

To post a comment you must log in.