Xorg freeze on playin video in flashplugin

Bug #879978 reported by Oleg "Nightwing" Lomakin on 2011-10-22
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Oleg "Nightwing" Lomakin

Bug Description

Xorg (and whole system sometimes, e.g. alt+sysrq+reisub doesn't work) on flash video playback(youtube, vimeo, etc). Sometimes it plays normally, but freeze after closing page. I tried to install i386 and x86-64 versions of flash-plugins, play with EnableLinuxHWVideoDecode parameter in /etc/adobe/mmc.cfg, install 285 instead 280 version of nvidia drivers, and nothing helps.
Everything works well on 11.04.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7
ProcVersionSignature: Ubuntu 3.0.0-13.21-generic 3.0.6
Uname: Linux 3.0.0-13-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Это каталог: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 285.05.09 Fri Sep 23 17:31:57 PDT 2011
 GCC version: gcc версия 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu3
Architecture: amd64
CheckboxSubmission: 828cb4471ecf6edcccac96c4269d67c5
CheckboxSystem: edda5d4f616ca792bf437989cb597002
CompizPlugins: [core,bailer,detection,composite,opengl,copytex,compiztoolbox,decor,imgpng,grid,vpswitch,blur,gnomecompat,move,regex,mousepoll,place,session,resize,snap,wall,bicubic,animation,fade,workarounds,expo,ezoom,scale,unityshell]
CompositorRunning: compiz
Date: Sat Oct 22 19:49:47 2011
DistUpgraded: Log time: 2011-10-13 19:39:56.024946
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 285.05.09, 3.0.0-13-generic, x86_64: installed
 vboxhost, 4.0.10, 2.6.38-11-generic, x86_64: installed
 vboxhost, 4.0.10, 2.6.38-12-generic, x86_64: installed
 vboxhost, 4.0.10, 3.0.0-12-generic, x86_64: installed
 vboxhost, 4.0.10, 3.0.0-13-generic, x86_64: installed
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GpuHangFrequency: Several times a day
GpuHangReproducibility: Yes, I can easily reproduce it
GpuHangStarted: Since before I upgraded
GraphicsCard: nVidia Corporation GT215 [GeForce GT 240] [10de:0ca3] (rev a2) (prog-if 00 [VGA controller])
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
JockeyStatus:
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
MachineType: System manufacturer System Product Name
ProcEnviron:
 PATH=(custom, no user)
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-13-generic root=UUID=2bd26358-3026-4c78-a556-2878f2dbf1cb ro nomodeset
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
UpgradeStatus: Upgraded to oneiric on 2011-10-13 (9 days ago)
XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 04/07/2006
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: ASUS A8N-E ACPI BIOS Revision 1013
dmi.board.name: A8N-E
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: 2.XX
dmi.chassis.asset.tag: 123456789000
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSA8N-EACPIBIOSRevision1013:bd04/07/2006:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnA8N-E:rvr2.XX:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu5
version.ia32-libs: ia32-libs 20110725.2~natty48
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

bugbot (bugbot) on 2011-10-23
affects: xorg (Ubuntu) → xserver-xorg-video-nv (Ubuntu)

I use proprietary nvidia driver

AlmAck (gluca86) wrote :

I had a similar problem, I solved commenting the line below in /etc/adobe/mms.cfg:
EnableLinuxHWVideoDecode=1
I think this is a problem on the nVidia graphics card.
Tested with sony VPCCW2S1E, nvidia 285.05.09 with GeForce GT 330M, kernel 3.0.0-15-generic, ubuntu 11.10 64bit

Timo Aaltonen (tjaalton) on 2012-01-09
affects: xserver-xorg-video-nv (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Thal (andy-mendyk) wrote :

Same problem ...
Using flashplyer in firefox, try fast forward with mouse, leads to system freeze
xorg load around 100% CPU load (top)
xserver do not responde, no console login possible
mouse very slow moving
ssh login possible, have to kill xorg process
Already have "EnableLinuxHWVideoDecode=1"
nvidia, Linux 3.0.0-15-generic #26-Ubuntu SMP Fri Jan 20 17:23:00 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
problem since 11.10

Full system reinstall has solved this problem for me.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
Thal (andy-mendyk) wrote :

Well, this is a linux system - I'm not willing to handle it as a Windows system!
Maybe a gnome2 problem - will check next time this issue occurs

This is not gnome2 problem. I had this problem in unity.

Sworddragon (sworddragon) wrote :

On my system the X-Server isn't freezing but the flash video is freezing if I try a fast-forward. Setting EnableLinuxHWVideoDecode to 0 in /etc/adobe/mms.cfg will solve the problem for me too.

I'm using a GeForce 8600 GT with nvidia-current 295.20-0ubuntu1, adobe-flashplugin 11.1.102.63-0precise1 and xserver-xorg-core 2:1.11.4-0ubuntu5 on a 64 bit system.

Sworddragon (sworddragon) wrote :

At least this fast-forward bug seems to be fixed with adobe-flashplugin 11.2.202.228-0precise1.

Changed in nvidia-graphics-drivers (Ubuntu):
assignee: nobody → Oleg "Nightwing" Lomakin (nightwing666)
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers