Ubuntu

Repainting problems on desktop after upgrating to Natty

Reported by Javi Molina on 2011-07-14
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading to Natty I started to see that there are problems repainting the desktop.

As I work through the day, suddenly blocks of the screen are replaced by what it is the background picture, in other cases it is the border of a window that should be behind the one that is bring to first plane.

I started to use Unity and then switched to Ubuntu Classic to start discarding possible culprits. Currently I am running ubuntu classic.

I was running nvidia driver 275.09.07 when running Maverick, and have tried natty supplied driver as well with no difference at all. I
Currently I am running external nvidia driver 275.09.07 as the Ubuntu Additional drivers application failed to restore the previous driver.

I think this problem has been previously reported but I struggle to find similar bug reports.

See the attached pictures

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xorg 1:7.6+4ubuntu3.1
ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
Uname: Linux 2.6.38-10-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 275.09.07 Wed Jun 8 14:16:46 PDT 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu4)
Architecture: amd64
CompizPlugins: [core,commands]
CompositorRunning: None
CurrentDmesg:
 [ 25.096721] tg3 0000:08:00.0: eth0: Flow control is off for TX and off for RX
 [ 25.097047] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
 [ 25.715352] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
 [ 28.952715] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
 [ 2902.357991] exe (8144): /proc/8144/oom_adj is deprecated, please use /proc/8144/oom_score_adj instead.
Date: Thu Jul 14 11:29:44 2011
DistUpgraded: Log time: 2011-07-01 12:29:46.829497
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: nvidia-current, 270.41.06, 2.6.38-10-generic, x86_64: installed
GraphicsCard:
 nVidia Corporation G84 [Quadro FX 1700] [10de:040f] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: nVidia Corporation Device [10de:049a]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
JockeyStatus:
 xorg:nvidia_173 - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, Not in use)
MachineType: Dell Inc. Precision WorkStation T5400
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, user)
 LANG=en_AU.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-10-generic root=UUID=d2d4e47e-8408-44d3-ada3-693a43fb1eba ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg
Symptom: display
UpgradeStatus: Upgraded to natty on 2011-07-01 (12 days ago)
dmi.bios.date: 05/30/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A03
dmi.board.name: 0RW203
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 7
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA03:bd05/30/2008:svnDellInc.:pnPrecisionWorkStationT5400:pvr:rvnDellInc.:rn0RW203:rvr:cvnDellInc.:ct7:cvr:
dmi.product.name: Precision WorkStation T5400
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.4+bzr20110606-0ubuntu1~natty2
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4.1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Javi Molina (javich) wrote :
bugbot (bugbot) on 2011-09-08
affects: xorg (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

Hey javich,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Incomplete
Javi Molina (javich) wrote :

Bug has not appeared on oneiric and I don't think is worth trying to find a solution for natty at this stage.

I am happy to have this bug closed.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → Fix Committed
To post a comment you must log in.