Resume from suspend fails after 3th suspend/resume attempt [LG R590-5700]

Bug #803613 reported by Hélio Nunes on 2011-06-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

No matter what way I put the machine to suspend (hotkey, suspend menu, suspend_test) in the 3th attempt it fails to resume: I hear the disk initializing and fans sound goes high, but backlight is off, keyboard does not respond and wireless led is off. Additionally, TEST 1 (dbus, AC cord on) from suspend_test --full fails to suspend.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-8-generic 2.6.38-8.42
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dedalu 2050 F.... pulseaudio
CRDA: Error: [Errno 2] Arquivo ou diretório não encontrado
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd9100000 irq 46'
   Mixer name : 'Realtek ALC272'
   Components : 'HDA:10ec0272,18540832,00100001'
   Controls : 16
   Simple ctrls : 9
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xd3000000 irq 17'
   Mixer name : 'Nvidia GPU 0d HDMI/DP'
   Components : 'HDA:10de000d,10de0101,00100100'
   Controls : 16
   Simple ctrls : 4
Date: Wed Jun 29 16:15:47 2011
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=15b1a0e3-8294-45bf-8b75-b407aa6cde60
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
MachineType: LG Electronics R590-P.BN58P1
ProcEnviron:
 LANGUAGE=pt_BR:en
 PATH=(custom, user)
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=d885c9b0-0614-41b8-a984-45d7fea64afc ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-8-generic N/A
 linux-backports-modules-2.6.38-8-generic N/A
 linux-firmware 1.52
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/06/2010
dmi.bios.vendor: INSYDE
dmi.bios.version: QL4L3I51
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Base Board Product Name
dmi.board.vendor: Intel Corp.
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvrQL4L3I51:bd01/06/2010:svnLGElectronics:pnR590-P.BN58P1:pvrTBD:rvnIntelCorp.:rnBaseBoardProductName:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion:
dmi.product.name: R590-P.BN58P1
dmi.product.version: TBD
dmi.sys.vendor: LG Electronics

Hélio Nunes (dedalu-dedalu) wrote :
Hélio Nunes (dedalu-dedalu) wrote :

Hibernation works ok after 5 sequential attempts.

Hélio Nunes (dedalu-dedalu) wrote :

Update: sometimes resume from hibernation does not work and I must login in ssh to kill compiz and replace unity.

Hélio Nunes (dedalu-dedalu) wrote :

Solved for me, installing the nvidia-graphics-drivers -275.09.07-0ubuntu1~edgers~natty from xorg-edgers PPA. I didn't need any other packages, so I used a pin on that PPA, forcing only the nvidia-graphics-driver version.

But I did another thing that may interfere: http://paolobernardi.wordpress.com/2011/05/01/fix-plymouth-on-ubuntu-after-installing-nvidia-or-ati-proprietary-drivers-for-ubuntu-11-04-natty/, which installs uvesafb and configures grub to pass mode_option=1024x768-24 to linux.

"May interfere", because I think that this bug is related to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=604094 (chvt breaks resume with binary nvidia driver), since I never could resume properly from console (using single). So, another console mode, could interfere, I don't know...

My overall impression is that this bug is fixed with the new nvidia driver.

Now the '/usr/share/checkbox/scripts/suspend_test --full' completes ok, except for the first test "suspend triggered via dbus message": "SUSPEND FAILED, did not go to sleep".

Hélio Nunes (dedalu-dedalu) wrote :

The nvidia-drivers 275.09.07 has hit x-updates (https://launchpad.net/~ubuntu-x-swat/+archive/x-updates) for natty and is in Oneiric.

Changed in linux (Ubuntu):
status: New → Fix Committed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/803613

tags: added: laptop-testing
affects: linux (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
dino99 (9d9) on 2015-06-26
Changed in nvidia-graphics-drivers (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.