Ubuntu

Installing nvidia-current and still no Unity (driver didn't load, even on reboot)

Reported by Jeff Lane on 2011-05-02
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

Installed Natty to a Lenovo T510. The nouveau drive was installed/loaded by default, and that has issues with 3d acceleration, thus, I get the old classic instead of Unity.

So I ran jockey and installed the nvidia-current driver instead. However, after install, Jockey says that the driver is activated but not currently in use.

I've rebooted a couple of times and each time, nouveau is still loaded, not nvidia current.

I think that the issue is that nouveau is still present. I'm about to purge it and try again, but jockey should have taken care of this for me when it installed nvidia-current anyway.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: nvidia-current 270.41.06-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Uname: Linux 2.6.38-8-generic-pae i686
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DP.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DP.3:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1920x1080 1920x1080 1920x1080 1680x1050 1400x1050 1280x1024 1280x960 1152x864 1024x768 800x600 640x480 720x400 640x400 640x350
 edid-base64: AP///////wAwrrJAAAAAAAETAQOAIhN46iE1rVA3qiQRUFQAAAABAQEBAQEBAQEBAQEBAQEBTDaAgnA4MkA8MKoAWMEQAAAYPy2AgnA4MkA8MKoAWMEQAAAYAAAADwDRCTLRCSgbGQAGr1Y0AAAA/gBCMTU2SFcwMSBWNCAKANY=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Mon May 2 16:14:35 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: nvidia-current, 270.41.06: added
GraphicsCard:
 nVidia Corporation GT218 [NVS 3100M] [10de:0a6c] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:215c]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
MachineType: LENOVO 434926U
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic-pae root=UUID=c8c79b9d-25da-45db-9a71-870e4c4a1bbb ro quiet splash initcall_debug vt.handoff=7
Renderer: Unknown
SourcePackage: nvidia-graphics-drivers
UnitySupportTest:
 Error: command ['/usr/lib/nux/unity_support_test', '-p'] failed with exit code 1: Xlib: extension "GLX" missing on display ":0.0".
 Xlib: extension "GLX" missing on display ":0.0".
 Xlib: extension "GLX" missing on display ":0.0".
 Error: unable to create the OpenGL context
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/26/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6MET81WW (1.41 )
dmi.board.name: 434926U
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6MET81WW(1.41):bd10/26/2010:svnLENOVO:pn434926U:pvrThinkPadT510:rvnLENOVO:rn434926U:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 434926U
dmi.product.version: ThinkPad T510
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Jeff Lane (bladernr) wrote :
tags: added: blocks-hwcert
Jeff Lane (bladernr) wrote :

Ok.... when trying to remove nouveau, I discovered that the install of nvidia-current failed to complete. dpkg --configure -a showed it installing the nvidia dkms stuff and rebuilding the initrd and all that happy stuff.

Jeff Lane (bladernr) wrote :

Ok not sure if this was just a fluke or not, but dpkg --configure -a did resolve the issue. Unity is now running with the nvidia drivers. No idea why the install failed though...

tags: removed: blocks-hwcert
Jeff Lane (bladernr) on 2011-05-03
Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Invalid
kenden (kenden) wrote :

I don't think the bug is invalid, I am getting the issue (no Unity) on a fresh install of Natty on a T420 with a Nvidia NVS 4200M.

Jockey-gtk shows that nvidia-current is installed but not in use.
I did not install proprietary drivers, so I wonder why it is installed.

Note: I did get Unity on Ubuntu Live, during install. Just not after installation.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers