unity worse performance when running with nvidia proprietary driver

Bug #762749 reported by Marlon Nunes on 2011-04-16
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

i don't know exactly to which package i should report the bug against to, but i noted yesterday that when i was running unity
with nvidia proprietary driver installed from the ubuntu repository, the performance of unity was very slow. i removed the proprietary driver and enabled 3D support for the nouveau opensource driver and after that everything work fast and smoothly.
System Info:
Description: Ubuntu Natty (development branch)
Release: 11.04
unity:
  Installed: 3.8.8-0ubuntu2
  Candidate: 3.8.8-0ubuntu2
  Tabela de versão:
 *** 3.8.8-0ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ natty/main amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xorg 1:7.6+4ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,imgpng,vpswitch,move,snap,resize,mousepoll,grid,place,gnomecompat,unitymtgrabhandles,wall,regex,session,animation,expo,workarounds,ezoom,staticswitcher,fade,scale,unityshell]
CompositorRunning: compiz
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1920x1080 1680x1050 1280x1024 1280x1024 1440x900 1280x960 1280x720 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 800x600 640x480 640x480 640x480 640x480 720x400
 edid-base64: AP///////wAF4zYiAQEBAQATAQNoMBt4KjWBplZImiQSUFS/7wCBwIFAgYCVALMAAQEBAQEBAjqAGHE4LUBYLEUA3QwRAAAeAAAA/QA4Sx5QEQAKICAgICAgAAAA/AAyMjM2CiAgICAgICAgAAAA/wAKICAgICAgICAgICAgAPk=
Date: Sat Apr 16 10:10:56 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: virtualbox-ose, 4.0.4, 2.6.38-8-generic, x86_64: installed
GraphicsCard:
 nVidia Corporation C61 [GeForce 7025 / nForce 630a] [10de:03d6] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:83a4]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110413)
Lsusb:
 Bus 002 Device 003: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
 Bus 002 Device 002: ID 0e8f:0021 GreenAsia Inc. Multimedia Keyboard Controller
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: System manufacturer System Product Name
ProcEnviron:
 LANGUAGE=pt_BR:en
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=c4043fb5-ff05-421e-b88c-c397dfb027c9 ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/12/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1102
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M4N68T-M LE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1102:bd06/12/2010:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM4N68T-MLE:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu12
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental 7.10.2-0ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Marlon Nunes (mns) wrote :
Marlon Nunes (mns) on 2011-04-16
description: updated
affects: ubuntu → nvidia-graphics-drivers (Ubuntu)
ZeroBeat (zerobeat) wrote :

Hi Marlon.
Same problem here. First, I thougt it's a bug in unity. After reading your bug-report, I removed the proprietary driver and enabled 3D support for the nouveau opensource driver and after that everything work fast and smoothly.
The following bugs are gone:
bug #747355 briquolo
bug #747363 pathological
bug #747367 tecnoballz
bug# 748025 firefox

Best regards
Mike

Marlon Nunes (mns) wrote :

it's good to see the Nouveau open source driver doing really well, it has a promising future. =)

How can I enable 3d in nouveau?

Daniel van Vugt (vanvugt) wrote :

I've had a lot of success improving the smoothness of the proprietary nvidia driver using this setting (/etc/X11/xorg.conf):

Section "Device"
  Option "DynamicTwinView" "False"
EndSection

It has worked for several different nvidia chips in my experience.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
tags: added: might-be-763005
Daniel van Vugt (vanvugt) wrote :

There is a chance that the fix proposed in bug 763005 might also fix this one. Please test it.

Daniel van Vugt (vanvugt) wrote :

OK, forget my previous comment. NVIDIA users are not benefiting from the fix for 763005.

On another note, this bug might be a duplicate of bug 92599. Please review.

Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 92599, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

tags: removed: might-be-763005
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers