redrawing issues after resolution change

Bug #750440 reported by Paolo Sammicheli on 2011-04-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

Performing weekly test with proprietary Video Driver.
http://testcases.qa.ubuntu.com/Hardware/X/ProprietaryDrivers#Different%20resolutions

Hardware: nVidia GeForce 8600 GTS. Trying to change resolution result in redrawing issues. Attaching a screenshot.

Warning: previous week, this testcase was working perfectly, this is an one week regression!
Last week: http://xorg.qa.ubuntu.com/qatracker/result/5161/421
This week: http://xorg.qa.ubuntu.com/qatracker/result/5343/421

---
Architecture: i386
DistroCodename: natty
DistroRelease: Ubuntu 11.04
DistroVariant: ubuntu
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110404)
NonfreeKernelModules: nvidia
Package: nvidia-graphics-drivers (not installed)
ProcEnviron:
 LANGUAGE=it_IT:en
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Tags: natty running-unity ubuntu
Uname: Linux 2.6.38-7-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu1
---
.proc.driver.nvidia.gpus.0: Error: [Errno 21] È una directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 270.30 Fri Feb 25 14:34:41 PST 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu2)
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
DistUpgraded: Fresh install
DistroCodename: natty
DistroRelease: Ubuntu 11.04
DistroVariant: ubuntu
DkmsStatus: nvidia-current, 270.30, 2.6.38-8-generic, i686: installed
GraphicsCard:
 nVidia Corporation G84 [GeForce 8600 GTS] [10de:0400] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:8241]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110404)
JockeyStatus: xorg:nvidia_current - Driver grafici accelerati nVidia (Proprietario, Abilitato, In uso)
MachineType: System manufacturer P5K-E
NonfreeKernelModules: nvidia
Package: nvidia-graphics-drivers (not installed)
ProcEnviron:
 LANGUAGE=it_IT:en
 PATH=(custom, user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=bf5b0048-d76d-44ac-852d-f6e1adaef946 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Renderer: Unknown
Tags: natty running-unity ubuntu compiz-0.9
Uname: Linux 2.6.38-8-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
  Option "NoPowerConnectorCheck"
 EndSection
dmi.bios.date: 05/25/2007
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0307
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5K-E
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0307:bd05/25/2007:svnSystemmanufacturer:pnP5K-E:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5K-E:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: P5K-E
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.4+bzr20110411-0ubuntu1+r2747+201104121350
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Paolo Sammicheli (xdatap1) wrote :
tags: added: apport-collected natty running-unity ubuntu
description: updated
Paolo Sammicheli (xdatap1) wrote :

Apport-Collect showed an error while completing this bug:

$ apport-collect 750440
The authorization page:
 (https://launchpad.net/+authorize-token?oauth_token=lsX50zkjJxXwX9vwss4Q&allow_permission=DESKTOP_INTEGRATION)
should be opening in your browser. Use your browser to authorize
this program to access Launchpad on your behalf.

Waiting to hear from Launchpad about your decision...
ERROR: hook /usr/share/apport/package-hooks//source_nvidia-graphics-drivers.py crashed:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/apport/report.py", line 656, in add_hooks_info
    symb['add_info'](self, ui)
  File "/usr/share/apport/package-hooks//source_nvidia-graphics-drivers.py", line 446, in add_info
    attach_xorg_package_versions(report, ui)
  File "/usr/share/apport/package-hooks//source_nvidia-graphics-drivers.py", line 293, in attach_xorg_package_versions
    report['version.%s' %(package)] = package_versions(package)
  File "/usr/lib/python2.7/dist-packages/problem_report.py", line 504, in __setitem__
    assert k.replace('.', '').replace('-', '').replace('_', '').isalnum()
AssertionError

Is it another bug to open on launchpad?

description: updated
description: updated
Bryce Harrington (bryce) wrote :

Try running 'apport-collect 750440' again; I think that issue should be fixed now.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Incomplete
Paolo Sammicheli (xdatap1) wrote :

I Just updated the system but the problem is not solved:

$ apt-cache policy nvidia-current
nvidia-current:
  Installato: 270.30-0ubuntu3
  Candidato: 270.30-0ubuntu3
  Tabella versione:
 *** 270.30-0ubuntu3 0
        500 http://it.archive.ubuntu.com/ubuntu/ natty/restricted i386 Packages
        100 /var/lib/dpkg/status

Do you still need I run apport-collect again?

apport information

tags: added: compiz-0.9
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Paolo Sammicheli (xdatap1) wrote :

I just realised that maybe Bryce Harrington meant the apport issue, not the resolution thing. Yes, the apport problem is resolved now, it succesfully uploaded all the information to the bug. The resolution issue is still there, btw.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → New
Bryce Harrington (bryce) wrote :

Hey xdatap1,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Incomplete
Paolo Sammicheli (xdatap1) wrote :

Hello Bryce,

I just performed the testcase with Oneiric and nvidia-current 280.13-0ubuntu6 it works properly.

Marking it fixed release, thanks for the reminder.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers