Ubuntu won't finish boot after nVidia proprietary driver install

Bug #738789 reported by Joaquín Ignacio Aramendía on 2011-03-20
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xorg

Followed these steps:
1. Fresh install of a daily build of Natty just updated (20/3/2011 1:30 pm GMT-3)
2. Log in on Unity with no error from Xorg (GSettings crashed and reported bug successfully).
3. Followed instructions on Installation test for nVidia Proprietary Drivers Xorg Team (http://testcases.qa.ubuntu.com/Hardware/X/ProprietaryDrivers#Installation)
4. When in the step of rebooting, loaded the kernel 2.6.38-7-generic in grub and wait.
5. Ubuntu never got into GUI, not even into the command line as it used to. The last version I tested this (and dumped in the CLI) was Maverick on kernel 2.6.35-28-generic on this machine.

It happens every time I want to install the driver.

Expected result:
GUI or CLI login prompt

Result:
Hang up shell with blinking underscore responsive only to return key to new-line and ctr+alt+del to reboot.

I'll attach logs from kernel, xorg and xorg.conf if apport doesn't do it.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xorg 1:7.6~3ubuntu11
ProcVersionSignature: Ubuntu 2.6.38-7.36-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 270.30 Fri Feb 25 14:34:55 PST 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-6ubuntu4)
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: None
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64: AP///////wAGr+wjAAAAAAETAQOQIhN4CsiVnldUkiYPUFQAAAABAQEBAQEBAQEBAQEBAQEBsBxWoFAAIjAgGDQAWMEQAAAasBxWoFAAIjAgGDQAWMEQAAAaAAAA/gBXNDY1UoFCMTU2WFcyAAAAAAAAAAAAAAAAAAEBCiAgAMo=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
Date: Sun Mar 20 13:21:32 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: nvidia-current, 270.30, 2.6.38-7-generic, x86_64: installed
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 18) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:044e]
 nVidia Corporation GT218 [GeForce 310M] [10de:0a75] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:044e]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110320)
JockeyStatus:
 kmod:wl - Broadcom STA wireless driver (Proprietary, Disabled, Not in use) [auto-install]
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
MachineType: Dell Inc. Vostro 3500
ProcEnviron:
 LANGUAGE=es_AR:en
 LANG=es_AR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=fea1fced-1a8e-47b2-96aa-1cf49a2955f6 ro single
Renderer: Unknown
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/10/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A08
dmi.board.name: 0NVXFV
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnDellInc.:bvrA08:bd09/10/2010:svnDellInc.:pnVostro3500:pvrNotSpecified:rvnDellInc.:rn0NVXFV:rvrA00:cvnDellInc.:ct8:cvrNotSpecified:
dmi.product.name: Vostro 3500
dmi.product.version: Not Specified
dmi.sys.vendor: Dell Inc.
nvidia-settings:
 (process:1944): Gtk-WARNING **: Locale not supported by C library.
  Using the fallback 'C' locale.
version.compiz: compiz 1:0.9.4-0ubuntu7
version.libdrm2: libdrm2 2.4.23-1ubuntu5
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

bugbot (bugbot) on 2011-03-21
affects: xorg (Ubuntu) → nvidia-graphics-drivers (Ubuntu)

Apport info

Apport info

Attachments in comments #2 and #3 are apport generated reports from the same issue in today's daily build of natty.

Also tried to plug an external monitor but only got the same output twice. The boot won't finish but is responsive to ctrl+alt+F1 to enter a tty console. There i got this two files.

Hope is useful

Changed in nvidia-graphics-drivers (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed

More apport report messages in next attachments. Should I still upload more info on future daily builds? This are from today's natty daily build.

Ok, news. Today's build failed. But something changed.

Following instructions on Installation test case:
http://testcases.qa.ubuntu.com/Hardware/X/ProprietaryDrivers#Installation

# Falied at step 7. xorg.conf didn't list the proprietary driver but no problem.
# I rebooted and got into GUI (the nvidia module was not loaded).
# I ran nvidia-xconfig to generate the xorg.conf.
# Rebooted and got the same result as previous test, won't boot into GUI or CLIA.
# Switched to console (ctrl+alt+F1) and got the apport info on both nvidia-current and xorg packages. Also I'm attaching both xorg.conf's before and after nvidia-xconfig

Jukka Siitari (reed-siitari) wrote :

The problem still persists today on different nVidia card and driver - see https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/782868

barnex (barnex) wrote :

I have a similar problem.

After upgrading my ubuntu 11.04 to kernel 2.6.38-10, the nvidia-current driver stopped working.
I upgraded my system with the normal software updates. I had to remove the driver (with jockey, over ssh) to get my display back. Before that I could not even get into a tty - just a black screen.

Bryce Harrington (bryce) wrote :

Hey samsagax,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Incomplete

Oh. I totally forgot this issue. In fact this is part of a major issue: No support in any way for Hybrid-graphics under GNU/Linux. You can close this issue, but don't mark it as "solved" as it isn't. I switched distros (to ArchLinux) about 5~6 months ago.

I'm sorry for the delay. But the best thing to do is to provide the best effort to get Hybrid-graphics cards supported. They are a reality and in fact all laptops now have this tech/crap on them, so there is no escape from user frustration in that matter.

If I can help in any way, please let me know.

Launchpad Janitor (janitor) wrote :

[Expired for nvidia-graphics-drivers (Ubuntu) because there has been no activity for 60 days.]

Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → Expired
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/738789

tags: added: laptop-testing
Rocko (rockorequin) wrote :

Just a note that I still get this occasionally in Ubuntu 16.04 and 16.10, usually after moving to a new series of the nvidia driver, and my case the problem is that nvidia overwrites the /usr/lib/xorg/modules/extensions/libglx.so and /usr/lib/x86_64-linux-gnu/libGL.so files (eg "ldd /usr/lib/x86_64-linux-gnu/libGL.so|grep -i nvidia" shows nvidia in the file).

A workaround when this happens is to install nvidia-prime and run "sudo prime-select intel" to reset to using the intel libraries.

To post a comment you must log in.