Failed to detect second monitor (no XRandR 1.2 support)

Bug #737349 reported by Ofir Klinger on 2011-03-18
62
This bug affects 10 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Medium
Canonical X.org
Natty
Medium
Unassigned

Bug Description

Following the test case from here:
http://testcases.qa.ubuntu.com/Hardware/X/ProprietaryDrivers#Monitor%20HotPlugging

The second monitor isn't detected even after reboot, running xrandr confirms that.

Running:
xrandr --output DVI-0 --auto --left-of VGA-0 --auto
fails as expected.

Using NVIDIA X Server Settings works right away (for extended monitor).

http://xorg.qa.ubuntu.com/qatracker/result/5154/423

Changed in nvidia-graphics-drivers (Ubuntu Natty):
status: New → Confirmed
importance: Undecided → Medium
Changed in nvidia-graphics-drivers (Ubuntu Natty):
importance: Medium → High
Changed in nvidia-graphics-drivers (Ubuntu Natty):
assignee: nobody → Canonical X.org (canonical-x)
Ofir Klinger (klinger-ofir) wrote :

Same results as in the bug description for this week's test.
http://xorg.qa.ubuntu.com/qatracker/result/5161/423

Martin Pitt (pitti) wrote :

Not a release critical bug, lowering severity.

Changed in nvidia-graphics-drivers (Ubuntu Natty):
importance: High → Medium
Alberto Milone (albertomilone) wrote :

The main problem here is the fact that the nvidia driver doesn't support the RandR 1.2 protocol, therefore neither the following command nor monitors hotplug are expected to work:

xrandr --output DVI-0 --auto --left-of VGA-0 --auto

Martin Pitt (pitti) wrote :

Ah, so it seems this isn't a regression at all. Untargetting for natty then.

Changed in nvidia-graphics-drivers (Ubuntu Natty):
status: Confirmed → Won't Fix
assignee: Canonical X.org (canonical-x) → nobody
Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Triaged
summary: - Failed to detect second monitor
+ Failed to detect second monitor (no XRandR 1.2 support)

How is this not a regression?

If a use-case worked in 10.10 and now does not work in 11.04 (monitor detection on specific hardware using the supplied accelerated driver), how is that not a regression?

And why won't this be fixed?

Chris Halse Rogers (raof) wrote :

As far as I can tell, this isn't a regression because it *didn't* work under 10.10 and isn't expected to work until the nvidia drivers support XRandR 1.2.

As for why it won't be fixed: it won't be fixed because we can't (reasonably) fix it. We don't have the source code for the binary drivers, so we can't (reasonably) fix bugs in them.

My setup: Dell Precision M4500 laptop with NVidia Quadro FX 880M with external TFT monitor.

Ubuntu 10.10 external monitor was detected. (using NVidia's binary driver as provided by Ubuntu)
Ubuntu 11.04 exteernal monitor is not detected. (using NVIdia's binary driver as provided by Ubuntu)

By all means feels like a regression to me.

RubbelDieCatc (rubbel) wrote :

I can confirm the problem and the report from esben.

It is a regression because the second screen worked fine in 10.10.

So it is not a MINOR Problem because nearly every users with an nvidia laptop or more than one screen will have the same issue.

1: Ubuntu does not detect second screen.....
2: ... Compiz and the Window Manager will not be active for this screen
3: ... second Monitor is nearly unsuable because of this

Maybe it is important.

Michael Zeng (michaelzeng7) wrote :

Actually, when I was on Ubuntu 10.04 or 10.10 (forgot) the screen went down and lots of colored lines came up on the screen as if it corrupted. I was running on a IBM ThinkPad T42. I bought a new T61 and made a fresh install of Ubuntu 11.04 (natty) and now it gives no notice of any second monitor. I really do not know if the 10.10 error was the same problem as this one, but I am sure the natty bug is this one.

See my question here: http://askubuntu.com/questions/78237/unity-3d-with-nvidia-driver-becomes-very-slow-and-laggy

TwinView works with binary drivers, but /usr/bin/X starts to use lots of CPU after a while and everything becomes laggy.

Nouveau drivers do not lag, but randr -q fails to pick up my second monitor.

The Nouveau docs (nouveau.freedesktop.org/wiki/Randr12) say that Xrandr 1.2 is complete and should work -- so why does this bug exist?

Timo Aaltonen (tjaalton) wrote :

Graham: run 'ubuntu-bug xserver-xorg-video-nouveau' if it doesn't do multi-monitor. Not related to this bug.

Bryce Harrington (bryce) wrote :

The nvidia we have in precise now supports RandR 1.2, so theoretically this issue should now be gone.

Can someone please re-test and confirm?

Changed in nvidia-graphics-drivers (Ubuntu):
status: Triaged → Incomplete
Bryce Harrington (bryce) wrote :

Given lack of input, I'll assume no one disagrees and that this is indeed resolved now that nvidia supports xrandr 1.2.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers