emacs23/rxvt/xawtv/vlc crash Xorg w/ proprietary NVIDIA driver

Bug #683016 reported by Robert Fleming on 2010-11-30
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 10.10
nvidia-current=260.19.06-0ubuntu1
nvidia-kernel-common=20080825+1ubuntu2
nvidia-common=0.2.24

From comment 136 on bug 650539:

> Exactly what problem are you seeing?
>
> If you've got problems in a single monitor setup then you'll be
> triggering a different bug. Please feel free to file a new bug so we
> can start to figure out the cause of your problem.

I'm seeing the same problem as Jérôme and Mauro [from bug 650539]. I have exactly one NVIDIA display adapter, using the proprietary driver (version 173 and "current" both exhibit the problem), and the adapter is attached to exactly one monitor. Emacs, rxvt, VLC, and xawtv each crash the server. Here is the Xorg output:

  Backtrace:
  0: X (xorg_backtrace+0x3b) [0x80e82fb]
  1: X (0x8048000+0x5da8d) [0x80a5a8d]
  2: (vdso) (__kernel_rt_sigreturn+0x0) [0x13e40c]
  3: X (ProcessWorkQueue+0x30) [0x8073a60]
  4: X (WaitForSomething+0x56) [0x809fc06]
  5: X (0x8048000+0x25d3e) [0x806dd3e]
  6: X (0x8048000+0x1a5ba) [0x80625ba]
  7: /lib/libc.so.6 (__libc_start_main+0xe7) [0xd3ace7]
  8: X (0x8048000+0x1a191) [0x8062191]
  Segmentation fault at address (nil)

  Caught signal 11 (Segmentation fault). Server aborting

I ran through half of the demos in the "qtdemo" package and none crashed the server. (I don't have all the KDE infrastructure installed, so I didn't test that.) So it does not seem to be related to bug 650539. The server does *not* crash when using the free-software NVIDIA driver.

I have not been able to disable the Xinerama extension either by putting 'Option "Xinerama" "0"' in the "ServerLayout" sections, or by using the "-xinerama" command-line argument to /usr/bin/Xorg. I've read that the NVIDIA driver forces it on or something.

Also, "ubuntu-bug" accused my of installing NVIDIA drivers manually from nvidia.com. I did not.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: nvidia-current 260.19.06-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-23.40-generic 2.6.35.7
Uname: Linux 2.6.35-23-generic i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 260.19.06 Mon Sep 13 06:35:06 PDT 2010
 GCC version: gcc version 4.4.5 (Ubuntu/Linaro 4.4.4-14ubuntu5)
Architecture: i386
Date: Tue Nov 30 02:00:09 2010
DkmsStatus: Error: [Errno 2] No such file or directory
MachineType: Dell Inc. Dimension 9100
ProcCmdLine: root=/dev/md0 ro quiet splash
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/tcsh
SourcePackage: nvidia-graphics-drivers
UdevDb: Error: [Errno 2] No such file or directory
dmi.bios.date: 05/25/2005
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A01
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 7
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA01:bd05/25/2005:svnDellInc.:pnDimension9100:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct7:cvr:
dmi.product.name: Dimension 9100
dmi.sys.vendor: Dell Inc.
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.35-23-generic

Robert Fleming (fleming) wrote :
Jérôme (kibohely) wrote :

As Robert wrote, i also meet this bug in the same condition.

- Sony Vaio z series;
- Ubuntu 10.10 64bits
- Nvidia Geforce GT 330
- last NVIDIA drivers

I also have a intel card in this laptop (with a switch to use it or the nvidia), and it's work without changing anything (except gl lib needed for 3d acceleration)

Hergen Lehmann (hergen-snafu) wrote :

I'm experiencing this bug, too

- Zotac ION ITX
- Ubuntu 10.10 32bit
- Single screen configuration
- NVIDIA closed source drivers from distribution

Many QT based applications seem to be affected. In addition to those listed in the bug title, i have also problems with keepassx and smplayer. Some apps crash the x server immediately, others only when trying to work with them (e.g. opening dialog boxes).

Hergen Lehmann (hergen-snafu) wrote :

Because this bug is extremly annoying, i looked a bit further into what is happening.
Running the X server in gdb gives the following details on the crash:

----------snip------
Program received signal SIGSEGV, Segmentation fault.
0x08096feb in doListFontsWithInfo (client=0x8ad5d58, c=0x8b28dc8)
    at ../../dix/dixfonts.c:920
920 ../../dix/dixfonts.c: No such file or directory.
 in ../../dix/dixfonts.c
(gdb) bt
#0 0x08096feb in doListFontsWithInfo (client=0x8ad5d58, c=0x8b28dc8)
    at ../../dix/dixfonts.c:920
#1 0x08094200 in ProcessWorkQueue () at ../../dix/dixutils.c:527
#2 0x080a2766 in WaitForSomething (pClientsReady=0x8a401e0)
    at ../../os/WaitFor.c:169
#3 0x08080c4e in Dispatch () at ../../dix/dispatch.c:368
----------snip------

The blameworthy code in dixfonts.c looks like this:

    918 while (c->current.current_fpe < c->num_fpes)
    919 {
    920 fpe = c->fpe_list[c->current.current_fpe];
    921 err = Successful;

So lets take a look into the ominous "c":

----------snip------
(gdb) print *c
$1 = {client = 0x8b292c8, num_fpes = 145920400, fpe_list = 0x0, reply = 0x0,
  length = 228, current = {
    pattern = "-sony-fixed-medium-r-normal--16-120-100-100-c-80-iso8859-1\262\b", '\000' <repeats 192 times>, "-\000\000", patlen = 58, current_fpe = 0,
    max_names = 0, list_started = 1, private = 0x0}, saved = {
    pattern = "\b\b\b\b\t\t\t\t\n\n\n\n\v\v\v\v\f\f\f\f\r\r\r\r\r\r\r\r\016\016\016\016\017\017\017\017\017\017\017\017", '\020' <repeats 12 times>, '\021' <repeats 44 times>, '\020' <repeats 12 times>, "\017\017\017\017\017\017\017\017\016\016\016\016\r\r\r\r\r\r\r\r\f\f\f\f\v\v\v\v\n\n\n\n\t\t\t\t\b\b\b\b\a\a\a\a\006\006\006\006\005\005\005\005\004\004\004\004\003\003\003\003\001\001\001\001", '\000' <repeats 83 times>, patlen = 0, current_fpe = 0, max_names = 0,
    list_started = 0, private = 0x0}, savedNumFonts = 0, haveSaved = 0,
  savedName = 0x0}
----------snip------

Note, that c->fpe_list is NULL, while c->num_fpes contains an unreasonable value.
When printing this value in hex, it actually looks like a pointer instead of the
expected count. I guess, the data structure has either been corrupted somewhere or
c points to something completely wrong.

At this point i must give up; i don't understand enough on the interna of the x server.

Try uninstalling xfs.

sudo apt-get remove xfs

Bryce Harrington (bryce) wrote :

145920400 is 0x08B29190 which does look a little like a pointer (would be more convincing if it was 8 digits of hex rather than 7 or if the hex value matched one of the pointers in the backtrace), but it probably is merely an uninitialized integer, and just looks similar because its the same byte size as an ordinary pointer.

Fjodor (sune-molgaard) wrote :

Ashley's suggestion of removing xfs worked for me...

bugbot (bugbot) wrote :

Hey Robert,

Hi, have you had a chance to test if this bug is still present in natty?

If it does (and if you're the original reporter), please boot into natty
and run the command:

  apport-collect <bug-number>

which will update the bug with fresh logs and tag the bug as affecting
natty. (It is best to run this right after reproducing the problem.)

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Incomplete
bugbot (bugbot) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → Expired

.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 173.14.30 Sat Apr 16 21:49:29 PDT 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu4)
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: kwin
DistUpgraded: Fresh install
DistroCodename: natty
DistroRelease: Ubuntu 11.04
DistroVariant: kubuntu
DkmsStatus:
 nvidia-current, 270.41.06, 2.6.38-8-generic, x86_64: installed
 virtualbox-ose, 4.0.4, 2.6.38-8-generic, x86_64: installed
 nvidia-173, 173.14.30, 2.6.38-8-generic, x86_64: installed
GdmLog1:

GdmLog2:

GraphicsCard:
 nVidia Corporation G96 [Quadro FX 580] [10de:0659] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: nVidia Corporation Device [10de:063a]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
JockeyStatus:
 xorg:nvidia_173 - NVIDIA accelerated graphics driver (Proprietary, Enabled, Not in use)
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
MachineType: Dell Inc. Precision WorkStation T5500
NonfreeKernelModules: nvidia
Package: nvidia-graphics-drivers (not installed)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=80cd9220-f6a7-4712-97fe-44dacf666148 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Renderer: Unknown
Tags: natty kubuntu patch
Uname: Linux 2.6.38-8-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 09/16/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.name: 0CRH6C
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 7
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd09/16/2010:svnDellInc.:pnPrecisionWorkStationT5500:pvr:rvnDellInc.:rn0CRH6C:rvrA00:cvnDellInc.:ct7:cvr:
dmi.product.name: Precision WorkStation T5500
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

tags: added: apport-collected kubuntu natty patch

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in nvidia-graphics-drivers (Ubuntu):
status: Expired → Confirmed

I experience this problem also on Natty. I reopened the bug, as instructed, and provided information using apport-collect. I ran apport-collect after provoking an X crash, and then logging in again.

The problem is easy to reproduce by starting emacs, nxclient, or a few other applications whose names I currently don't remember.

Removing xfs did not work for me. KDE hangs when I login. If anyone has hints on how to run KDE without xfs, I am interested.

Regards,

Lars Albertsson

dino99 (9d9) wrote :

That version is no more supported; please open a new bug report if the actual archive found version also has the same issue.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers