Ubuntu

Xorg.log flooded with specific Xalloc warning message about 0 size memory

18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-173 (Ubuntu)
Undecided
Unassigned
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned
nvidia-graphics-drivers (Unity Linux)
New
Undecided
Unassigned

Bug Description

Binary package hint: xorg

my Xorg.log is being flooded by the following message :
"Warning: Xalloc: requesting unpleasantly large amount of memory: 0 bytes."

I use nvdia drivers in Ubuntu 10.10.
I don't really noticed anything unusual in my system other than these messages and the fact that the mouse sometimes send left clicks very quickly and so are recognised as double clicks (but the mouse bug may be a hardware problem really).

If you need further info please ask

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xorg 1:7.5+6ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-23.40-generic 2.6.35.7
Uname: Linux 2.6.35-23-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 173.14.28 Wed Sep 29 09:44:58 PDT 2010
 GCC version: gcc version 4.4.5 (Ubuntu/Linaro 4.4.4-14ubuntu5)
Architecture: amd64
Date: Fri Nov 26 23:50:48 2010
DkmsStatus:
 nvidia-173, 173.14.28, 2.6.35-22-generic, x86_64: installed
 nvidia-173, 173.14.28, 2.6.35-23-generic, x86_64: installed
 vboxhost, 3.2.10, 2.6.35-23-generic, x86_64: installed
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
Lsusb:
 Bus 002 Device 004: ID 09da:000e A4 Tech Co., Ltd
 Bus 002 Device 003: ID 045e:00dd Microsoft Corp. Comfort Curve Keyboard 2000 V1.0
 Bus 002 Device 002: ID 04cc:1122 ST-Ericsson Hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: MICRO-STAR INTERNATIONAL CO., LTD MS-7100
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-23-generic root=UUID=ae44f7ca-9f24-4765-b5bc-ca0dcc978dab ro quiet splash
ProcEnviron:
 LANGUAGE=en
 PATH=(custom, user)
 LANG=el_GR.utf8
 SHELL=/bin/bash
SourcePackage: xorg
dmi.bios.date: 10/27/2008
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: MS-7100
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO., LTD
dmi.board.version: 1.0
dmi.chassis.type: 3
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd10/27/2008:svnMICRO-STARINTERNATIONALCO.,LTD:pnMS-7100:pvr1.0:rvnMICRO-STARINTERNATIONALCO.,LTD:rnMS-7100:rvr1.0:cvn:ct3:cvr:
dmi.product.name: MS-7100
dmi.product.version: 1.0
dmi.sys.vendor: MICRO-STAR INTERNATIONAL CO., LTD
system:
 distro: Ubuntu
 codename: maverick
 architecture: x86_64
 kernel: 2.6.35-23-generic

bugbot (bugbot) on 2010-11-27
affects: xorg (Ubuntu) → nvidia-graphics-drivers-180 (Ubuntu)
Timo Aaltonen (tjaalton) on 2011-04-26
affects: nvidia-graphics-drivers-180 (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
bugbot (bugbot) wrote :

Hey Γουργιώτης,

Hi, have you had a chance to test if this bug is still present in natty?

If it does (and if you're the original reporter), please boot into natty
and run the command:

  apport-collect <bug-number>

which will update the bug with fresh logs and tag the bug as affecting
natty. (It is best to run this right after reproducing the problem.)

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Incomplete
Aldo Maggi (sentiniate) wrote :

i'm experiencing the same problem with natty
if from gdm window i choose "ubuntu classic (with no effects)" Xorg log file doesn't show anything strange;
if i choose "ubuntu classic" the warning "Xalloc: requesting unpleasantly large amount of memory: 0 bytes." appears just once but Xorg seems to work well,
if i choose "ubuntu" the warning is repeated endlessly , Xorg leaves the wallpaper of gdm and no icon is diplayed, htop shows that it (Xorg) is running

Aldo Maggi (sentiniate) wrote :
Bryce Harrington (bryce) wrote :

Run under natty:
   apport-collect 681945

tags: added: natty
Aldo Maggi (sentiniate) wrote :

i've tried yesterday to do so, but the answer was that i was not allowed because it wasn't me who started the bug report.
if you tell me what are the files you need i'll get them manually

Tiago Nunes Silveira (tiagon72) wrote :

ubuntu classic mode without effect, it did not work here

Tiago Nunes Silveira (tiagon72) wrote :

forgot to say, the error happens when I start a game, it gets very slow.

mrtwister (mrtwister) wrote :

I have the same problem on 10.04, however only when running a Windows XP guest on Virtualbox 4.0.4. Additionally the Virtualbox guest window sometimes doesn't get refreshed anymore, unil I resize the window several times.

Changed in nvidia-graphics-drivers-173 (Ubuntu):
status: New → Confirmed
Tomodachi (tomodachi) wrote :

problem still around with oneiric

Garry Leach (garry-leach) wrote :

I am using 11.04.

I have had problems with displaying the Grub boot menu, plus getting a warning from the monitor (Dell 24 inch) about matching the resolution. After much "research" & some trial & error with changing Grub2's input files (GFXMODE & VGA=), I now have the grub menu, but I do get an Ubuntu error msg (about VGA=, which I realise is unrelated to this bug).

So I tried running in recovery mode & that is when I received the error msg about memory.

I have an nVidia Corporation G96 [GeForce 9500 GT] (rev a1) chip on a card, & "using" NVidia accelerated graphics driver (version 173), although the Additional Drivers tool says that it is activated but not in use (I have read that this msg is incorrect). I previously had the "version current" installed, but changed it when it also said that it was not in use...

I also get a major failure when I try to return to the desktop (from a console), using ctl/alt/F7; only the bottom half of the screen shows anything, but it is gibberish.

Regards, Garry.

Bryce Harrington (bryce) on 2012-02-04
Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → Confirmed

hi all, i'm the original reporter of the bug and i'm not facing this bug anymore neither in my 11.10 nor in my 12.04 installation.
thanks

forgot to tell, i'm using 280 version of nvidia drivers
$ sudo apt-cache show nvidia-current | grep Version
Version: 280.13-0ubuntu6

To post a comment you must log in.