X does not launch directly on startup

Bug #654516 reported by Mathias Friman on 2010-10-04
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

Maverick Meerkat development branch does not boot X at startup.

I run latest nVidia-drivers (256.53) and i get a text-only login prompt.

After login, i run "startx" to start the GUI which executes nicely, and get a gnome-keyring window to connect to my WLAN. After a couple of minutes the Xorg seems to start a second time. I guess this is the original startup. I've tried waiting for it to start naturally, but if I don't login in text-only mode, the GUI does not start at all.

The information included is reported with apport _before_ i manually start the GUI.

Sorry for the crappy bug report, I hope that you could get something out of it anyway.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xorg 1:7.5+6ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 256.53 Fri Aug 27 20:27:48 PDT 2010
 GCC version: gcc version 4.4.5 (Ubuntu/Linaro 4.4.4-14ubuntu5)
Architecture: amd64
CurrentDmesg:
 [ 16.106121] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
 [ 65.822257] cfg80211: Found new beacon on frequency: 2472 MHz (Ch 13) on phy0
Date: Mon Oct 4 12:15:10 2010
DkmsStatus:
 nvidia-current, 256.53, 2.6.35-22-generic, x86_64: installed
 nvidia-current, 256.53, 2.6.35-19-generic, x86_64: installed
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64 (20100901.1)
MachineType: Zepto Znote
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic root=UUID=b1eaa9e8-71a3-46fb-bf76-2ea26c46594b ro quiet splash
ProcEnviron:
 LANG=sv_SE.UTF-8
 SHELL=/bin/bash
SourcePackage: xorg
Symptom: display
dmi.bios.date: 09/30/2007
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: Z15N011
dmi.board.name: Znote
dmi.board.vendor: Zepto
dmi.board.version: 6025WD/6625WD
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: Zepto
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrZ15N011:bd09/30/2007:svnZepto:pnZnote:pvr6025WD/6625WD:rvnZepto:rnZnote:rvr6025WD/6625WD:cvnZepto:ct1:cvrN/A:
dmi.product.name: Znote
dmi.product.version: 6025WD/6625WD
dmi.sys.vendor: Zepto
system:
 distro: Ubuntu
 codename: maverick
 architecture: x86_64
 kernel: 2.6.35-22-generic

Mathias Friman (mathias-friman) wrote :

Got the exact same problem with a nvidia 8600gtm on ubuntu 10.04

johannes (johannes-simeonidis) wrote :

Also affected by this. However, X loads after about 2-3 minutes at the login prompt.
At the moment I have a znote 6625 with 8600m gt on linux mint 10.10 Gnome 32-bit RC.

Bryce Harrington (bryce) on 2010-11-04
affects: xorg (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers