Ubuntu

Plymouth doesn't show Kubuntu or Ubuntu logo with Nvidia proprietary driver. NVIDIA does not provide compatible framebuffer.

Reported by Alessandro Ghersi on 2010-10-01
208
This bug affects 37 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
nvidia-graphics-drivers (Ubuntu)
Wishlist
Unassigned

Bug Description

This is a regression. In Kubuntu Maverick with Nvidia Driver enabled (256.53-0ubuntu3) plymouth doesn't show the Kubuntu logo, it shows only the Kubuntu Text.

In Lucid it works. So I installed the Lucid kernel from here: https://launchpad.net/ubuntu/+source/linux/2.6.32-21.32
and if I boot the Maverick machine with that Kernel (2.6.32-21.32) Plymouth is able to shows the Kubuntu logo.

It's not a problem in Plymouth, I try also the plymouth version which is in Lucid but it didn't work.
And it's not a problem in the Kubuntu theme.

My Nvidia card is a GTX 260.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: linux-image-2.6.35-22-generic-pae 2.6.35-22.33
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic-pae 2.6.35.4
Uname: Linux 2.6.35-22-generic-pae i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: VT1708S Analog [VT1708S Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: lex 2222 F.... pulseaudio
 /dev/snd/pcmC0D0p: lex 2222 F...m pulseaudio
CRDA: Error: [Errno 2] Nessun file o directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf9ff8000 irq 45'
   Mixer name : 'VIA VT1708S'
   Components : 'HDA:11060397,10438346,00100000'
   Controls : 37
   Simple ctrls : 21
Date: Fri Oct 1 22:56:37 2010
HibernationDevice: RESUME=UUID=47d5de40-3360-4eb2-8fd6-e76be305683c
InstallationMedia: Kubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.2)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.

 vboxnet0 no wireless extensions.
MachineType: System manufacturer System Product Name
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic-pae root=UUID=9b230cac-d867-427e-a407-f6f89a4722c3 ro quiet splash
ProcEnviron:
 LANGUAGE=it_IT
 PATH=(custom, no user)
 LANG=it_IT.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.38
RfKill:

SourcePackage: linux
dmi.bios.date: 08/28/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 2204
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5Q SE PLUS
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr2204:bd08/28/2009:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5QSEPLUS:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

tags: added: iso-testing kubuntu
Changed in linux (Ubuntu):
milestone: none → ubuntu-10.10
status: New → Confirmed
Giuseppe Pennisi (giupenni78) wrote :

I have the same problem with nVidia cart GeForce 8400 GS.
Kernel: 2.6.35-22-generic-pae

summary: - Plymouth doesn't show Kubuntu logo with Nvidia proprietary driver
+ Plymouth doesn't show Kubuntu or Ubuntu logo with Nvidia proprietary
+ driver
Changed in ubuntu-release-notes:
status: New → Confirmed
Jesse Palser (jessepalser) wrote :

Running Ubuntu 10.10 RC 32bit.
Using 260.19.06 nVidia proprietary drivers
with an nVidia GeForce GT 240 1GB PCIe graphics adaptor.

On startup and shutdown the nice Ubuntu logo is not shown
and ugly texts of background processes are shown.

Hope you can fix this soon!

Changed in ubuntu-release-notes:
status: Confirmed → Fix Released
Changed in linux (Ubuntu):
milestone: ubuntu-10.10 → maverick-updates
Artur Rona (ari-tczew) wrote :

Does your plymouth looks like in this photo?
Sorry for poor quality, phone aparat.

Yes it looks like that, with only text.

Boynas (garyflores) wrote :

I am having the same problem Ubuntu 10.10 final with NVIDIA (CURRENT) driver.

Artur Rona (ari-tczew) wrote :

Could someone test script/work-around from following link and give feedback? http://kyleabaker.com/2010/07/11/how-to-fix-your-ubuntu-boot-screen/

MaksimKa (netvin) wrote :

I have ubuntu and same issue. No logo at all. Just text

MaksimKa (netvin) wrote :

Booting screen looks for me like this:

MaksimKa (netvin) wrote :

and shutdown screen looks like this:

Spencer Gibb (spencer-gibb) wrote :

I had the same problem and used the following from ubuntu forums to get the nice boot screen

http://ubuntu-virginia.ubuntuforums.org/showthread.php?p=9749459

Glenn (glenn-rivkees) wrote :

I had the same problem and it was easily fixed by an addition to the kernel boot command.
In addition to "nouveau.modset=0" to deactivate the default driver and allow it to use the proprietary driver
I also added "vga=868" (no quotes in either one) to the kernel command.
Where 868 is the code that represents your screen found here http://en.wikipedia.org/wiki/VESA_BIOS_Extensions#Linux_video_mode_numbers

From what I can tell, once the NVidia driver starts, there is no issue, but the kernel starts before that, so the vga=### command tells the kernel what resolution to use.

thom_51 (thom-51) on 2010-10-13
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
MaksimKa (netvin) on 2010-10-13
Changed in linux (Ubuntu):
status: Fix Released → Confirmed

If somebody adds vga=xxx to the kernel command, what happens when a new kernel is released as an update and they install it?
The old kernel command is not used any more and they have to add vga=xxx again, on and on.
Also, how come this has gotten "Fix Released"? I mean, it still affects me.
I have a 1920x1080 resolution, what video mode would be good for me? (I can't find my resolution to the tables)
Thanks.

iCe (iceclow) wrote :

I had a similar problem after installing nvidia drivers on Ubuntu 10.04. I fixed it following this tutorial, option 1: http://news.softpedia.com/news/How-to-Fix-the-Big-and-Ugly-Plymouth-Logo-in-Ubuntu-10-04-140810.shtml

After upgrading to 10.10 the workaround is still working, and I see a nice boot screen. This my grub.cfg line:

linux /boot/vmlinuz-2.6.35-22-generic root=UUID=d8df72bc-5eb0-4f73-98bc-2561cd4e6ced ro quiet splash nomodeset video=uvesafb:mode_option=1280x1024-24,mtrr=3,scroll=ywrap

And my /etc/initramfs-tools/conf.d/splash content:

cat /etc/initramfs-tools/conf.d/splash
FRAMEBUFFER=y

Hope it helps!

I used the same workaround as iCe and it works perfectly for me both on Lucid and Maverick.

This should be properly fixed. The "fix released" does not represent anything here.

Scott Kitterman (kitterman) wrote :

It's marked fix released against ubuntu-release-notes. All that means is it's documented there (and it is). The bug is still open against the kernel.

iCe (iceclow) wrote :

A script to easily do the steps I mention in #15 has been post at WebUpd8

http://www.webupd8.org/2010/10/script-to-fix-ubuntu-plymouth-for.html

Boynas (garyflores) wrote :

Wait a second, I thought that bugs.launchpad.net was a forum to call bugs out and let developers know about bugs and try to help them with details to have them fix.

While having a bunch of ways to patch the issue is very nice because we don't have to "suffer" every time that we turn the system on or off; I thought that this space was to have the issue resolved for people who will be installing the system from scratch without the need to patch it with a script or editing files.

Being that said, do we have to still complain about the issue or keep recommending new ways to patch the issue?

With respect. Thanks to all the devs

Ofir Klinger (klinger-ofir) wrote :

This bug effects me too. I have nVidia 9600GT and I see the same screens posted in comments 10 and 11.

This should be fixed through the update system since it looks very bad that Ubuntu (and Kubuntu, in my case) boots with this ugly screen.

Sense Egbert Hofstede (sense) wrote :

I can confirm that this is still an issue in Ubuntu Natty Narwhal pre-Alpha.

tags: added: natty regression-release
removed: regression-proposed
Changed in linux (Ubuntu):
milestone: maverick-updates → none
Jeremy Foshee (jeremyfoshee) wrote :

not sure how I managed to remove the milestone... fixed.

~JFo

Changed in linux (Ubuntu):
milestone: none → maverick-updates
HX_unbanned (linards-liepins) wrote :

Where is problem to put this script as run-once within plymouth setup when upgrading / installing Ubuntu Distro(s) ?

Currently this issue is DBD ... so the smallest thing you can do is to make this workaround available until real fix is released ... am I wrong?

HX_unbanned (linards-liepins) wrote :

Ooopps ... sorry, somehow jumped over status ...

Pardon.

Andy Whitcroft (apw) wrote :

It is not at all clear that this is a kernel issue. When installing the binary drivers the frame buffers no longer work, which lead to the texttual boot. The insertion of the manually configured uvesafb or similar would not be something the main kernel would do here. This seems like an issue with the proprietry drivers and as such should be filed against them. Opening a task against the Nvidia binary driver packaging.

affects: linux (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Bryce Harrington (bryce) on 2012-02-03
summary: Plymouth doesn't show Kubuntu or Ubuntu logo with Nvidia proprietary
- driver
+ driver. NVIDIA does not provide compatible framebuffer.
Changed in nvidia-graphics-drivers (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers