kde apps kill X in 10.10

Bug #650599 reported by alfille on 2010-09-28
66
This bug affects 11 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdebase

Fresh 10.4 upgraded to 10.10 Ubuntu. Using nVidia driver v256 and 4-screen display (Quadro nvs 420 running as two "twinviews" with Xinerama coupling them.

Gnome seems to work untiI try a kde program (konsole or cervisia) that displays briefly and then dumps me to the gsm login page.

Similarly, trying to boot into kde shows the kde display briefly and then drops me to the gdm login page.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: konsole 4:4.5.1-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Tue Sep 28 16:22:07 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: kdebase

alfille (paul-alfille) wrote :
Jonathan Thomas (echidnaman) wrote :

This is highlighting an issue with the nvidia graphics drivers.

affects: kdebase (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Bryce Harrington (bryce) on 2010-09-29
tags: added: kubuntu
gryphius (oli-wgwh) wrote :

Same here. It only crashes if xinerama is enabled. If I disable xinerama, qt apps can be run ok.
Tested with Lucid and Meerkat, also tried newest beta of the nvidia drivers (260.19.04), same result.

Log shows a little more info:
Backtrace:
[ 378.165] 0: /usr/bin/X (xorg_backtrace+0x28) [0x4a0fa8]
[ 378.165] 1: /usr/bin/X (0x400000+0x60fcd) [0x460fcd]
[ 378.165] 2: /lib/libpthread.so.0 (0x7f12f9be8000+0xfb40) [0x7f12f9bf7b40]
[ 378.165] 3: /usr/bin/X (0x400000+0xbb22f) [0x4bb22f]
[ 378.165] 4: /usr/bin/X (0x400000+0x2c2d9) [0x42c2d9]
[ 378.165] 5: /usr/bin/X (0x400000+0x2184b) [0x42184b]
[ 378.165] 6: /lib/libc.so.6 (__libc_start_main+0xfe) [0x7f12f8b53d8e]
[ 378.165] 7: /usr/bin/X (0x400000+0x213d9) [0x4213d9]
[ 378.165] Segmentation fault at address 0x4
[ 378.165]
Caught signal 11 (Segmentation fault). Server aborting
[ 378.165]

gryphius (oli-wgwh) wrote :
alfille (paul-alfille) wrote :

After some testing (and reporting to nVidia as well) I can report:

1. nVidia 260.19.04 is also vulnerable
2. Xinerama is the culprit. No problems with twinview and no Xinerama (2 separate dual head displays).

Paul Alfille

damien_d (d-dusha) wrote :

I too can report that X seems to crash when launching a KDE application with this particular PPA enabled. Skype also causes it to crash (QT dependency perhaps?)

I can also report that disabling Xinerama allows application to work as normal.

  -- Damien

damien_d (d-dusha) wrote :

Just to be clearer, I was referring to this particular PPA:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

alfille (paul-alfille) wrote :

I reported this bug to nVidia, and they find it's an Xorg error in Ubuntu's implementation. Their comment is:
http://nvidia.custhelp.com/cgi-bin/nvidia.cfg/php/enduser/acct_login.php?p_next_page=myq_upd.php&p_iid=298195&p_created=1285728578
--------------------
Thanks for running those xinerama tests and for the additional information.

I set this up and can reproduce this fairly easily, but I'm pretty sure this isn't an
NVIDIA bug.

I can reproduce the problem with Ubuntu Maverick, but I can't reproduce
it on a recent version of Arch Linux, which uses the same X server version.

On Ubuntu, I can induce a crash by just running `kwrite` in a bare X
server with Xinerama enabled. I always get the same backtrace from the
crashing server:

Program received signal SIGSEGV, Segmentation fault.
PanoramiXTranslateCoords (client=0x86f6dc8) at
../../Xext/panoramiXprocs.c:637
637 ../../Xext/panoramiXprocs.c: No such file or directory.
in ../../Xext/panoramiXprocs.c
(gdb) bt
#0 PanoramiXTranslateCoords (client=0x86f6dc8) at
../../Xext/panoramiXprocs.c:637
#1 0x0806e087 in Dispatch () at ../../dix/dispatch.c:432
#2 0x080625ba in main (argc=1, argv=0xbffff874, envp=0xbffff87c) at
../../dix/main.c:291

This does seem to be a core X server bug rather than a driver bug.

Let me know if I can help further.

Best regards,
Mike

gryphius (oli-wgwh) wrote :

I just installed ArchLinux - same problem. Further googling shows this bug affects various distributions and has already been reported for ubuntu as well:

Ubuntu:
https://bugs.launchpad.net/ubuntu/+source/qt4-x11/+bug/650539

Arch:
https://bbs.archlinux.org/viewtopic.php?id=106125

Gentoo:
http://bugs.gentoo.org/show_bug.cgi?id=339135

Nokia/QT:
http://bugreports.qt.nokia.com/browse/QTBUG-14260

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.