Dist-Upgrading with Nvidia driver installed causes XServer not to load

Bug #625993 reported by falcon1620 on 2010-08-28
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: dpkg-dev

In each version 10.4 and now Maverick I have noticed that the Nvidia drivers do not transition well. Generally I un-install the Nvidia drivers on my machine before preforming an upgrade to my system, (even the latest). However I have Ubuntu installed (32 and 24 bit kernels) on several workstations that are used for CAD and Matlab systems users just "Upgrade" with out un-installing the Nvidia drivers. (Yea I have shown them how to and explained why). Still people insist on upgrading with out removing drivers. Instead of a nice welcoming GUI with X they are greeted with a Bash prompt, and that's when I get called in. I have attempted to remedy the situation by
running:
sudo dpkg-reconfigure xserver-xorg (Still X failed to load)
purging xorg.conf files (tried purging and re-running dpkg)
sudo Xorg -configure (Tired invoking the Xorg configuration and it stilled loaded nvidia drivers in that were non functional)
completely removing Xorg, Gnome, and GDM from the system purging files and re-installing them (Even then this did not help, it would start only by manually invoking "startx".)

I have found that the xserver will still attempt to load Nvidia drivers installed from an earlier version during the upgrade, and this will cause the Xserver to fail to start.

Finally I found that after a failed update, I removed the module /usr/lib/xorg/modules/drivers/nvidia_driver.so
and I was FINALLY able to start Gnome and X going. I don't think that users who have the Nvidia modules installed preforming an upgrade are going to have an easy time figuring out why they are not getting a GUI though. This has failed on me in 10.04 several times, and I noticed this upgrading to Alpha on my personal machine here with the same issue. I have seen this issue occur on users who have any type of Nvidia driver installed through the "Restricted Drivers" panel on Gnome.

Removing the Nvidia drivers is a good idea, but users just happily click on update with out even thinking about them. I was thinking about writing out a script to remove the Nvidia drivers and upgrade the system in the background for them, but the problem is that when the update dialog box pops up, users get overzealous on upgrades and go YEA! New version, upgrade now.

At least they are using Ubuntu at home on their personal machines and getting work done on them :-) I don't know if anyone wants to tackle this problem but it would be helpful.

By the way the Aplha is very exciting, I love it so far! :O

Philip Muškovac (yofel) wrote :

reassigning to the nvidia driver as this isn't a dpkg issue. Your problems might come from bug 616023 though which should be fixed soon.

affects: dpkg (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
tags: added: maverick
bugbot (bugbot) wrote :

Hey falcon1620,

Thanks for testing maverick during its development period. Unfortunately it looks like this bug report didn't get attention during the maverick development period. But I see there's not been more comments on the bug since the release, which makes me wonder if this is still an issue for you?

If you've not seen this issue since maverick's release yourself, it may have been solved by kernel or X or other updates that occurred late in the release; if so, would you mind please closing the bug for us? Go to the URL mentioned in this bug report, click the yellow icon(s) in the status column and set to 'Fix Released'.

If you no longer have the hardware needed to reproduce the problem, or otherwise feel the bug no longer needs tracked in Launchpad, you can set the status to 'Invalid'.

If you are the original reporter and still have this issue, just reply to this email saying so. (Or set the bug status to Confirmed.) If you are able to re-test this against 11.04 Natty Narwhal (our current development focus) and find the issue still affects Natty, please also run 'apport-collect <bug-number>' while running natty, which will add fresh logs and debug data, and flag it for the Ubuntu-X development team to look at.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Incomplete
bugbot (bugbot) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → Expired
Henry Tang (henryykt) wrote :

Following the test case from here: http://testcases.qa.ubuntu.com/Hardware/X/ProprietaryDrivers#Upgrade From Manual Install Testing

X won't start after upgrade from Maverick to Natty.

Henry Tang (henryykt) wrote :

Following the test case from here: http://testcases.qa.ubuntu.com/Hardware/X/ProprietaryDrivers#Upgrade From Manual Install Testing

X won't start after upgrade from Maverick to Natty: The following message is found in Xorg.0.log:

This server has a video driver ABI version of 10.0 that is not supported by this NVIDIA driver. Please check http://www.nvidia.com/ for driver updates or downgrade to an X server with a supported driver ABI.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers