Ubuntu 10.10 freezes when loading

Bug #619008 reported by Ron Rhodes on 2010-08-17
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: plymouth

Description: Ubuntu maverick (development branch)
Release: 10.10

plymouth:
  Installed: 0.8.2-2ubuntu3
  Candidate: 0.8.2-2ubuntu3
  Version table:
 *** 0.8.2-2ubuntu3 0
        500 http://gb.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

Ubuntu to load

Screen freezes at Xubuntu logo, only action which works is Ctrl/Alt/Del to force reboot

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: plymouth 0.8.2-2ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-23.37-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-23-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Tue Aug 17 02:19:04 2010
DefaultPlymouth: /lib/plymouth/themes/xubuntu-logo/xubuntu-logo.plymouth
MachineType: System manufacturer System Product Name
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-23-generic root=UUID=04c40a69-0e7b-45a2-a077-4bcf12238797 ro single
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcFB: 0 VGA16 VGA
SourcePackage: plymouth
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
dmi.bios.date: 03/26/2007
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: ASUS M2N8L ACPI BIOS Revision 0404
dmi.board.name: M2N8L
dmi.board.vendor: ASUSTek Computer INC.
dmi.board.version: 1.xx
dmi.chassis.asset.tag: 123456789000
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSM2N8LACPIBIOSRevision0404:bd03/26/2007:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTekComputerINC.:rnM2N8L:rvr1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Ron Rhodes (owdronrhodes) wrote :
Charlie Kravetz (charlie-tca) wrote :

Thank you for reporting this issue. Unfortunately, there is not enough information for the developers to begin to resolve this for you. Since Xubuntu 10.10 is a development version, we need to try to find the errors you are experiencing.

Please use the shift key during boot to bring up the Grub menu. Then edit the menu line before booting. At the end of the kernel line, there will be "ro quiet splash". Please delete the words "quiet splash" and the hit Ctrl=x to boot the system. This will allow you to see and copy the errors. We will need to know the errors shown.

Does the system boot using recovery mode from the Grub menu?

Does the systetm work using the Desktop/Live CD?

Changed in plymouth (Ubuntu):
status: New → Incomplete
Ron Rhodes (owdronrhodes) wrote :

Booting with quiet splash deleted the messages move too quickly up the screen for me to read. When they stop I do not know how to copy and save what is on the screen. I thought all the files produced by apport and attached to the report would provide this information.
Using the recovery mode I have to select FailsafeX to boot and run in low graphics mode.
I do not have a Desktop/Live CD available as I upgraded on line from 10.04.1.

On Tue, Aug 17, 2010 at 05:28:49PM -0000, Ron Rhodes wrote:
> Booting with quiet splash deleted the messages move too quickly up the
> screen for me to read. When they stop I do not know how to copy and save
> what is on the screen.

We will need you either to take a photo of the screen and upload it, or
hand-copy the information from the screen, in order to debug this problem.
Sorry, by definition when the system fails to boot, we have no guaranteed
method of capturing this information digitally.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Ron Rhodes (owdronrhodes) wrote :

I attach boot.messages file produced immediately after booting with quiet splash deleted. Please note when I boot this way it boots to a CLI log in screen, not to the gui. I believe this file, which incidentally appears to be similar to the BootDmesg.txt file produced by Apport and attached to the original report, should contain all the information needed to proceed with debugging this problem.
My reason for believing this file should contain the information you require is based on the following extract from "man dmesg":
"DESCRIPTION
       dmesg is used to examine or control the kernel ring buffer.

       The program helps users to print out their bootup messages. Instead of
       copying the messages by hand, the user need only:
              dmesg > boot.messages
       and mail the boot.messages file to whoever can debug their problem."

Charlie Kravetz (charlie-tca) wrote :

I am sorry. We now have two copies of that file. Unfortunately, we still do not have enough information to actually do anything. The messages you get when the computer stops booting do not appear in this log. Since this is generated by a system that does not stop while booting, it does not tell us what is happening when it freezes during the boot.

Does your system now boot to the login window without "quiet splash" ?

Ron Rhodes (owdronrhodes) wrote :

Yes the system boots to the login window without "quiet splash".
The following are the messages I get on the final screen when I boot without "quiet splash":
*Starting Kernel Oops catching service kerneloops [OK]
speech-dispatcher disabled; edit /etc/default/speech-dispatcher
*Saved ALSA mixer setting detected; aumix will not touch mixer.
*Starting Common Unix Printing System: cupsd [OK]
*Pulse Audio configured for per-user sessions
Saned disabled; edit /etc/default/saned
*Checking battery state... [OK]

Ubuntu maverick (development branch) Desktop1 tty1

Desktop1 login: _

NB: The following two additional lines appear on a second computer after the "battery state..." line:
mountall: Plymouth command failed
mountall: Disconnected from Plymouth

Steve Langasek (vorlon) wrote :

when the boot freezes at the logo (booting with 'splash'), does hitting 'Esc' have any effect? Does Alt+F1? Does Ctrl+Alt+F1?

Ron Rhodes (owdronrhodes) wrote :

None of these key combinations have any effect, as I clearly stated in my original report (see above), the only action which works is Ctrl/Alt/Del to force reboot.

Ron Rhodes (owdronrhodes) wrote :

Update on progress I have recently made in overcoming this problem. I can now boot up to the GUI desktop!
How did I achieve this? I decided to remove the hardware driver, NVIDIA accelerated graphics driver (version current) which I had inherited from 10.04.1 when I upgraded to 10.10. I was then able to boot up without freezing. System>Administration>Hardware Drivers still recommended this driver so I reactivated it and to my surprise I was still able to boot up without freezing. It would appear that the problem is not with Plymouth but down to the hardware driver.
The problem is, however, only partially solved. I reported the problem from my main computer but it also existed on my older stand by/back up computer. This uses the NVIDIA 96 driver on 10.04.1 so I removed this on 10.10 which then booted up without freezing. I have been unable to find a driver which is recommended on this machine and boots up without freezing, I intend to report a new bug on this problem.
I will be pleased to provide any further information if requested.

Steve Langasek (vorlon) on 2010-08-22
affects: plymouth (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → New
Bryce Harrington (bryce) on 2010-08-23
tags: added: xubuntu
Isegrim (isegrimderwolf) on 2010-10-15
Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
status: Confirmed → New
assignee: nobody → Isegrim (isegrimderwolf)
hagbard (emailjasonclark) wrote :

I was experiencing this same problem and found a way to fix it.

I just received a new Lenovo T410 laptop with discrete NVidia graphics accelerator today. Installed Ubuntu 10.10 and everything worked fine. When I installed the NVidia driver and rebooted, the system would hang on "checking battery state" message and not progress any further.

The cause and solution: I checked the bios of the T410 and there is a graphics setting that switches between "integrated" (no acceleration) "discrete" (activates NVidia accelerator at all times) and "NVidia Optimus". The "Optimus" setting was on by default, with this description:

"If enabled, System BIOS automatically switches Graphics Device setting to NVIDIA Optimus mode if the OS supports the feature, and to Discrete Graphics if the OS does not support it."

I changed the setting to "discrete" and Ubuntu booted with no problems. I assume that Linux does not currently support NVIDIA Optimus :)

jsgaarde (jakob-simon-gaarde) wrote :

I would like to point out that there is a bug that has similarity to this one. It also freezes the system under boot:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/607399

It might not be related, I don't see any kernel oops in this bug....

jsgaarde (jakob-simon-gaarde) wrote :

I would like to point out that bug #607399 has similarity to this one. It also freezes the system under boot because of the nvidia-graphics-drivers:

It might not be related, I don't see any kernel oops in this bug....

jsgaarde (jakob-simon-gaarde) wrote :

I would like to point out that bug 607399 has similarity to this one. It also freezes the system under boot because of the nvidia-graphics-drivers.

It might not be related, I don't see any kernel oops in this bug....

Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

I can confirm that upgrading from one release to the next with the Nvidia hardware drivers installed will cause this issue. The only workaround I have found is to remove and reinstall the drivers. If the hardware drivers are removed prior to upgrading, this does not appear.

Thanks for taking the time to make Ubuntu better!

Changed in nvidia-graphics-drivers (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
assignee: Isegrim (isegrimderwolf) → nobody
arthur morgan (artmorgan1) wrote :

A note: I just downloaded Ubunto 10.10 onto my HP desktop, installed it onto my thumb drive, and have encountered the same problem. Probably the video driver, according to what I read above...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers