twinview: windows maximize across both monitors

Bug #597771 reported by purecharger on 2010-06-23
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)

Bug Description

Binary package hint: xorg

After upgrading to 10.04 from 9.10, the window manager (compiz) does not treat my 2 displays as it did with 9.10. Now windows maximize across both screens, they do not snap to the screen boundary, my lower task bar (where apps get minimized to) extends across both monitors without appearing: by that I mean I dont see it on the 2nd monitor, but I can not resize a window into the area that it would take up on the 2nd monitor.

The alt+tab switcher and all windows that launch in the center of the screen are split across the monitors.

I have my 2 screens in both nvidia-xconfig and CCSM defined as: 0,0+0+0 and 0,1920+0+0

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xorg 1:7.5+5ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-22.36-generic
Uname: Linux 2.6.32-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Wed Jun 23 09:36:26 2010
DkmsStatus: nvidia-current, 195.36.24, 2.6.32-22-generic, x86_64: installed
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
MachineType: Dell Inc. Precision T1500
ProcCmdLine: root=UUID=be8b8a85-7560-4929-ba6e-9f7b59fdfc75 ro quiet splash
 PATH=(custom, user)
SourcePackage: xorg 09/18/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.0.1 0P67HD
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 3
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.0.1:bd09/18/2009:svnDellInc.:pnPrecisionT1500:pvr00:rvnDellInc.:rn0P67HD:rvrA00:cvnDellInc.:ct3:cvr: Precision T1500
dmi.product.version: 00
dmi.sys.vendor: Dell Inc.
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-22-generic

purecharger (rnideffer) wrote :
Bryce Harrington (bryce) on 2010-06-24
affects: xorg (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
purecharger (rnideffer) wrote :

I have solved this by ensuring that my window manager, Compiz, now starts up properly when I log in to my session.

dino99 (9d9) wrote :

That version is no more supported; please open a new bug report if the actual archive found version also has the same issue.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers