Ubuntu

immutable inexplicable screen switch

Reported by keepitsimpleengr on 2010-06-22
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-nv

Shut down system, next day booted and screens were switched. The former screen 0 is now on the smaller second monitor and the former screen 1 is on the larger main monitor. No changes were made except shut down and restart.

How do I fix this and how do I keep it from happening again?

10.04 Linux-x86_64 clean install, nvidia 195.36.24, Server 11.0 1.7.6, nv-control 1.22, Geforce 9400GT

Was DFP-0 Screen 0 Large main DFP-1 Screen 1 small second
Now DFP-0 Screen 1 Large main DFP-1 Screen 0 small second

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xserver-xorg-video-nv 1:2.1.15-1ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-22.36-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CurrentDmesg:
 [ 20.010057] hda_codec: ALC1200: BIOS auto-probing.
 [ 20.650116] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:0f.1/input/input9
 [ 29.220006] eth1: no IPv6 routers present
Date: Tue Jun 22 10:38:49 2010
DkmsStatus:
 nvidia-current, 195.36.24, 2.6.32-22-generic, x86_64: installed
 nvidia-173, 173.14.22, 2.6.32-21-generic, x86_64: installed
 nvidia-173, 173.14.22, 2.6.32-22-generic, x86_64: installed
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MachineType: EVGA 132-YW-E178-FTW
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=49494cf3-d878-4987-b93e-2e10ee46f1df ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: xserver-xorg-video-nv
dmi.bios.date: 01/23/2009
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: 132-YW-E178-FTW
dmi.board.vendor: EVGA
dmi.board.version: 1
dmi.chassis.type: 3
dmi.chassis.vendor: EVGA
dmi.chassis.version: 132-YW-E178-FTW
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd01/23/2009:svnEVGA:pn132-YW-E178-FTW:pvr1:rvnEVGA:rn132-YW-E178-FTW:rvr1:cvnEVGA:ct3:cvr132-YW-E178-FTW:
dmi.product.name: 132-YW-E178-FTW
dmi.product.version: 1
dmi.sys.vendor: EVGA
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-22-generic

Well, I haven't fixed it, but I did find a work-around. It is astonishing, but at least it worked!

1) From terminal: sudo nvidia-settings
2) Under "X Server Display Configuration" arrange Layout with larger screen to left.
3) Press "Configure..." button and select TwinView.
4) Press the "Save to X Configuration File"
5) Restart computer (or X server)
6) From terminal: sudo nvidia-settings
7) Press "Configure..." button and select Seperate X Screen.
8) Press the "Save to X Configuration File"
9) Cross your fingers
10) Restart computer (or X server)

Bryce Harrington (bryce) on 2010-07-02
Changed in xserver-xorg-video-nv (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2012-02-27
affects: xserver-xorg-video-nv (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers