nVidia driver scrambles Usplash

Bug #565866 reported by bwallum
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Expired
Undecided
Unassigned

Bug Description

If the (Version current recommended) nVidia driver is activated the Usplash is thin lines of scrambled pixels upon reboot. De activating the nVidia driver (restoring to default driver) brings back the expected Usplash and messaging. 100% repeatable, AMD64 Ubuntu lucid updated 10:30 GMT Sun 18th Apr

Impact: If a disk check or any other messaging is presented the user will not be able to read it. Closely scrutinised one or two pixels can be seen to change but the general appearance is of a hung system.
---
Architecture: amd64
CurrentDmesg:
 [ 377.140012] eth0: no IPv6 routers present
 [ 437.510021] Clocksource tsc unstable (delta = -262350616 ns)
 [ 752.721292] end_request: I/O error, dev fd0, sector 0
 [ 752.761287] end_request: I/O error, dev fd0, sector 0
 [ 757.641453] EXT4-fs (sdd1): mounted filesystem with ordered data mode
DistroRelease: Ubuntu 10.04
DkmsStatus:

InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100224.1)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 003: ID 1871:01f0 Aveo Technology Corp.
 Bus 001 Device 002: ID 152d:2329 JMicron Technology Corp. / JMicron USA Technology Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: BIOSTAR Group N61PB-M2S
NonfreeKernelModules: nvidia
Package: nvidia-graphics-drivers (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=c6b6fed6-6e38-43b6-8515-90759725f2e1 ro splash vga=786 quiet splash
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Tags: lucid lucid
Uname: Linux 2.6.32-22-generic x86_64
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev plugdev sambashare tape video
dmi.bios.date: 09/03/2009
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: N61PB-M2S
dmi.board.vendor: BIOSTAR Group
dmi.chassis.type: 3
dmi.chassis.vendor: BIOSTAR Group
dmi.chassis.version: N61PB-M2S
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd09/03/2009:svnBIOSTARGroup:pnN61PB-M2S:pvr:rvnBIOSTARGroup:rnN61PB-M2S:rvr:cvnBIOSTARGroup:ct3:cvrN61PB-M2S:
dmi.product.name: N61PB-M2S
dmi.sys.vendor: BIOSTAR Group
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-22-generic

Revision history for this message
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in nvidia-graphics-drivers.

When reporting bugs in the future please use apport, either via the appropriate application's "Help -> Report a Problem" menu or using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → nvidia-graphics-drivers (Ubuntu)
Revision history for this message
Robert Hooker (sarvatt) wrote :

usplash is not compatible with lucid in the first place. can you please run apport-collect 565866 to attach your logs to this bug?

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Incomplete
Revision history for this message
Andrew Dodd (atd7) wrote :

usplash might not be the correct terminology - if it is not usplash, then what is it that displays the splash screen prior to reaching the X display manager (kdm or gdm)?

Either way, the splash screen displayed is corrupted when the nvidia proprietary drivers are activated.

I'll attach some apport bugs once I get my hardware acceleration working again...

Revision history for this message
Bryce Harrington (bryce) wrote :

[Resetting to incomplete since we need a response from the original reporter on this].

Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Revision history for this message
bwallum (rbw2) wrote : BootDmesg.txt

apport information

tags: added: apport-collected
description: updated
Revision history for this message
bwallum (rbw2) wrote : GdmLog.txt

apport information

Revision history for this message
bwallum (rbw2) wrote : GdmLog1.txt

apport information

Revision history for this message
bwallum (rbw2) wrote : GdmLog2.txt

apport information

Revision history for this message
bwallum (rbw2) wrote : Lspci.txt

apport information

Revision history for this message
bwallum (rbw2) wrote : PciDisplay.txt

apport information

Revision history for this message
bwallum (rbw2) wrote : ProcCpuinfo.txt

apport information

Revision history for this message
bwallum (rbw2) wrote : ProcInterrupts.txt

apport information

Revision history for this message
bwallum (rbw2) wrote : ProcModules.txt

apport information

Revision history for this message
bwallum (rbw2) wrote : RelatedPackageVersions.txt

apport information

Revision history for this message
bwallum (rbw2) wrote : UdevDb.txt

apport information

Revision history for this message
bwallum (rbw2) wrote : UdevLog.txt

apport information

Revision history for this message
bwallum (rbw2) wrote : XorgLog.txt

apport information

Revision history for this message
bwallum (rbw2) wrote : XorgLogOld.txt

apport information

Revision history for this message
bwallum (rbw2) wrote : Xrandr.txt

apport information

Revision history for this message
bwallum (rbw2) wrote : monitors.xml.txt

apport information

Revision history for this message
bwallum (rbw2) wrote : setxkbmap.txt

apport information

Revision history for this message
bwallum (rbw2) wrote : xdpyinfo.txt

apport information

Revision history for this message
bwallum (rbw2) wrote : xkbcomp.txt

apport information

Revision history for this message
bwallum (rbw2) wrote :

Problem persists with latest updates 9:00 GMT Monday 3rd May 2010. Apologies if Usplash is the incorrect package. The splash screen after grub and before os boot to Desktop is the problem. What is the name of that splash screen app please?

Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → New
Revision history for this message
bwallum (rbw2) wrote :

I ran

apport-collect 565866

but can't see it reported here.

Revision history for this message
bwallum (rbw2) wrote :

oops, found it

Revision history for this message
Andrew Dodd (atd7) wrote :

bwallum's description of his bug effects are different than mine. Mine appears to have been caused by bug 551290. My issues were fixed in the updates pushed out on or around Wednesday May 5, 2010.

Correct terminology for the new bootsplash method is "plymouth".

As my symptoms have been resolved, I will be unsubscribing from this bug.

Revision history for this message
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi bwallum,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 565866

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 565866 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/565866

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Incomplete
tags: added: needs-retested-on-lucid-by-june
Bryce Harrington (bryce)
tags: added: lucid
Revision history for this message
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers