X with "nvidia" fails to start on Geforce G102M

Bug #560250 reported by Dr Emixam on 2010-04-10
74
This bug affects 13 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

nouveau driver never worked with my G102M (asus k50in)
"nvidia" non-free driver was working until this morning updates

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xorg 1:7.5+5ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CheckboxSubmission: 2df47a53862518fe17fa18819e051eac
CheckboxSystem: b8f3ec504801f13fc208edb5c785b099
Date: Sat Apr 10 21:44:49 2010
DkmsStatus: nvidia-current, 195.36.15, 2.6.32-19-generic, x86_64: installed
EcryptfsInUse: Yes
InstallationMedia: Error: [Errno 13] Permission non accordée: '/var/log/installer/media-info'
Lsusb:
 Bus 002 Device 002: ID 046d:c03e Logitech, Inc. Premium Optical Wheel Mouse
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 003: ID 04f2:b071 Chicony Electronics Co., Ltd 2.0M UVC Webcam / CNF7129
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: ASUSTeK Computer Inc. K50IN
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-19-generic root=UUID=fd437773-bbbc-459e-90e9-366bbd81ec6e ro quiet splash
ProcEnviron:
 LANG=fr_FR.utf8
 SHELL=/bin/bash
SourcePackage: xorg
Symptom: display
dmi.bios.date: 05/08/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 207
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: K50IN
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr207:bd05/08/2009:svnASUSTeKComputerInc.:pnK50IN:pvr1.0:rvnASUSTeKComputerInc.:rnK50IN:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr:
dmi.product.name: K50IN
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.
glxinfo: Error: [Errno 2] Aucun fichier ou dossier de ce type
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-19-generic

Dr Emixam (dr.emixam) wrote :
Bryce Harrington (bryce) on 2010-04-11
Changed in xorg (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2010-04-12
affects: xorg (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Dr Emixam (dr.emixam) wrote :

I don't know if it helps, but I noticed by watching my logs that :
When the display fail to start, this :

(**) Apr 30 09:25:58 NVIDIA(0): Enabling RENDER acceleration
(II) Apr 30 09:25:58 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) Apr 30 09:25:58 NVIDIA(0): enabled.
(EE) Apr 30 09:25:58 NVIDIA(0): Failed to initialize the NVIDIA kernel module. Please see the
(EE) Apr 30 09:25:58 NVIDIA(0): system's kernel log for additional error messages and
(EE) Apr 30 09:25:58 NVIDIA(0): consult the NVIDIA README for details.

in Xorg.*.log comes before this :

Apr 30 09:26:00 laptop-max kernel: [ 20.541963] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 195.36.15 Fri Mar 12 00:29:13 PST 2010

in /var/log/messages

When the display starts without any problem, the /var/log/messages one comes first (and of course, there isn't any errors)

We really need this problem to be solved because the free driver doesn't work at all with this graphic chip ( https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/568798 )

ZeroBeat (zerobeat) wrote :

Problem is still in the final 10.04

Solution:
Boot the live-cd using params "nomodeset xforcevesa"
Install lucid
Reboot using params "nomodeset xforcevesa"
Install th proprietary NVIDIA driver
Switch to console and copy attached xorg.conf
Reboot and configure your display by using NVIDIA X Server Settings (Administration)

So please implement xforcevesa to the options (F6) of the live-cd.

Best regards
ZB

ZeroBeat (zerobeat) wrote :

"NVIDIA X Server Settings" generates attached xorg.config.
From this moment "life has begun" (K50IN works fine).

Best regards
ZB

Vali (maxim-ioan) wrote :

"Boot the live-cd using params "nomodeset xforcevesa""

How do you do that?

tatsuno (carlos-troncoso) wrote :

ZeroBeat, I tried your xorg.conf, didn't work for me. nvidia keeps crashing and giving me low-res modes in cold boots in my K50IN. It only happens in cold boots, though, as soon as I reboot I have the proprietary drivers working, very odd and very annoying as well.

Vali, press "e" in the grub menu to edit the line and add the two params at the end of it.

Vali (maxim-ioan) wrote :

I don't have grub. I put the CD in, it boots; then I should be able to select language (in GUI mode) but because the graphic card it's not recognized I see only garbage on the screen.

tatsuno (carlos-troncoso) wrote :

Vali, there's a way of adding options to the kernel when you boot the Live CD as well, don't remember if it was with F6, but you should be able to type at the end of the line. I did that in order to install Lucid, because I had the same problem as you. You need to add the options before Linux starts loading.

ZeroBeat (zerobeat) wrote :

tatsuno:
Hi. Maybe there are different versions of the notebook.
Mine is K50INSX147C.
Best regards
Mike

tatsuno (carlos-troncoso) wrote :

ZeroBeat, mine is K50IN-SX149V.
Cheers.

yodaanneaux (romain-yoda) wrote :

Hi everyone,

"Solution:
Boot the live-cd using params "nomodeset xforcevesa"
Install lucid
Reboot using params "nomodeset xforcevesa"
Install th proprietary NVIDIA driver
Switch to console and copy attached xorg.conf
Reboot and configure your display by using NVIDIA X Server Settings (Administration)"

It worked 20 days ago. I don't know why it doesn't work anymore (I tried today), but I found an other way to solve this problem :

Boot the live-cd using params "nomodeset xforcevesa"
Install lucid
Reboot WITHOUT params "nomodeset xforcevesa"
When display shows the bad screen, tape ctrl+alt+F2
Tape login and password
Then, tape sudo jockey-text -l
Tape sudo jockey-text -e xorg:nvidia-§§§ (replace §§§ with number of version of pilote, or with "current").
Note that this command can take minutes.

olksy (noface) wrote :

sudo jockey-text -e xorg:nvidia

works only for the next cold reboot for me. It is not a solution. We are still at the same place.

olksy (noface) wrote :

Could it be because of asynchronous startup scripts? In another words, can it be that Xorg starts before nvidia driver is completely loaded?

Takayuki YAMAGUCHI (ytk) wrote :

I have the same error "Failed to initialize the NVIDIA kernel module"
when booting my pc with ubuntu 10.04 and nvidia 7050 graghics.
After I repeated booting my pc, I noticed that in the case disk check is executed
this error did not occur.
So, when I meet this error, I type Ctrl+Alt+F1, log in, and "sudo touch /forcefsck"
to check disk at next booting. I type "reboot" and then next booting succeeds.
Therefore, I thick upstart causes this error and if I force the boot process
to wait the finish of initialization of nvidia driver, this error does not occur.
Quick-fix method to wait the finish of initialization is to check disk.
Is there other smart method to avoid this error?

tatsuno (carlos-troncoso) wrote :

For me, it works when I just reboot (ctrl+alt+f1, ctrl+alt+del).

Related to this is probably another problem I have with my netbook, that wifi doesn't work until I reboot, so it's definitely something with upstart and synchronisation.

dino99 (9d9) wrote :

That version is no more supported; please open a new bug report if the actual archive found version also has the same issue.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers