Ubuntu

Can not change LCD brightness on Lenovo Y450 laptop

Reported by Ryan Hamilton on 2010-03-17
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: xorg

I'm having a tough time getting the backlight adjustment working on a laptop (Lenovo Y450) using the latest NVIDIA drivers for the G 130M in the machine.

The laptop function combination keys register as they should, and things get changed in the system in /proc/acpi/video/VGA/LCD/brightness
/sys/class/backlight/acpi_video0/brightness

Changing the backlight via the function combination (FN + up/down) works right up until the NVIDIA driver is loaded. I am able to adjust the backlight by dropping to a virtual terminal and using the function combination keys there, but that just stinks as a workaround. I've tried the latest driver versions, including the latest beta, without result.

ProblemType: Bug
Architecture: amd64
Date: Wed Mar 17 02:48:20 2010
DistroRelease: Ubuntu 10.04
DkmsStatus: nvidia-current, 195.36.08, 2.6.32-16-generic, x86_64: installed
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100317)
MachineType: LENOVO IdeaPad Y450
NonfreeKernelModules: nvidia
Package: xorg 1:7.5+3ubuntu1
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-16-generic root=UUID=14e13515-ae02-45a4-87a6-f1d4abd32089 ro quiet splash
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: xorg
Symptom: display
Uname: Linux 2.6.32-16-generic x86_64
dmi.bios.date: 08/14/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 17CN34WW
dmi.board.name: KL1
dmi.board.vendor: LENOVO
dmi.board.version: Rev 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Rev 1.0
dmi.modalias: dmi:bvnLENOVO:bvr17CN34WW:bd08/14/2009:svnLENOVO:pnIdeaPadY450:pvrRev1.0:rvnLENOVO:rnKL1:rvrRev1.0:cvnLENOVO:ct10:cvrRev1.0:
dmi.product.name: IdeaPad Y450
dmi.product.version: Rev 1.0
dmi.sys.vendor: LENOVO
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-16-generic

Ryan Hamilton (rthamilt) wrote :
Bryce Harrington (bryce) on 2010-03-17
affects: xorg (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Robert Hooker (sarvatt) wrote :

Have you tried adding

Option "RegistryDwords" "EnableBrightnessControl=1"

to your /etc/X11/xorg.conf at the bottom of the device section?

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Incomplete
importance: Undecided → Low
Ryan Hamilton (rthamilt) wrote :

Robert, that completely fixed it! I had been googling off and on for what seems like 6 months without a solution, and, bam, that gives me backlight control as well as automatic dimming based on activity. Thank you so much!

Robert Hooker (sarvatt) wrote :

No worries, it's not something we can just globally enable for everyone so tricks like that are often needed with the proprietary drivers.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → Fix Released
Philip Muškovac (yofel) wrote :

This can be resolved by disabling VT-D in the BIOS too as I just found out.
http://www.nvnews.net/vbulletin/showpost.php?p=2259741&postcount=46

Paul Abrahams (abrahams) wrote :

What is the best way to install the EnableBrightnessControl fix if xorg.conf doesn't exist (a common situation now)? I tried creating xorg.conf as

Section "Device"
        Identifier "Configured Video Device"
        Driver "fbdev"
        Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

with material copied from xorg.conf.failsafe but that didn't have any effect.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers