KMS driver blacklisting with /usr on separate partition fails (Lucid)

Bug #538071 reported by Stefan Lesicnik
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Fix Released
High
Alberto Milone
Lucid
Fix Released
High
Alberto Milone
nvidia-graphics-drivers (Ubuntu)
Fix Released
High
Alberto Milone
Lucid
Fix Released
High
Alberto Milone
nvidia-graphics-drivers-173 (Ubuntu)
Fix Released
High
Alberto Milone
Lucid
Fix Released
High
Alberto Milone
nvidia-graphics-drivers-96 (Ubuntu)
Fix Released
High
Alberto Milone
Lucid
Fix Released
High
Alberto Milone

Bug Description

Nouveau blacklisting fails when /usr is on seperate partition.

cat /etc/modprobe.d/nvidia-graphics-drivers.conf
blacklist nouveau
blacklist lbm-nouveau
blacklist nvidia-173
blacklist nvidia-96
alias nvidia nvidia-current

File exists as above and 'update-initramfs -u' was run.

System fails to blacklist nouveau and as a result nvidia drivers are unable to claim the device and boot.

This is clearly some type of race condition with upstart and not being able to access /usr/lib at time of boot. A temporary fix was to modify and include 'and local-filesystems' to the start line. This seems to slow down the boot process, but the driver was blacklisted.

  DO NOT DO THIS, THIS IS WRONG AND VERY VERY STUPID.

/etc/init/udev.conf

start on virtual-filesystems and local-filesystems

NOTE: the same applies to the fglrx driver which requires blacklisting the radeon module

Tags: lucid
Robert Hooker (sarvatt)
Changed in nvidia-graphics-drivers (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
status: New → Confirmed
Robert Hooker (sarvatt)
Changed in nvidia-graphics-drivers (Ubuntu):
importance: Undecided → High
Robert Hooker (sarvatt)
Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Triaged
Bryce Harrington (bryce)
tags: added: lucid
Revision history for this message
Julien Aubin (gojulgarbmail) wrote :

Same issue there.

Revision history for this message
Julien Aubin (gojulgarbmail) wrote :

The proposed fix does work.

Revision history for this message
Andreas Hasenack (ahasenack) wrote :

Sometimes I wish I were a "normal" user, with no fancy partitioning ;) Same problem here, will try the fix now.

Revision history for this message
Andreas Hasenack (ahasenack) wrote :

I believe the fix worked. Before I had zeroed-out the nouveau.ko files, to make sure they were not being loaded at all. I now reinstalled the kernel, made sure the module existed, and rebooted. Got my screen back, phew

Revision history for this message
Julien Aubin (gojulgarbmail) wrote :

I've remarked that the fix randomly screws up my boot process, i.e. quite often the system hangs while booting, and I have to perform SAK system call during boot to get prompted into a root shell and type "mountall".
Then everything runs fine, but I have a background root shell, which is not exactly what I would like to have...

Bug explained there :
Launchpad #554564

Revision history for this message
Robert Hooker (sarvatt) wrote :

a better temporary fix for now until the support files are moved into /lib would be to just manually copy the modprobe blacklist to /etc/modprobe.d instead with something like

sudo cp /usr/lib/nvidia-current/modprobe.conf /etc/modprobe.d/nvidia.conf

the problem is that /etc/modprobe.d/nvidia-graphics-drivers.conf is a symlink to a device thats not mounted when it needs to be in your situation and Alberto is going to move it to /lib at some point to work around this.

Revision history for this message
Julien Aubin (gojulgarbmail) wrote :

This fixes the boot problem. Now I really think that the nvidia-glx packages should be made incompatible as this was the case previously, and the one used for the graphic card sets up its own /etc/modprobe.d/nvidia.conf instead of using update-alternatives. This would demand a bit more bandwidth to the user, but would be considerably much safer...

Revision history for this message
Andreas Hasenack (ahasenack) wrote :

I'm also getting another issue, which may warrant another bug report entirely, but I wanted to show it here since it started happening as soon as I installed the nvidia related packages.

In the attached screenshot, you can see my bootsplash. It's "wrong". The colors are off, the resolution is also off. It doesn't fit the screen anymore.

Did you guys also get this? It started happening at exactly the first boot after I installed the nvidia driver.

Revision history for this message
Andreas Hasenack (ahasenack) wrote :

BTW, what is a conf file doing in /usr/lib? Doesn't that violate at least one of the gazillion Debian policies?

Revision history for this message
Julien Aubin (gojulgarbmail) wrote :

There's already a bug upon that. Search in launchpad "console is broken with vga=791" or stg like that.

Revision history for this message
Pavel Malyshev (afunix) wrote :

I have separate /usr too, and copying nvidia-current/modprobe.conf to /etc/modprobe.d helped me too.
And now my splash screen looks strange... too...
It looks like low resolution and low color mode is set in the bootsplash

Revision history for this message
Alberto Milone (albertomilone) wrote :

@Andreas
the configuration file in /usr/lib is part of the new alternatives system (which installs a slave link to it in /etc/modprobe.d). I plan on moving it to /lib/nvidia-$flavour though, so as to get around the problem.

@afunix
That's a 16 colours bootsplash.

summary: - Nouveau blacklisting with /usr on seperate partition fails (Lucid
- Alpha3)
+ KMS driver blacklisting with /usr on separate partition fails (Lucid)
Changed in nvidia-graphics-drivers-96 (Ubuntu Lucid):
status: New → Triaged
Changed in fglrx-installer (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → High
Changed in nvidia-graphics-drivers-173 (Ubuntu Lucid):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High
Changed in nvidia-graphics-drivers-96 (Ubuntu Lucid):
assignee: nobody → Alberto Milone (albertomilone)
Changed in fglrx-installer (Ubuntu Lucid):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-173 (Ubuntu Lucid):
status: New → Triaged
Changed in nvidia-graphics-drivers-96 (Ubuntu Lucid):
importance: Undecided → High
Revision history for this message
Alberto Milone (albertomilone) wrote :

I have changed the title and opened a task for the nvidia legacy drivers and for fglrx as they are all affected by this problem.

description: updated
description: updated
Revision history for this message
Andreas Hasenack (ahasenack) wrote :

Scott, you should refrain from offending people who try to help and actually managed to debug this problem. What this accomplishes is that they won't even file a bug the next time this happens, even less try to fix it.

A more constructive change would be to just say it's wrong (and not include the S word) and say why, even if it's obvious to you.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:8.721-0ubuntu8

---------------
fglrx-installer (2:8.721-0ubuntu8) lucid; urgency=low

  * debian/rules, fglrx.dirs, fglrx.postinst:
    - Install the blacklist file in /lib/fglrx instead of
      /usr/lib/fglrx so that the file is available early
      in the boot process when /usr is on a different
      partition (LP: #538071).
    - Ignore errors when trying to update the initramfs
      with -k $CURRENT_KERNEL which is known to fail when
      using chroots (LP: #556653).
    - Make 10fglrx a slave link so that it's removed from
      /etc/X11/Xsession.d when we switch to a different
      alternative (LP: #552903).
  * debian/fglrx.preinst:
    - Make sure that any 10fglrx file in /etc/X11/Xsession.d
      which is not a symbolic link is removed.
    - Remove diversions previously added by xorg-driver-fglrx
      not by fglrx (LP: #552782). Thanks to Steve Langasek
      for spotting the problem.
 -- Alberto Milone <email address hidden> Thu, 08 Apr 2010 18:37:48 +0200

Changed in fglrx-installer (Ubuntu Lucid):
status: Triaged → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-96 - 96.43.14-0ubuntu12

---------------
nvidia-graphics-drivers-96 (96.43.14-0ubuntu12) lucid; urgency=low

  * debian/nvidia-$flavour.{dirs|postinst}.in, rules:
    - Install the blacklist file in /lib/nvidia-$flavour instead
      of /usr/lib/nvidia-$flavour so that the file is available
      early in the boot process when /usr is on a different
      partition (LP: #538071).
    - Ignore errors when trying to update the initramfs
      with -k $CURRENT_KERNEL which is known to fail when
      using chroots (LP: #556653).
 -- Alberto Milone <email address hidden> Fri, 09 Apr 2010 13:03:03 +0200

Changed in nvidia-graphics-drivers-96 (Ubuntu Lucid):
status: Triaged → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-173 - 173.14.22-0ubuntu11

---------------
nvidia-graphics-drivers-173 (173.14.22-0ubuntu11) lucid; urgency=low

  * debian/nvidia-$flavour.{dirs|postinst}.in, rules:
    - Install the blacklist file in /lib/nvidia-$flavour instead
      of /usr/lib/nvidia-$flavour so that the file is available
      early in the boot process when /usr is on a different
      partition (LP: #538071).
    - Ignore errors when trying to update the initramfs
      with -k $CURRENT_KERNEL which is known to fail when
      using chroots (LP: #556653).
 -- Alberto Milone <email address hidden> Fri, 09 Apr 2010 13:10:28 +0200

Changed in nvidia-graphics-drivers-173 (Ubuntu Lucid):
status: Triaged → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers - 195.36.15-0ubuntu2

---------------
nvidia-graphics-drivers (195.36.15-0ubuntu2) lucid; urgency=low

  * debian/nvidia-$flavour.{dirs|postinst}.in, rules:
    - Install the blacklist file in /lib/nvidia-$flavour instead
      of /usr/lib/nvidia-$flavour so that the file is available
      early in the boot process when /usr is on a different
      partition (LP: #538071).
    - Ignore errors when trying to update the initramfs
      with -k $CURRENT_KERNEL which is known to fail when
      using chroots (LP: #556653).
 -- Alberto Milone <email address hidden> Fri, 09 Apr 2010 13:18:57 +0200

Changed in nvidia-graphics-drivers (Ubuntu Lucid):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers