" Failed to allocate video memory" nvidia-current on lucid

Bug #537218 reported by blakamin on 2010-03-11
68
This bug affects 12 people
Affects Status Importance Assigned to Milestone
NVIDIA Drivers Ubuntu
Undecided
Unassigned
nvidia-graphics-drivers (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: xorg

Booted laptop after updates from yesterday to find:
(EE) NVIDIA(0): Failed to allocate video memory
(EE) NVIDIA(0): *** Aborting ***

Since then I have to run in low graphics.

====================
Workaround:
  Add option "nopat" to kernel parameters.
====================

ProblemType: Bug
Architecture: i386
Date: Thu Mar 11 22:24:34 2010
DistroRelease: Ubuntu 10.04
DkmsStatus:
 nvidia-173, 173.14.22, 2.6.32-16-generic, i686: installed
 nvidia-current, 195.36.08, 2.6.32-15-generic, i686: installed
 nvidia-current, 195.36.08, 2.6.32-16-generic, i686: installed
MachineType: Acer, inc. Aspire 4520
NonfreeKernelModules: nvidia
Package: xorg 1:7.5+3ubuntu1
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-16-generic root=UUID=7959c660-f328-4e8f-a073-ad6baf734ef9 ro quiet splash
ProcEnviron:
 LANG=en_NZ.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: xorg
Symptom: display
Uname: Linux 2.6.32-16-generic i686
dmi.bios.date: 07/09/2007
dmi.bios.vendor: Acer
dmi.bios.version: v1.3615
dmi.board.name: Mono
dmi.board.vendor: Acer, Inc.
dmi.board.version: Not Applicable
dmi.chassis.type: 1
dmi.chassis.vendor: Acer, Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvrv1.3615:bd07/09/2007:svnAcer,inc.:pnAspire4520:pvrNotApplicable:rvnAcer,Inc.:rnMono:rvrNotApplicable:cvnAcer,Inc.:ct1:cvrN/A:
dmi.product.name: Aspire 4520
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer, inc.
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-16-generic

blakamin (blakamin) wrote :
Bryce Harrington (bryce) on 2010-03-11
affects: xorg (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
blakamin (blakamin) wrote :

Solved the problem by adding "nopat" to grub.cfg.
So is this the driver or the kernel? Combination of both maybe?

Matthias Klumpp (ximion) wrote :

Same here.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
description: updated
Kow (kow) wrote :

Is it possible to have the nvidia debs automatically add 'nopat' to /etc/default/grub and run update-grub ?

Igneus (thmaureira) wrote :

Solved adding "nopat" to /etc/default/grub.cfg and update-grub!

Daniel Hahler (blueyed) wrote :

For what's it worth, this started happening for me in Maverick, see bug 607490.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Daniel Hahler (blueyed) wrote :

Posted my workaround at: https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/607490/comments/36

I am not sure how much these bugs are really related, but probably they are.

Matthias Schmidt (mschmidt) wrote :

I can confirm that setting "nopat" in GRUB actually solves the problem for me. Strange enough, the problem with the NVIDIA card (I have a Geforce GTX 460) only appears when using x86_64 on Ubuntu 10.10. If I boot 10.10 on same hardware as 32bit installation, everything works fine.

Matthias Schmidt (mschmidt) wrote :

A side node to #8. It makes a difference if I start with IOMMU enabled in BIOS or not. If IOMMU is enabled, the Nvidia card does not work. If its disabled, it works with "nopat".

Bryce Harrington (bryce) on 2011-03-30
tags: added: natty
tags: added: maverick
Bryce Harrington (bryce) wrote :

Looks like this issue is still being seen on natty, after just looking at bug #731810, which I've set as a dupe of this.

It sounds like the root problem here is a bug in vesafb's memory handling when using a PAT-enabled kernel. There is some topical conversation about this at http://www.nvnews.net/vbulletin/showthread.php?t=148417

Presumably either booting with "nopat" or "vesafb.invalid=1" kernel parameters in grub should work around the bug. Disabling vesafb will also disable the boot logo graphic, fwiw.

Alberto Milone (albertomilone) wrote :

The problem with vesafb might be solved in the latest version of grub2 in Natty.

udippel (udippel) wrote :

I can confirm that the problem exists with 11.04 unmitigated. Bummer.

dino99 (9d9) wrote :

That version is no more supported; please open a new bug report if the actual archive found version also has the same issue.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Triaged → Invalid
Changed in nvidia-drivers-ubuntu:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers