nvidia/lucid deinstall of nvidia'current causes X11 mayhem

Bug #535339 reported by SeanBoran on 2010-03-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

Doing Uninstallation Testing according to
http://xorg.qa.ubuntu.com/qatracker/result/3729/427
week 4, Case ID: xpr-010

OK
# Boot with functioning proprietary driver
# Using the GUI software management tools, mark the proprietary driver for removal
# Verify the driver is removed by running dpkg -l '*fglrx*' and dpkg -l '*nvidia*' and noting any remaining installed components

dpkg -l '*nvidia*'
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-=================-=================-==================================================
ii nvidia-173 173.14.22-0ubuntu NVIDIA binary Xorg driver, kernel module and VDPAU
ii nvidia-173-modali 173.14.22-0ubuntu Modaliases for the NVIDIA binary X.Org driver
ii nvidia-96-modalia 96.43.14-0ubuntu1 Modaliases for the NVIDIA binary X.Org driver
ii nvidia-common 0.2.21 Find obsolete NVIDIA drivers
rc nvidia-current 195.36.08-0ubuntu NVIDIA binary Xorg driver, kernel module and VDPAU
ii nvidia-current-mo 195.36.08-0ubuntu Modaliases for the NVIDIA binary X.Org driver
un nvidia-glx <none> (no description available)
un nvidia-libvdpau <none> (no description available)
un nvidia-libvdpau1 <none> (no description available)
un nvidia-settings <none> (no description available)

# Reboot

Broken:
# Verify system starts up in GUI mode
==> lines on the screen.

Hell.
Removed nvidia-current via apt-get and rebooted.
Lines on the screen, login via text console (using update-alternatives), select free driver.
Same.
Tried to deinstall and reinstall nvidia-current package. Same result.
Over an hour later managed to get backup running nvidia-173.

[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x3b) [0x80e880b]
1: /usr/bin/X (mieqEnqueue+0x1ab) [0x80e7ffb]
2: /usr/bin/X (xf86PostMotionEventP+0xcc) [0x80c29ac]
3: /usr/lib/xorg/modules/input/evdev_drv.so (0xb556d000+0x4871) [0xb5571871]
4: /usr/lib/xorg/modules/input/evdev_drv.so (0xb556d000+0x4b66) [0xb5571b66]
5: /usr/bin/X (0x8048000+0x6d2af) [0x80b52af]
6: /usr/bin/X (0x8048000+0x121c54) [0x8169c54]
7: (vdso) (__kernel_sigreturn+0x0) [0xb78c7400]
8: /usr/lib/libpixman-1.so.0 (0xb77e8000+0x414fa) [0xb78294fa]
9: /usr/lib/libpixman-1.so.0 (0xb77e8000+0x424e4) [0xb782a4e4]
10: /usr/lib/libpixman-1.so.0 (0xb77e8000+0x4cf29) [0xb7834f29]
11: /usr/lib/libpixman-1.so.0 (0xb77e8000+0x145c3) [0xb77fc5c3]
12: /usr/lib/libpixman-1.so.0 (pixman_image_composite+0x16f) [0xb78222cf]
13: /usr/lib/xorg/modules/libfb.so (fbComposite+0x1cc) [0xb60f605c]
14: /usr/lib/xorg/extra-modules/nvidia_drv.so (0xb60ff000+0x3daae1) [0xb64d9ae1]
[mi] EQ overflowing. The server is probably stuck in an infinite loop.

ProblemType: Bug
Architecture: i386
CurrentDmesg:
 [ 35.357907] ppdev: user-space parallel port driver
 [ 44.616027] eth0: no IPv6 routers present
 [ 101.061062] CE: hpet increasing min_delta_ns to 15000 nsec
Date: Tue Mar 9 21:55:28 2010
DistroRelease: Ubuntu 10.04
DkmsStatus:
 nvidia-current, 195.36.08, 2.6.32-12-generic-pae, i686: installed
 nvidia-173, 173.14.22, 2.6.32-12-generic-pae, i686: installed
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100209)
MachineType: Dell Inc. MXG061
NonfreeKernelModules: nvidia
Package: nvidia-current 195.36.08-0ubuntu1
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-12-generic-pae root=UUID=d0ac9329-72bd-4696-a52f-7707e4467cd3 ro quiet splash
ProcEnviron:
 LANGUAGE=en
 PATH=(custom, no user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-12.17-generic-pae
SourcePackage: nvidia-graphics-drivers
Uname: Linux 2.6.32-12-generic-pae i686
dmi.bios.date: 06/27/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A07
dmi.board.name: 0CF456
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA07:bd06/27/2007:svnDellInc.:pnMXG061:pvr:rvnDellInc.:rn0CF456:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: MXG061
dmi.sys.vendor: Dell Inc.
system:
 distro: Ubuntu
 codename: lucidarchitecture: i686kernel: 2.6.32-12-generic-pae

SeanBoran (sean-boran) wrote :
Robert Hooker (sarvatt) on 2010-03-16
description: updated
Andreas Hasenack (ahasenack) wrote :

Assuming this is Lucid, do you have /usr as a separate partition? If you do, then this is likely a duplicate of bug #538071

dino99 (9d9) wrote :

That version is no more supported; please open a new bug report if the actual archive found version also has the same issue.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers