(Needs 195.36.15) X crashes during suspend/resume

Bug #534754 reported by Rocko on 2010-03-09
114
This bug affects 19 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: gdm

In Ubuntu 10.04, X crashes consistently on the suspend/resume cycle.

The symptoms are one of the following:

* X crashes on standby: the gdm-greeter screen appears complete with login prompt just before standby. The system either enters standby or doesn't; I can log in to X again.

* X crashes on standby: the gdm-greeter screen appears but without login prompt. The system either enters standby or doesn't; I can't login because there is no login prompt and have to reboot the PC.

* X crashes on resume: the PC appears to enter stand-by successfully but the gdm-greeter screen is present on resume. This may be the same as the first case except that the PC enters standby earlier, ie before the gdm-greeter screen can appear.

The attached /var/log/Xorg.0.log shows a segmentation fault in X during standby.

I have tried different combinations of the 2.6.33 and 2.6.32 (stock Ubuntu) kernels and the nvidia 195.30 (installed via nvidia installer) and 195.36.08 (installed with jockey) drivers and they all exhibit the same problem.

The one time that I can recall a successful standby/resume cycle (ie where it goes back to the screensaver password prompt) is immediately after I added the nomodeset command to the kernel boot options. However, it has not worked successfully since.

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x28) [0x4a25d8]
1: /usr/bin/X (0x400000+0x652dd) [0x4652dd]
2: /lib/libpthread.so.0 (0x7ffdcf7d1000+0xf920) [0x7ffdcf7e0920]
3: /usr/lib/xorg/modules/drivers/nvidia_drv.so (_nv001450X+0x16) [0x7ffdca610126]
4: /usr/lib/libpixman-1.so.0 (0x7ffdcf136000+0xa4a2) [0x7ffdcf1404a2]
5: /usr/lib/libpixman-1.so.0 (0x7ffdcf136000+0x34859) [0x7ffdcf16a859]
6: /usr/lib/libpixman-1.so.0 (0x7ffdcf136000+0x2ef6b) [0x7ffdcf164f6b]
7: /usr/lib/libpixman-1.so.0 (0x7ffdcf136000+0x36cc2) [0x7ffdcf16ccc2]
8: /usr/lib/libpixman-1.so.0 (0x7ffdcf136000+0x38030) [0x7ffdcf16e030]
9: /usr/lib/libpixman-1.so.0 (0x7ffdcf136000+0x2ec6a) [0x7ffdcf164c6a]
10: /usr/lib/libpixman-1.so.0 (pixman_image_composite+0x17c) [0x7ffdcf165acc]
11: /usr/lib/xorg/modules/libwfb.so (wfbComposite+0x1c0) [0x7ffdca118be0]
12: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7ffdca545000+0x323605) [0x7ffdca868605]
13: /usr/bin/X (0x400000+0xd7440) [0x4d7440]
14: /usr/bin/X (0x400000+0x164519) [0x564519]
15: /usr/bin/X (0x400000+0x1647e5) [0x5647e5]
16: /usr/bin/X (0x400000+0xa6146) [0x4a6146]
17: /usr/bin/X (0x400000+0x53586) [0x453586]
18: /usr/bin/X (MapWindow+0x179) [0x4576d9]
19: /usr/bin/X (0x400000+0x302d6) [0x4302d6]
20: /usr/bin/X (0x400000+0x30bac) [0x430bac]
21: /usr/bin/X (0x400000+0x2613a) [0x42613a]
22: /lib/libc.so.6 (__libc_start_main+0xfd) [0x7ffdce4cac4d]
23: /usr/bin/X (0x400000+0x25ce9) [0x425ce9]
Segmentation fault at address 0x132785

ProblemType: Bug
Architecture: amd64
CheckboxSubmission: 1bd8e90541d49b96c13cbfcc9baf103b
CheckboxSystem: d00f84de8a555815fa1c4660280da308
Date: Tue Mar 9 07:55:46 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100224.1)
NonfreeKernelModules: nvidia
Package: gdm 2.29.6-0ubuntu7
ProcEnviron:
 PATH=(custom, user)
 LANG=en_AU.utf8
 SHELL=/bin/bash
SourcePackage: gdm
Uname: Linux 2.6.33-generic x86_64

Rocko (rockorequin) wrote :
Sebastien Bacher (seb128) wrote :

thank you for your bug report, xorg crashing is an xorg issue though not a gdm one

affects: gdm (Ubuntu) → xorg-server (Ubuntu)
Bryce Harrington (bryce) wrote :

Thanks for submitting this bug report to make Ubuntu better. However, to report an X crash certain additional information is required, including a full backtrace. Please see http://wiki.ubuntu.com/X/Backtracing for guidance.

Changed in xorg-server (Ubuntu):
status: New → Invalid
Rocko (rockorequin) wrote :

I made another backtrace using the "screen" command. Does it contain sufficient information?

Out of interest, is there a program that will translate the original backtrace without symbols into a backtrace with symbols once the debug symbols are loaded?

Changed in xorg-server (Ubuntu):
status: Invalid → New
Rocko (rockorequin) wrote :

Also noting that this backtrace is with the nvidia 195.30 driver loaded, since nvidia pulled the 195.36.08 driver in case it damages cards by turning off the fan.

On Tue, Mar 09, 2010 at 11:36:21PM -0000, Rocko wrote:
> Also noting that this backtrace is with the nvidia 195.30 driver loaded,
> since nvidia pulled the 195.36.08 driver in case it damages cards by
> turning off the fan.

As Bryce said before you need to collect more informaiton for your bug, apport can do this automatically, you just need to run apport-bug 534754 in the command line (Application -> Accessories -> Terminal) and that should give us enough info. Thanks.

--
Regards,
Vikram Dhillon

A Computer Engineer was asked by his five-year-old son: "Dad, what is Windows 95?".
"Well, it's 32-bit extensions and a graphical shell for a 16-bit patch to an 8-bit operating system originally coded for a 4-bit microprocessor, written by a 2-bit company that can't stand 1 bit of competition."

Ah, the page Bryce directed me to was all about obtaining backtraces in the first place.

I ran apport-collect (apport-bug expects a pid, not the bug number), but it reports it has nothing further to add. The console says:

"Package xorg-server not installed and no hook available, ignoring"

It's true that dpkg doesn't list any entries for xorg-server. Is the assigned package for this bug wrong? Should it be xserver-xorg?

Bryce Harrington (bryce) on 2010-03-10
tags: added: crash
Bryce Harrington (bryce) on 2010-03-10
affects: xorg-server (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Alex Murray (alexmurray) wrote :

Might be worthwhile testing the just released prerelease Nvidia driver195.36.15 since it may fix the crash on resume and the fan problems as well, from http://www.nvnews.net/vbulletin/showthread.php?t=148947

Fixed a bug that caused the X server to crash when rendering occurred while the X server was not on the active VT.
Fixed a regression that caused the driver to fail to properly adjust the GPU fan speed on some GPUs.
Fixed a bug that prevented performance level transitions on recent GPUs with SDDR3 and GDDR5 memory.

If anyone can package it up into a PPA I'd be keen to test it

Robert Hooker (sarvatt) on 2010-03-16
summary: - X crashes during suspend/resume
+ (Needs 195.36.15) X crashes during suspend/resume
description: updated
Bryce Harrington (bryce) on 2010-03-16
Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Triaged
importance: Undecided → High
Rocko (rockorequin) wrote :

I installed 195.36.15 from the nvidia installer and I've done four successful suspend/resume cycles, so it does seem to fix the problem.

Noel J. Bergman (noeljb) wrote :

That's good news about 195.36.15, because 190.53 was the last nvidia driver to successfully suspend and resume for me.

Rocko (rockorequin) wrote :

Yes, it is good news!

And it has worked flawlessly for me now for the last couple of days, so it definitely fixes the bug.

Robert Hooker (sarvatt) wrote :

Alberto has uploaded a 195.36.15 nvidia-current package, and it will be available as soon as the archive freeze is over when beta 1 is released.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Triaged → Fix Committed
Bogdan Butnaru (bogdanb) wrote :

Sorry for being off-topic, but isn’t the -proposed repository useful for making such fixes available during freezes?

Robert Hooker (sarvatt) wrote :

nvidia-graphics-drivers (195.36.15-0ubuntu1) lucid; urgency=low

  * New upstream release:
    - Fixed a bug that caused the X server to crash when rendering
      occurred while the X server was not on the active VT.
    - Fixed a regression that caused the driver to fail to properly
      adjust the GPU fan speed on some GPUs.
    - Fixed a bug that prevented performance level transitions on
      recent GPUs with SDDR3 and GDDR5 memory.
  * debian/nvidia-$flavour.{postinst|prerm}.in:
    - Call gmenucache trigger so that the icon of nvidia-settings
      shows up in the menu (LP: #522969).
  * debian/nvidia-current.links{32}.in:
    - Add link to libOpenCL.so in /usr/lib and in /usr/lib32.

Date: Wed, 17 Mar 2010 10:21:52 +0100
Changed-By: Alberto Milone <alberto.milone at canonical.com>

Changed in nvidia-graphics-drivers (Ubuntu):
status: Fix Committed → Fix Released
u-foka (ufooka) wrote :

Thanks! The problem is now seems to solved!

Miloš Mandarić (mandzo18) wrote :

After last updates this issue is fixed for me.

zweetvoetje (roelanddilz) wrote :

This problem seems to be troubling me too.
I'm using an old fx5500 video card, so I can't use driver 195.36.15. The newest driver is 173.x.x. So there's no fix for me...

I do encounter the same problem. I do see the 'lock-screen' just a short time before powerdown.
When rebooting everything seems to go nice and smooth, except there is no video output. I can login using SSH, and it seems all is normal except for xorg using 100% cpu.

Maybe I should note that I'm using tvout as the main-screen.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers