Compiz displays upside down

Bug #531467 reported by WaywardGeek on 2010-03-03
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

In Ubuntu Lucid Alpha, When switching to "Normal" visual effects, the desktop is shown upside down. I found the following 2-day old thread discussing this problem here:

http://<email address hidden>/msg48053.html

As suggested in the thread, I removed all video drivers, and compiz with the "Remove completely" option in Synaptic. I then rebooted, and used a repair login to install xserver-xorg-video-ati, and compiz. While this works for other users, with other graphics drivers, it does not work for me. This may be an ATI graphics bug.

Another clue may be that ubuntu-bug insists on reporting this as an nvidia bug, when I don't even have the nv or nouveau drivers installed!

ProblemType: Bug
Architecture: i386
Date: Wed Mar 3 12:02:20 2010
DistroRelease: Ubuntu 10.04
DkmsStatus:
 nvidia-173, 173.14.22, 2.6.32-14-generic, i686: installed
 nvidia-173, 173.14.22, 2.6.32-15-generic, i686: installed
InstallationMedia: Vinux-3.0-Alpha-3 - Release i386
Lsusb:
 Bus 002 Device 002: ID 8087:0020
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 003: ID 0c45:6417 Microdia
 Bus 001 Device 002: ID 8087:0020
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. Studio 1557
Package: xorg 1:7.5+1ubuntu11
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-15-generic root=UUID=5afce1b7-acb2-4f06-8ee3-9e9f9217bbab ro quiet splash
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-15.22-generic
SourcePackage: nvidia-graphics-drivers
Symptom: display
Uname: Linux 2.6.32-15-generic i686
dmi.bios.date: 10/06/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A02
dmi.board.name: 0KM426
dmi.board.vendor: Dell Inc.
dmi.board.version: A02
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A02
dmi.modalias: dmi:bvnDellInc.:bvrA02:bd10/06/2009:svnDellInc.:pnStudio1557:pvrA02:rvnDellInc.:rn0KM426:rvrA02:cvnDellInc.:ct8:cvrA02:
dmi.product.name: Studio 1557
dmi.product.version: A02
dmi.sys.vendor: Dell Inc.
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: lucidarchitecture: i686kernel: 2.6.32-15-generic

WaywardGeek (waywardgeek) wrote :
WaywardGeek (waywardgeek) wrote :

I searched for 'nvidia' in synaptic, and then removed every package that used the name. This caused compiz to start working properly with my ATI driver!

Bill

Sal Mazzola (salmaz) wrote :

Worked for me to remove all the nvidia with my ATI card as well. Thanks for the tip WaywardGeek!

Randy Wilson (blazerw) wrote :

Worked for me as well. However, I have an Intel Series 4 GPU (GM45). Uninstalled anything with "nvidia" in the name and it was fixed. Note that the reversed screen only happens with Desktop Effects enabled. Disabling desktop effects immediately fixes the screen as well.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers