Xorg crashed with SIGSEGV

Bug #525595 reported by ashayh on 2010-02-22
70
This bug affects 15 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Medium
Unassigned

Bug Description

Laptop was on for 22+ hours.

ProblemType: Crash
Architecture: i386
Date: Sun Feb 21 20:17:39 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/Xorg
MachineType: Hewlett-Packard HP Pavilion dv9000 (EY797AV#ABA)
NonfreeKernelModules: nvidia
Package: xserver-xorg-core 2:1.6.4-2ubuntu4 [modified: usr/lib/xorg/modules/extensions/libglx.so]
ProcCmdLine: root=/dev/mapper/dawkins-root ro quiet splash rootflags=data=writeback
ProcCmdline: /usr/bin/X :0 -br -verbose -auth /var/run/gdm/auth-for-gdm-QBapUn/database -nolisten tcp
ProcEnviron:
 LANG=en_US.UTF-8
 PATH=(custom, no user)
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu7
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
SegvAnalysis:
 Segfault happened at: 0x8113415: mov 0x8(%edi),%edx
 PC (0x08113415) ok
 source "0x8(%edi)" (0x558b0008) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: xorg-server
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? () from /usr/lib/xorg/modules/drivers//nvidia_drv.so
Title: Xorg crashed with SIGSEGV
Uname: Linux 2.6.31-14-generic i686
UserGroups:

dmi.bios.date: 01/02/2007
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.13
dmi.board.name: 30BD
dmi.board.vendor: Quanta
dmi.board.version: 66.36
dmi.chassis.type: 10
dmi.chassis.vendor: Quanta
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.13:bd01/02/2007:svnHewlett-Packard:pnHPPaviliondv9000(EY797AV#ABA):pvrRev1:rvnQuanta:rn30BD:rvr66.36:cvnQuanta:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv9000 (EY797AV#ABA)
dmi.product.version: Rev 1
dmi.sys.vendor: Hewlett-Packard
fglrx: Not loaded
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-14-generic

ashayh (ashay-humane) wrote :

StacktraceTop:miDCPutUpCursor (pDev=0x8b48600, pScreen=0x89e54d8, pCursor=0x8b91360,
miSpriteRestoreCursor (pDev=<value optimized out>,
xf86CursorEnableDisableFBAccess (index=0, enable=1)
?? () from /usr/lib/xorg/modules/drivers//nvidia_drv.so

Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Bryce Harrington (bryce) on 2010-07-18
tags: added: crash
Changed in xorg-server (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2010-07-20
tags: added: karmic
Bryce Harrington (bryce) on 2010-11-26
visibility: private → public
Timo Aaltonen (tjaalton) on 2011-01-23
affects: xorg-server (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
bugbot (bugbot) wrote :

This bug report was filed against an old version of Ubuntu.
Can you confirm whether this is still an issue in natty?

If you don't mind, it would be very helpful if you could update the bug
report in launchpad to 'Fix Released' if it is no longer an issue for
you, or if it is still occurring under natty, please tag the bug 'natty'
so it's easier for us to track.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → New
status: New → Incomplete
bugbot (bugbot) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → Expired
Walter Ribeiro (wribeirojr) wrote :

Ubuntu 13.04
HP Pavilion dv6000
nvidia-304-updates

Changed in nvidia-graphics-drivers (Ubuntu):
status: Expired → Confirmed
To post a comment you must log in.