gnome-screensaver-gl-helper crashed with SIGSEGV in exit()

Bug #508531 reported by Roy Jamison on 2010-01-16
116
This bug affects 20 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-screensaver

Unknown reason for this bug report, possibly gnome entering screensaver, as I did not touch the laptop for a few minutes, didn't think it was over 5 minutes though.

ProblemType: Crash
Architecture: i386
Date: Sat Jan 16 20:47:15 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/lib/gnome-screensaver/gnome-screensaver-gl-helper
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100113)
NonfreeKernelModules: nvidia
Package: gnome-screensaver 2.28.0-1ubuntu4
ProcCmdline: /usr/lib/gnome-screensaver/gnome-screensaver-gl-helper
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-10.14-generic
SegvAnalysis:
 Segfault happened at: 0x6cebe8: mov (%eax),%esi
 PC (0x006cebe8) ok
 source "(%eax)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%esi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-screensaver
StacktraceTop:
 ?? () from /usr/lib/nvidia-current/libGL.so.1
 ?? () from /lib/tls/i686/cmov/libc.so.6
 exit () from /lib/tls/i686/cmov/libc.so.6
 __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
 ?? ()
Tags: lucid
Title: gnome-screensaver-gl-helper crashed with SIGSEGV in exit()
Uname: Linux 2.6.32-10-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Roy Jamison (xteejx) wrote :

StacktraceTop:
 ?? () from /usr/lib/nvidia-current/libGL.so.1
 __run_exit_handlers (status=-1216544704, listp=0x8f61304,
 *__GI_exit (status=0) at exit.c:100
 __libc_start_main (main=0x8048cb0 <main>, argc=1,
 _start ()

Changed in gnome-screensaver (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
affects: gnome-screensaver (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Roy Jamison (xteejx) wrote :

Appears to be working fine now, haven't seen any problems, so closing bug report since I don't know what fixed it.

Changed in nvidia-graphics-drivers (Ubuntu):
importance: Medium → Undecided
status: New → Invalid
PJO (paul-onolan) wrote :

I got this error when installing Nvidia drivers in Ubuntu 10.04 beta 1 (fresh install, all updates applied). It's repeatable. Since this is closed I'll find an open bug with the same error and upload the crash report.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers