Installing nvidia kills xorg on non-nvidia systems, or makes display upside down

Bug #496363 reported by Martin Owens on 2009-12-14
116
This bug affects 21 people
Affects Status Importance Assigned to Milestone
ltsp (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
nvidia-graphics-drivers (Ubuntu)
Wishlist
Alberto Milone
Lucid
Wishlist
Alberto Milone

Bug Description

On a system where i was moving hard drives from one machine to another, I noticed that the second machine would not boot successfully because the first had an nvidia driver which was loaded for it's operation.

This presents a problem, because if the nvidia package could be accidentally installed, then people could end up with non working systems.

Removing /etc/X11/xorg.conf fixed the problem.

For more info and ways to work around this problem, see:
https://wiki.ubuntu.com/X/Troubleshooting/NvidiaDriverSwitching

Bryce Harrington (bryce) wrote :

Yeah the issue is most likely that you had "nvidia" configured in your xorg.conf, but the new hardware I assume was non-nvidia (or at least a video chip not supported by whatever nvidia driver you had installed).

Sort of a hard issue to solve or work around, but one we've known about. There are several ways this situation could be avoided. 1) Make it unnecessary to specify "nvidia" in xorg.conf by automatically detecting it in xserver (see xserver patches 104/105). 2) Have functionality in the xserver to somehow detect when the hardware has changed and inform the user. 3) Drop the system into failsafe-x in this situation with guidance to enable the proper driver for the new hardware.

All three of these options are identified as tasks in https://blueprints.edge.launchpad.net/ubuntu/+spec/desktop-lucid-xorg-proprietary-drivers but are currently set to POSTPONED.

affects: nvidia-graphics-drivers-180 (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Changed in nvidia-graphics-drivers (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
assignee: nobody → Alberto Milone (albertomilone)
Bryce Harrington (bryce) on 2010-03-24
description: updated
SabreWolfy (sabrewolfy) wrote :

Confirmed in Lucid Beta 1 with updates (updated online from Karmic) on Acer laptop which does *not* have an NVidia card in it. Screen is reversed as per Bug #544774 (Duplicate). gdm still as per Karmic, not Lucid. No xorg.conf file in /etc/X11, although there never has been. Running Intel graphics. Any solution / workaround?

SabreWolfy (sabrewolfy) wrote :

Workaround here:

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/544813

solved the reversed / flipped screen issue. Loading of Karmic gdm in Lucid is obviously unrelated.

Running Intel GMA 950 for reference.

Martin Pitt (pitti) on 2010-04-23
Changed in nvidia-graphics-drivers (Ubuntu Lucid):
status: Triaged → Won't Fix
SabreWolfy (sabrewolfy) wrote :

Why wontfix? What does this mean?

komputes (komputes) wrote :

@ SabreWolfy, I think Martin marked it as "Not going to be fixed in Lucid". This is most definitely still an issue. As a workaround is available, the bug looses some priority (especially at this point in the Lucid release cycle).

The issue will most likely be fixed in a future release.

@Alberto and Bryce, could you set a new objective for this bug (perhaps Maverick) once you decide when it should be fixed.

Martin Pitt (pitti) wrote :

Right. Please note that maverick doesn't exist yet in Launchpad, so we can't target to maverick yet.

Bryce Harrington (bryce) on 2010-04-29
summary: - Installing nvidia kills xorg on non-nvidia systems
+ Installing nvidia kills xorg on non-nvidia systems, or makes display
+ upside down
James Cuzella (trinitronx) wrote :

I stumbled across this bug when trying to suspend on my new Lenovo ThinkPad T410. Upon starting it up again, I got an upside down and mirrored screen:

http://img543.imageshack.us/img543/4531/reversed.png

It was pretty trippy to say the least. Anyway, this happens due to compiz being started without the binary nvidia drivers installed at all. The problem with this laptop is that it's got "hybrid graphics". It contains both of these cards:

nVidia Quadro NVS 3100M with 512MB
Intel HD Graphics 5700MHD [ Intel(R) HD Graphics (Core i5) ]

$ lspci -vnnn | perl -lne 'print if /^\d+\:.+(\[\S+\:\S+\])/' | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller [0300]: nVidia Corporation GT218 [NVS 3100M] [10de:0a6c] (rev a2) (prog-if 00 [VGA controller])

Switching to tty1 and executing "DISPLAY=:0 metacity --replace" seems to fix it until the next reboot. However, I don't have "nvidia" in my xorg.conf, and I'm running the nouveau drivers. I'm also not sure why compiz keeps trying to start though yet.

This issue is probably related to the hybrid graphics support bug 312756

komputes (komputes) on 2012-03-20
tags: added: css-sponsored-p
Alberto Milone (albertomilone) wrote :

@James: this problem should be fixed in Ubuntu 12.04 as the system should automatically switch to the correct driver (if you install the nvidia driver) after a reboot if you have hybrid graphics.

Alkis Georgopoulos (alkisg) wrote :

Added "LTSP" to the affected projects, because it's very common there (nvidia drivers on the LTSP server, and e.g. intel-based clients), even though it can't be fixed in that project.

Changed in ltsp (Ubuntu):
status: New → Invalid
Changed in ltsp (Ubuntu Lucid):
status: New → Invalid
Alberto Milone (albertomilone) wrote :

We no longer set the driver in xorg.conf. Furthermore we have a mechanism (the hybrid-detect tool) which will automatically switch to the alternative for the available card.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Triaged → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/496363

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers