Please consider turning powermizer OFF

Bug #456637 reported by srikumar on 2009-10-20
86
This bug affects 15 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
High
Alberto Milone
Declined for Maverick by Sebastien Bacher

Bug Description

This is not a bug report but more of feature request.

I cannot use any nvidia driver newer than 185.18.14 on my Sony Vaio AR520E with Nvidia 8400M GT. The symptoms are, screen flickering, artifacts, complete system freeze, etc. It turns out that this is a well known problem with the latest drivers, a lot of people experience it. The problem is hardware specific, not OS dependent. The fix for is to turn powermizer off by creating a file /etc/modprobe.d/nvidia.conf with the following in it:

options nvidia NVreg_RegistryDwords="PerfLevelSrc=0x2222"

Since Karmic boots into graphical desktop by default, any user whose h/w is affected by this bug will not be able to get even a usable login prompt after installing the nvidia driver. The user may not even be able to fix the problem. In light of that, please consider changing the installer so that the user gets a choice of turning on powermizer with a warning that it may make the system unusable. There should also be a boot-time option to disable powermizer, if X does not stat properly. Or maybe it is better to turn off powermizer by default with a warning that turning it on may create problems.

Please consider turning the powermizer feature off, or make it optional.

Lod (ubuntu-louistielens) wrote :

I had the same problems within minutes or even before logging in (as described in the bug), for me the fix worked.
I had to boot up from a live cd and mount my drives manually to create the file.

I have a Sony Vaio VGN-AR41E with an NVidia GeForce 8400M GT graphics card.

Your problem is almost identical to my own. No driver newer than 185.18.14 will work properly.

The moment I reach the GDM login screen, artefacts appear. The more I move the mouse cursor, menus, or (especially) drag windows, the more artefacts occur.

After a moment or two, the computer will freeze, then reboot itself without my input.

One strange behaviour I found was that I could _prolong_ the length of time the computer would work by swapping to a TTY for a few seconds, as soon as I noticed any artefacts. I could then return to an artefact-free desktop for a moment longer. It would _always_ end up with artefacts and an eventual freeze/reboot.

srikumar (srikumar108) wrote :

I think it's unrealistic to expect a new user to fix the problem by booting from a live CD and create a text file in the right place, etc. If a first time karmic user is bitten by this bug, and cannot login, he/she is likely to scrap the Ubuntu install altogether and move on to something else. Hence my appeal that Uubuntu developers seriously consider turning off powermizer by default and make it optional. This would not have been an issue in the past because older drivers did not have this problem. But without this workaround, a lot of people will find themselves locked out of their Karmic boxes.

NRD (nickdecarlo) wrote :

Wanted to add a me too - I've been experiencing frequent artifacts on screen leading to eventual system instability. I've been running for 22h without one hiccup since I forced the Nvidia Powermizer to performance mode. It seems that before the 190 series drivers the only way to do this is to use srikumar's method above, however in the newer drivers (190 series) there is an option in Nvidia-settings to change the Powermizer settings. It would be great if we could include this as an option in the nvidia-settings for drivers prior to the 190 series. Nvidia must have included that option for good reason, so it only seems logical that it should also be included in previous versions. I honestly believe this would solve alot of issues that people are having running the latest NVidia drivers from the repo's 185.18.36.

Manjul Apratim (manzdagratiano) wrote :

I have been plagued by this bug as well and it has interrupted my karmic koala experience - I otherwise believe the new changes in karmic are quite impressive!

The permanent solution to this problem that I believe is (rather than a workaround which though works is still a workaround and hence an extra step that needs to be done to obtain a smooth desktop; and hence also pertains to Bug #1) that the 185.xx drivers in the repos be replaced with the newer 190.xx eventually (this would fix the problem without reliance on nvidia). Would that be possible to implement in karmic?

Have you tried the 190.xx drivers yourself? They don't fix the problem for me:)

Btw, I've been using the workaround for over a week now, and it's great! Compiz doesn't stutter when I flip windows, the GPU doesn't get any hotter than normal (according to NVidia Settings)...

Bryce Harrington (bryce) wrote :

Just for the record could those of you experiencing this please post your /var/log/Xorg.0.log so we can see what hardware, etc. is affected by this?

Changed in nvidia-graphics-drivers-180 (Ubuntu):
importance: Undecided → High
status: New → Triaged
Manjul Apratim (manzdagratiano) wrote :

After the bug I had reformatted my system with jaunty; people in the Ubuntu forums with similar issues had reported that the 190.xx drivers worked for them because it has a separate powermizer setting.

NRD (nickdecarlo) wrote :

Ah the sweet taste of victory... I could not resist doing a new install of karmic again now that some three months have elapsed, and it all went like a breeze - install took less than five minutes! Reboot - everything is perfect... update and upgrade, and install the proprietary nvidia drivers.... reboot, and powermizer bug is back... But this time I knew exactly what to do thanks to this fine bug report right here... and voila! - Karmic works like a charm! A myriad thanks!

hackel (hackel) wrote :

I do not support this bug. The users with faulty hardware that is affected by this bug, while significant, are not in the majority. I would be very frustrated if suddenly an Nvidia update caused Powermizer to be disabled for me. For most laptop users, this feature is crucial to obtaining decent battery life from these power-hungry graphics adapters.

The solution is obviously for Nvidia to fix its drivers. I do think, however, that when a user installs the Nvidia driver a HUGE warning should pop up to advise users that they are installing a proprietary driver, that the code has not been validated by *anyone* and that it could very easily destroy their computer, that if they experience problems it is NOT Ubuntu's fault and to report all issues directly to Nvidia.

Bryce Harrington (bryce) on 2010-03-05
tags: added: karmic
srikumar (srikumar108) wrote :

Sorry, it is not up to you to "support a bug." What I am proposing is a workaround so people don't end up with a unusable system. "Don't bother us, go to nvidia" is IMHO not what is Ubuntu about. "Don't use proprietary driver" is also a completely unrealistic advice for most users, you might as well tell potential Ubuntu users to move to Windows. I would understand if Ubuntu took a stance of not including proprietary drivers at all. But if nvidia drivers are included, then it makes sense to take steps to make it usable.

There have been several releases of the nVidia driver that have this issue for me.

The only way to get it working in linux is to disable powermizer. It works perfectly fine with the latest Vista video driver.

I have an nVidia GeForce 8400M GT btw.

No proposed fix for this yet? I have been running Karmic without any issues ever since the awesome workaround, but it would indeed be a formidable experience for someone unfamiliar with this problem to install a new system and see everything go haywire. If the solution is not to disable powermizer, it must be for the nvidia driver to check if the relevant drivers for fan speed etc are correctly installed or not - I believe that if they are not, and usually they are not, then the powermizer reports fake values causing the system to freeze? If it were to detect they are not installed, powermizer should be disabled, else left turned on for instance for someone like hackel above who does need it.

Lod (ubuntu-louistielens) wrote :

Installation of Ubuntu 10.04 forced me to take another look at this bug.
The workaround in the first post originated from this link: http://forums.nvidia.com/index.php?showtopic=102344.
I reread this thread and found out there were some new posts advising to update the BIOS. I downloaded an update from the ASUS site (which adressed this problem) and made the upgrade. It seems to do the trick for me, the nvidia driver is now working 'out of the box'.

ZelinskiyIS (ivze) wrote :

My hardware:
1) Asus M2A-VM motherboard,
2) NVidia GT220 card.

I had graphical artefacts problems after update to pre-release 10.04, used PowerMizer off workaround to make the system usable.
After updating BIOS firmware up to 2302 all is clear, no artefacts for some hours of testing, despite screen corruption would happen in less than ten minutes with PowerMizer on before.

In my case, the issue is no more!

ZelinskiyIS (ivze) wrote :

Sorry everyone, It was too early...
The whole situation is back, No I am having the same bugs after reboot.

ZelinskiyIS (ivze) wrote :

I have just tried `256.25 beta` drivers. Same result.

ZelinskiyIS (ivze) wrote :

Same for `256.29`. With PowerMizer on I got artefacts and garbage.

ZelinskiyIS (ivze) wrote :

It seems that the issue is no more with 195.36.31 drivers. Can anyone confirm this?

ZelinskiyIS (ivze) wrote :

There is no graphical garbage, but there are complete system freezes from time to time with PowerMizer on using 195.36.31 drivers.

rifter (rifter0x0000) wrote :

The people who claim only some people are affected by this bug are completely off base. This is a bug that affects everyone. It is ridiculous that the setting for the nvidia powermizer is not saved when you change it unless you do so by manually editing xorg.conf. It's also pretty annoying that it defaults to the lowest performance setting even on a desktop. On my system this results in what is a pretty decent nvidia card using performance that would have been considered weak something like 10 years ago. I'm talking about clocks going down to 1/12 speed.
And it should not affect desktop performance, but it does. It especially seems to affect video. And like pretty much all "adaptive" cpu technologies to date it is not very adaptive in that it does not change performance levels quickly enough if at all. I read something online that suggested that powermizer waits 15 seconds after detecting a performance change to change performance.
There are settings available to make powermizer default to a different performance mode and even set it to be smart enough to use a different setting when on ac power versus battery power. Of course right now the change in performance mode is not saved when done through the gui and there is no gui way to change the other stuff, but the capability exists. There's really no excuse for this bug having persisted for years without relief.
The problem I see with editing xorg.conf manually, besides the fact there is a lot of misinformation and bad instructions out there for how to set powermizer therein which have led people to a bad pass at times and besides the aforementioned problem that this is a high bar for the target Ubuntu user, is that what you put in there is likely to get blown away unless there is some awareness in the tools involved and installers that also edit xorg.conf on a regular basis.
All that aside, quite apart from the fact that EVERYONE will suffer from bad performance and settings not being saved, there are clearly a significant set of cards, etc, that actually have flickering and freezing problems from powermizer. That would be solved if it defaulted to off and could be changed later somehow. In any case, absent that it will be difficult for most people to fix once they are in that state where they can't even see or log in, and I would imagine there are not many who would even figure out that powermizer was the problem in the first place.
The nvidia-settings app is nvidia's, as is powermizer itself, so I see some of the passing of the buck there. However, there's no reason we can't do something about xorg.conf within Ubuntu.

Dave Haring (4trade) wrote :

I have screen flicker issue Ubuntu 11.04 and nvidia GTX 460M. Seems every time powermizer changes performance level I have screen flicker. Only choices in powermizer settings is "Adaptive" and "Prefer Maximum Performance". If I change to "Prefer Maximum Performance" there is no more flicker but setting does not hold. Each reboot must change setting again.

I tried adding "options nvidia NVreg_RegistryDwords="PerfLevelSrc=0x2222"" to modprobe.d but its not working.

Also tried adding similar line to modprobe.d which included the word "mobile" (something I found while searching) since I have ASUS G73Sw-A1 laptop but also not working.

Note I do not have "artifacts" condition as some other users - just a quick screen flicker...

Zane (zanetu) wrote :

A workaround I've found is adding the following line under 'Section "Device"' to /etc/X11/xorg.conf.
Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefault=0x1; PowerMizerDefaultAC=0x1"

You may need to restart your machine after that.

Hope it helps.

Reference:
http://tutanhamon.com.ua/technovodstvo/NVIDIA-UNIX-driver/

Zane (zanetu) wrote :

Mind you that setting the nvidia graphics card to Maximum Performance forcibly may lead to GPU overheating and consequently cause your system to freeze from time to time. So make sure you have a strong cooling system, and laptop users may consider cleaning the interior of the machine.

rifter (rifter0x0000) wrote :

@#25 Maximum performance is not an overclocked setting. I would expect overheating when overclocking. Not to say that Nvidia cards don't do that under normal speed, because the ones that don't do powermizer have for me in the past. However that only happens if you have insufficient cooling. Older cards basically require a slot fan because generally there is not enough airflow over them otherwise. I learned that the hard way long ago. I have a newer card now and it comes with a builtin slot fan, probably for this reason. Essentially what I am getting at is if you are having that kind of issue when under maximum performance, not overclocking the card, the problem is in your case setup/cooling solution, not in the powermizer setting, in which case you need to address that anyway.
I would prefer that powrmizer remember the setting you put in, then people in your situation could have it set to something else. I would notify Nvidia upstream but I never was able to discover a way to do so. Very frustrating.

Bryce Harrington (bryce) wrote :

Is this still unfixed in oneiric/precise?

affects: nvidia-graphics-drivers-180 (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Changed in nvidia-graphics-drivers (Ubuntu):
status: Triaged → Incomplete
ZelinskiyIS (ivze) wrote :

My experience shows that the bug IS present in Oneric. Moreover the bug with my particular GT220 video card has been reproduced with 3 different motherboards. It's the card that matters.

Turning powermizer off in xorg.conf has yet been the only solution found:
Section "Device"
 Identifier "NVIDIA GT220"
 Driver "nvidia"
 Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefault=0x1; PowerMizerDefaultAC=0x1"
EndSection

Alberto Milone (albertomilone) wrote :

I'll be happy to add a quirk for your specific card models. If you have a card which requires the following line:

Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefault=0x1; PowerMizerDefaultAC=0x1"

Please attach the output of the following command:

lspci -n | grep 300

01:00.0 0300: 10de:064c (rev a1)

thank you
e

On Mon, Aug 6, 2012 at 11:23 AM, Alberto Milone
<email address hidden> wrote:
> I'll be happy to add a quirk for your specific card models. If you have
> a card which requires the following line:
>
> Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222;
> PowerMizerDefault=0x1; PowerMizerDefaultAC=0x1"
>
> Please attach the output of the following command:
>
> lspci -n | grep 300
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/456637
>
> Title:
> Please consider turning powermizer OFF
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/456637/+subscriptions

ZelinskiyIS (ivze) wrote :

Alberto Milone (albertomilone): thank you for your attention!
That's the command output on my computer with a faulty NVidia card.

ivze@ivze-desktop:~$ lspci -n | grep 300
01:00.0 0300: 10de:0a20 (rev a2)

These are my specs:

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G86 [GeForce 8400M GT] [10de:0426] (rev a1) (prog-if 00 [VGA controller])

I have been using the above mentioned hack in xorg.conf for four years now since Karmic Koala - I almost forgot it's there!

I just wondering, why you doesn't report this PowerMizer issues to nVidia? 8400M is still supported, so they should fix this in newer builds of the driver.
http://nvidia.custhelp.com/app/ask

Launchpad Janitor (janitor) wrote :

[Expired for nvidia-graphics-drivers (Ubuntu) because there has been no activity for 60 days.]

Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → Expired
rifter (rifter0x0000) wrote :

The issue exists for *all* cards, including the newest, and in the newest drivers from nvidia. It doesn't remember the setting between reboots, either, which is very frustrating. And the only reason we did not report it to nvidia as I recall is we could find no means to do so.

rifter (rifter0x0000) wrote :

Oh and just in case ?I was not clear this affects the latest Ubuntu and the latest drivers. I don't see a way to indicate that but I believe we're still where we were before on this.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Expired → Incomplete
Changed in nvidia-graphics-drivers (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments