MASTER: nVidia doesn't support Xrandr so monitor resolution is wrong

Bug #273797 reported by Tobias Bradtke on 2008-09-24
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Wishlist
Unassigned

Bug Description

Description: Ubuntu intrepid (development branch)
Release: 8.10 (alpha-6)

[Problem]
gnome-display-properties uses Xrandr to set resolutions, however the proprietary nVidia driver doesn't implement Xrandr yet, and instead requires using its own configuration tool or editing xorg.conf.

Similarly, sometimes other client applications sometimes assume RANDR works universally and use it even on -nvidia. Various problems occur as a result.

[Original Report]
After installing Intrepid-alpha-6, the maximum resolution with 'gnome-display-properties' is 1024x786.

Resolution with Ubuntu Hardy was 1680x1050.

I could not find a way to change the maximum resolution. 'displayconfig' is obsolete. I will try to change xorg.conf, but is there an nicer way?

greetz!
webwurst

Timo Aaltonen (tjaalton) wrote :

How about attaching your /var/log/Xorg.0.log? I have no idea what hardware you have..

Changed in xorg:
status: New → Incomplete
Tobias Bradtke (webwurst) wrote :
Tobias Bradtke (webwurst) wrote :

with this lines added to my xorg.conf the resolution of 1680x1050 does work. with and without the nvidia-driver.

Bryce Harrington (bryce) on 2008-11-08
description: updated

The core issue here is that nVidia doesn't support Xrandr, which is what gnome-display-settings requires for doing what it does. nVidia's Xrandr support is fairly limited (just rotation iirc), so until that's improved you'll need to use either nvidia's own configuration tools or edit xorg.conf directly.

Changed in nvidia-graphics-drivers-177:
importance: Undecided → Wishlist
status: Incomplete → Triaged
Alan Lord (theopensourcerer) wrote :

I have had a problem with the nvidia drivers and my hardware ever since trying Intrepid at Alpha 5. So I reverted to the nv driver until yesterday. I thought I'd try again.

The problem is that I only get 1024x768 *every* time I reboot. Even if I use the nvidia-settings tool to change it to 1152x864 (which is better but the only other option I get is 1360x768). In the System->Preferences-Screen resolution, the only highest resolution offered is1024x768.

I have an Nvidia 9500Gt card and my Monitor (A Dell M991 CRT) is connected via a Belkin KVM on the VGA port. It seems that there is a problem detecting my monitor. Hardy (with an older Nvidia card [5200?]) used to work fine through the same KVM and with the same Monitor.

I've attached my Xorg.0.log.

If I can "fix" it by hand coding an xorg.conf that would be fine for now. But seeing how Intrepid seems to create a blank xorg.conf and gather all the needed data automatically I was unsure if my changes would be accepted or simply overwritten on each reboot. Suggestions gratefully accepted.

Bryce Harrington (bryce) wrote :

[This is an automated message]

In Jaunty (9.04), we have just updated to the latest
nvidia-graphics-drivers-180 package from nVidia, version 180.44.

This package provides fixes for a large number of bugs, and we need your
assistance in testing if it fixes the issue you reported.

To do this, please do the following:

 a. Update to the 180.44 version of -nvidia using your favorite update
     method

 b. Attempt to reproduce your bug

 c. If your bug still remains, please simply reply to this email
     indicating so.

 d. If your bug is now solved, you can help us by setting your bug
     report to Fix Released:
     * In launchpad, go to your bug report
     * Click on the downward pointing arrow under Status
     * Set the Status field to 'Fix Released'
     * Comment on the change, such as, 'Verified fixed in 180.44'
     * Click 'Save Changes'

 e. If the original problem is solved but there are now other problems,
     please close the original bug and open new ones for those issues.

Thank you!

For details on the changes in this version of -nvidia, please see:

   http://www.nvidia.com/object/linux_display_ia32_180.44.html

TRiSS (triss) wrote :

Tried it, this driver version still doesn't have full Xrandr support, so for this bug nothing changes.

Jonathan Thomas (echidnaman) wrote :

This feature probably won't be added for the -177 driver series, as it has been removed from distribution on our part.

Changed in nvidia-graphics-drivers-177 (Ubuntu):
status: New → Invalid
Bryce Harrington (bryce) on 2012-03-21
no longer affects: nvidia-graphics-drivers-177 (Ubuntu)
affects: nvidia-graphics-drivers-180 (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
tags: added: lucid precise
Bryce Harrington (bryce) on 2012-03-21
summary: - nVidia doesn't support Xrandr so monitor resolution is wrong
+ MASTER: nVidia doesn't support Xrandr so monitor resolution is wrong
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers