Recent update broke multiheaded sleep

Bug #1695141 reported by Barry Warsaw on 2017-06-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

I just dist-upgraded my Zesty machine and two things broke related to sleeping the displays. I have a 34" wide panel on the left and a 20" high resolution Dell on the right.

Everything works fine until the displays sleep, say after a lockscreen has started. First, the right screen never wakes from sleep; even though the lights on the front are green (indicating an active display), once the right display has slept, it never wakes back up even after a login.

Second, and probably related: all the windows that were on the right display are now shifted over to the left and full-screened.

This has all worked for a long time, but something in the recent stable updates has broken this, so it's a pretty serious regression. Nothing short of a reboot returns the dual screens to full functionality.

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: xorg 1:7.7+16ubuntu3
ProcVersionSignature: Ubuntu 4.10.0-21.23-generic 4.10.11
Uname: Linux 4.10.0-21-generic x86_64
NonfreeKernelModules: zfs zunicode zavl zcommon znvpair nvidia_uvm nvidia_drm nvidia_modeset nvidia
.proc.driver.nvidia.gpus.0000.01.00.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0000:01:00.0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 375.66 Mon May 1 15:29:16 PDT 2017
 GCC version: gcc version 6.3.0 20170406 (Ubuntu 6.3.0-12ubuntu2)
.tmp.unity_support_test.0:

ApportVersion: 2.20.4-0ubuntu4.1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity:Unity7
Date: Fri Jun 2 00:17:33 2017
DistUpgraded: Fresh install
DistroCodename: zesty
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.8, 4.10.0-20-generic, x86_64: installed
 bbswitch, 0.8, 4.10.0-21-generic, x86_64: installed
 nvidia-375, 375.66, 4.10.0-21-generic, x86_64: installed
EcryptfsInUse: Yes
ExtraDebuggingInterest: Yes
GraphicsCard:
 NVIDIA Corporation GK104 [GeForce GTX 760] [10de:1187] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Gigabyte Technology Co., Ltd GK104 [GeForce GTX 760] [1458:360b]
InstallationDate: Installed on 2016-01-22 (497 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160117)
MachineType: Gigabyte Technology Co., Ltd. Z170X-UD5
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-21-generic root=UUID=d03718f1-9983-4b07-a942-1b42fe8352ec ro
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/24/2015
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: F2
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: Z170X-UD5-CF
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrF2:bd07/24/2015:svnGigabyteTechnologyCo.,Ltd.:pnZ170X-UD5:pvrTobefilledbyO.E.M.:rvnGigabyteTechnologyCo.,Ltd.:rnZ170X-UD5-CF:rvrx.x:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: Z170X-UD5
dmi.product.version: To be filled by O.E.M.
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.13.1+17.04.20170109-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.76-1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.0.3-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 17.0.3-1ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.19.3-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.5-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.9.0-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20170309-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.14-0ubuntu1
xserver.bootTime: Thu Jun 1 23:54:29 2017
xserver.configfile: default
xserver.errors: open /dev/fb0: No such file or directory
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.19.3-1ubuntu1

Barry Warsaw (barry) wrote :
Barry Warsaw (barry) wrote :

% uname -a
Linux subdivisions 4.10.0-21-generic #23-Ubuntu SMP Fri Apr 28 16:14:22 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

FWIW, booting 4.10.0-20 hangs on boot so that's not a viable option.

Also, setting Brightness&Lock->Turn screen off when inactive for: Never
does not prevent Ubuntu from sleeping the displays (after progressive dimming) and thus causing the problem.

Timo Aaltonen (tjaalton) on 2017-06-02
affects: xorg (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Barry Warsaw (barry) wrote :

Confirmed that falling back to nvidia-graphics-drivers-375 375.39-0ubuntu5 fixes the problem.

Barry Warsaw (barry) wrote :

Has there been any updates to this in either the Zesty security channel or Artful? It's a pretty serious regression.

To post a comment you must log in.