low graphics mode due to possible race condition on precise

Bug #1275760 reported by Gordon Ball on 2014-02-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

Precise 12.04.4 x86_64, kernel 3.2.0-58-generic.

lspci reports:
01:00.0 VGA compatible controller: NVIDIA Corporation GF108GL [Quadro 600] (rev a1)

dpkg -l 'nvidia*' | grep '^ii' reports:
ii nvidia-304 304.116-0ubuntu0.0.1
ii nvidia-319-updates 331.20-0ubuntu0.0.1
ii nvidia-331-updates 331.20-0ubuntu0.0.1
ii nvidia-common 1:0.2.44.2
ii nvidia-current 304.116-0ubuntu0.0.1
ii nvidia-settings 331.20-0ubuntu0.0.1
ii nvidia-settings-304 331.20-0ubuntu0.0.1
ii nvidia-settings-319-updates 331.20-0ubuntu0.0.1

ii xorg 1:7.6+12ubuntu2

Since installation, this system has periodically fallen to the "running in low graphics mode" prompt on boot. This can always be resolved by logging into a TTY and restarting LightDM: sudo service lightdm restart. Recently (sorry I can't say precisely - probably the last month or so) the frequency of this event has increased to ~90% of boots.

Sample Xorg.0.log attached, but the key lines appear to be
[ 3.364] (EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module. Please see the
[ 3.364] (EE) NVIDIA(0): system's kernel log for additional error messages and
[ 3.364] (EE) NVIDIA(0): consult the NVIDIA README for details.
[ 3.364] (EE) NVIDIA(0): *** Aborting ***

While `dmesg | grep nvidia` shows
[ 2.737764] nvidia: module license 'NVIDIA' taints kernel.
[ 3.658332] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 3.658338] nvidia 0000:01:00.0: setting latency timer to 64

From the timestamps, it looks like Xorg attempts to load the nvidia drivers 300ms before the kernel has actually loaded/initialised them, and hence fails. This certainly looks like a race condition. By the time I log into a TTY, lsmod shows the `nvidia` module to be loaded and restarting lightdm succeeds.

Is there any way for either Xorg to check and if necessary wait for kernel module loading, or the low graphics dialog at least include a better option for dealing with this situation?

Gordon Ball (chronitis) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
Bernhard (baumber) wrote :

Hello,

I have the same problem with a Nvidia NVS300 (kernel 3.2.0-60-generic, nvidia driver 304.116) in my office-PC, mostly after a kernel update.
=> VGA compatible controller: NVIDIA Corporation GT218 [NVS 300] (rev a2)

It helps to reinstall all nvidia* packages; nvidia-common, nvidia-current, etc, but the error occurs occasionally again.

When I reboot the system after this error, the error comes again, sometimes only a shutdown, and then poweron helps.

In my home-PC I have a Nvidia GT 430 and I never had this problem. Maybe it is related to different hardware models, which initialize too slowly at startup?

Best regards, Bernhard

Bernhard (baumber) wrote :

I forgot to mention that I use Twinview with two monitors Samsung SMS24A450 with one DVI-connector on the card.

Bernhard (baumber) wrote :

I have added module nvidia to /etc/modules to ensure it will be loaded at boot time;

cat /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.
nvidia

and then update initramfs with "update-initramfs -uk all".

No problem so far after one week testing!

Bernhard (baumber) wrote :

Testing

Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → In Progress
Bernhard (baumber) wrote :

The problem didn't occur anymore!

Marked fixed by adding module nvidia to /etc/modules and "sudo update-initramfs -uk all".

Changed in nvidia-graphics-drivers (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments