Xorg crashed with SIGABRT in RRSetChanged() with nvidia-prime

Bug #1249551 reported by Michał Sawicz on 2013-11-09
184
This bug affects 21 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Medium
Unassigned
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

Enabling nvidia-prime results in this Xorg crash.

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: xserver-xorg-core 2:1.14.3-3ubuntu4
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
NonfreeKernelModules: nvidia wl
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 319.60 Wed Sep 25 14:28:26 PDT 2013
 GCC version: gcc version 4.8.2 (Ubuntu/Linaro 4.8.2-1ubuntu2)
ApportVersion: 2.12.6-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Sat Nov 9 09:46:54 2013
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
ExecutablePath: /usr/bin/Xorg
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0493]
 NVIDIA Corporation GF119M [NVS 4200M] [10de:1056] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:1493]
MachineType: Dell Inc. Latitude E6420
MarkForUpload: True
ProcCmdline: /usr/bin/X -core :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.11.0-12-generic root=/dev/mapper/michal--laptop-ubuntu--root ro splash quiet vt.handoff=7
Signal: 6
SourcePackage: nvidia-graphics-drivers
StacktraceTop:
 RRSetChanged ()
 RRScreenSetSizeRange ()
 xf86RandR12CreateScreenResources ()
 ?? ()
 ?? ()
Title: Xorg crashed with SIGABRT in RRSetChanged()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 07/11/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A14
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA14:bd07/11/2012:svnDellInc.:pnLatitudeE6420:pvr01:rvnDellInc.:rn:rvr:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E6420
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.46-4
version.libgl1-mesa-dri: libgl1-mesa-dri 9.2.2-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.2.2-1ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.14.3-3ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu10
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.904-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu1
xserver.bootTime: Sat Nov 9 09:47:29 2013
xserver.configfile: default
xserver.errors:
 Failed to load module "nvidia" (module does not exist, 0)
 Failed to load module "nvidia" (module does not exist, 0)
 [drm] KMS not enabled
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 12606
 vendor AUO
xserver.version: 2:1.14.3-3ubuntu4

Michał Sawicz (saviq) wrote :

This crash has the same stack trace characteristics as bug #1161797. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: added: regression-retracer

StacktraceTop:
 RRSetChanged (pScreen=<optimized out>) at ../../randr/randr.c:486
 RRScreenSetSizeRange (pScreen=pScreen@entry=0x7f439242be80, minWidth=<optimized out>, minHeight=<optimized out>, maxWidth=<optimized out>, maxHeight=<optimized out>) at ../../randr/rrinfo.c:228
 xf86RandR12CreateScreenResources12 (pScreen=0x7f439242be80) at ../../../../hw/xfree86/modes/xf86RandR12.c:1593
 xf86RandR12CreateScreenResources (pScreen=pScreen@entry=0x7f439242be80) at ../../../../hw/xfree86/modes/xf86RandR12.c:842
 xf86CrtcCreateScreenResources (screen=0x7f439242be80) at ../../../../hw/xfree86/modes/xf86Crtc.c:710

Changed in nvidia-graphics-drivers (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Michał Sawicz (saviq) on 2013-11-09
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
tags: added: utopic
tags: added: vivid
tags: added: bugpattern-needed
tags: added: wily
Daniel van Vugt (vanvugt) wrote :

Tracking in:
https://errors.ubuntu.com/problem/36eb0ae57099021d0345a5f2e4cd873c718acdfa

As there are zero reports of it in Ubuntu 17.10 and later we can call that Fix Released. Only unfortunate that we don't know what fixed it.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Fix Released
Changed in xorg-server (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.